aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-07-10 17:04:45 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-07-10 18:46:33 +0000
commit143072ff128f78f0c63639d6bc28f5d0081a5618 (patch)
treeb0a3164da7aa00d3b724f01f563a71ebc58d5247 /security/gpgme
parent1595d14911e55d7a8c9deb9771efd84220561bf6 (diff)
downloadports-143072ff128f78f0c63639d6bc28f5d0081a5618.tar.gz
ports-143072ff128f78f0c63639d6bc28f5d0081a5618.zip
security/*gpgme*: Update to 1.21.0
Split out the headers shared between the qt5 and qt6 flavors of security/gpgme-qt to security/gpgme-qt-headers so that they no longer conflict. https://dev.gnupg.org/T6585
Diffstat (limited to 'security/gpgme')
-rw-r--r--security/gpgme/Makefile31
-rw-r--r--security/gpgme/distinfo6
-rw-r--r--security/gpgme/pkg-plist2
3 files changed, 25 insertions, 14 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 7169cfc03799..fd7b18ee07d2 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gpgme
-PORTVERSION= 1.20.0
+PORTVERSION= 1.21.0
PORTREVISION?= 0
CATEGORIES?= security
MASTER_SITES= GNUPG/gpgme
@@ -18,7 +18,8 @@ USES= compiler:c11 cpe gmake libtool localbase:ldflags tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
+CFLAGS+= -Wno-suggest-override -Wno-unknown-warning-option
+INSTALL_TARGET?=install-strip
TEST_TARGET= check
CPE_VENDOR= gnu
@@ -54,7 +55,7 @@ BUILD_WRKSRC= ${WRKSRC}/lang/${BINDING_NAME}
INSTALL_WRKSRC= ${WRKSRC}/lang/${BINDING_NAME}
TEST_WRKSRC= ${WRKSRC}/lang/${BINDING_NAME}/tests
-. if ${SLAVEPORT} != "cpp"
+. if ${SLAVEPORT} != "cpp" && ${SLAVEPORT} != "qt-headers"
OPTIONS_DEFINE+= TEST
. endif
@@ -64,26 +65,32 @@ CONFIGURE_ARGS+=--enable-languages="cpp"
NO_TEST= yes
. endif
+. if ${SLAVEPORT} == "qt-headers"
+CONFIGURE_ARGS+=--enable-languages=""
+ALL_TARGET= all-am
+INSTALL_TARGET= install-data
+NO_TEST= yes
+. endif
+
. if ${SLAVEPORT} == "qt"
LIB_DEPENDS+= libgpgmepp.so:security/gpgme-cpp
+RUN_DEPENDS+= ${LOCALBASE}/include/qgpgme/qgpgme_version.h:security/gpgme-qt-headers
FLAVORS= qt5 qt6
FLAVOR?= ${FLAVORS:[1]}
qt5_PKGNAMESUFFIX= -qt5
qt6_PKGNAMESUFFIX= -qt6
-qt5_PLIST= ${.CURDIR}/pkg-plist.qt5
-qt6_PLIST= ${.CURDIR}/pkg-plist.qt6
-qt5_CONFLICTS_INSTALL= gpgme-qt6
-qt6_CONFLICTS_INSTALL= gpgme-qt5
. if ${FLAVOR:U} == "qt5"
USES+= compiler:c++11-lib pkgconfig qt:5
USE_QT= buildtools:build core
TEST_USE= QT=testlib:build
+PLIST_SUB= QT_SUFFIX="" qt_SUFFIX=""
. else
USES+= compiler:c++17-lang pkgconfig qt:6
USE_QT= base
USE_CXXSTD= c++17
+PLIST_SUB= QT_SUFFIX="Qt6" qt_SUFFIX="qt6"
. endif
CONFIGURE_ARGS+=--enable-languages="cpp ${FLAVOR}"
@@ -115,13 +122,17 @@ post-patch:
. if ${SLAVEPORT} == "qt"
@${FIND} ${BUILD_WRKSRC} -name "Makefile.in" -type f | ${XARGS} \
${REINPLACE_CMD} -e 's|../../cpp/src/libgpgmepp.la|-lgpgmepp|g'
+ @${REINPLACE_CMD} -e 's|install-exec-am install-data-am|install-exec-am install-data-local|' \
+ ${WRKSRC}/lang/qt/src/Makefile.in
+. endif
+. if ${SLAVEPORT} == "qt-headers"
+ @${REINPLACE_CMD} -e '/^all-am/s|$$(LTLIBRARIES)||' \
+ -e '/^install-data-am/s|install-data-local||' \
+ ${WRKSRC}/lang/qt/src/Makefile.in
. endif
.endif
@${REINPLACE_CMD} -e 's|^clfilesdir.*|clfilesdir=$$\(libdir\)/common-lisp/gpgme|g' \
${WRKSRC}/lang/cl/Makefile.in
- @${REINPLACE_CMD} -e 's|-Wsuggest-override||g' \
- ${WRKSRC}/lang/cpp/src/Makefile.in \
- ${WRKSRC}/lang/qt/src/Makefile.in
post-patch-DOXYGEN-off:
@${REINPLACE_CMD} -e '/SUBDIRS/s|doc||' \
diff --git a/security/gpgme/distinfo b/security/gpgme/distinfo
index 527c32d38147..6a1ca470392a 100644
--- a/security/gpgme/distinfo
+++ b/security/gpgme/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1683032158
-SHA256 (gpgme-1.20.0.tar.bz2) = 25a5785a5da356689001440926b94e967d02e13c49eb7743e35ef0cf22e42750
-SIZE (gpgme-1.20.0.tar.bz2) = 1817377
+TIMESTAMP = 1688831601
+SHA256 (gpgme-1.21.0.tar.bz2) = 416e174e165734d84806253f8c96bda2993fd07f258c3aad5f053a6efd463e88
+SIZE (gpgme-1.21.0.tar.bz2) = 1830113
diff --git a/security/gpgme/pkg-plist b/security/gpgme/pkg-plist
index 848a524b7fda..7477164b34fb 100644
--- a/security/gpgme/pkg-plist
+++ b/security/gpgme/pkg-plist
@@ -8,7 +8,7 @@ lib/common-lisp/gpgme/gpgme.asd
lib/common-lisp/gpgme/gpgme.lisp
lib/libgpgme.so
lib/libgpgme.so.11
-lib/libgpgme.so.11.29.0
+lib/libgpgme.so.11.30.0
libdata/pkgconfig/gpgme-glib.pc
libdata/pkgconfig/gpgme.pc
share/aclocal/gpgme.m4