aboutsummaryrefslogtreecommitdiff
path: root/security/knock
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2008-11-14 16:36:55 +0000
committerShaun Amott <shaun@FreeBSD.org>2008-11-14 16:36:55 +0000
commit95aad006b540e3425ab25113b321a4fed28d95ee (patch)
treed48b77626eca9899593e60452ae10975cfaede9d /security/knock
parent4e3ff8a4f6f8eae87ecab835981cd5edd5ee0b79 (diff)
downloadports-95aad006b540e3425ab25113b321a4fed28d95ee.tar.gz
ports-95aad006b540e3425ab25113b321a4fed28d95ee.zip
Increase pcap read timeout to reduce gratuitous CPU burden.
PR: ports/127313 Submitted by: Duane Wessels <wessels@life-gone-hazy.com>
Notes
Notes: svn path=/head/; revision=222847
Diffstat (limited to 'security/knock')
-rw-r--r--security/knock/Makefile1
-rw-r--r--security/knock/files/patch-src-knockd.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/knock/Makefile b/security/knock/Makefile
index 848a3c3f1742..eeffa47903e7 100644
--- a/security/knock/Makefile
+++ b/security/knock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= knock
PORTVERSION= 0.5.20051124
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/security/knock/files/patch-src-knockd.c b/security/knock/files/patch-src-knockd.c
new file mode 100644
index 000000000000..4132b3835619
--- /dev/null
+++ b/security/knock/files/patch-src-knockd.c
@@ -0,0 +1,11 @@
+--- src/knockd.c.orig 2008-11-14 16:32:31.000000000 +0000
++++ src/knockd.c 2008-11-14 16:33:22.000000000 +0000
+@@ -200,7 +200,7 @@
+ }
+
+ #if defined(__FreeBSD__) || defined(__APPLE__)
+- cap = pcap_open_live(o_int, 65535, 0, 1, pcapErr);
++ cap = pcap_open_live(o_int, 65535, 0, 1000, pcapErr);
+ #else
+ cap = pcap_open_live(o_int, 65535, 0, 0, pcapErr);
+ #endif