aboutsummaryrefslogtreecommitdiff
path: root/security/nextcloud-end_to_end_encryption/Makefile
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2023-01-14 19:30:14 +0000
committerBernard Spil <brnrd@FreeBSD.org>2023-01-14 19:30:14 +0000
commit4784a824f3164ddfe15b1b52a06a7b6273a048ff (patch)
tree91d86e36821bdba2a91a69c3790671a230c5ea9e /security/nextcloud-end_to_end_encryption/Makefile
parent0f63b7fec4d06588b49635bab46da189ab2b4668 (diff)
downloadports-4784a824f3164ddfe15b1b52a06a7b6273a048ff.tar.gz
ports-4784a824f3164ddfe15b1b52a06a7b6273a048ff.zip
Mk/Uses/nextcloud.mk: Introduce USES= nextcloud
* Simplify's port creation for Nextcloud apps * Convert existing ports to USES= nextcloud
Diffstat (limited to 'security/nextcloud-end_to_end_encryption/Makefile')
-rw-r--r--security/nextcloud-end_to_end_encryption/Makefile22
1 files changed, 2 insertions, 20 deletions
diff --git a/security/nextcloud-end_to_end_encryption/Makefile b/security/nextcloud-end_to_end_encryption/Makefile
index deacd72c2cd5..32df7e8b20ed 100644
--- a/security/nextcloud-end_to_end_encryption/Makefile
+++ b/security/nextcloud-end_to_end_encryption/Makefile
@@ -2,33 +2,15 @@ PORTNAME= end_to_end_encryption
PORTVERSION= 1.11.1
DISTVERSIONPREFIX= v
CATEGORIES= security
-MASTER_SITES= https://github.com/${PKGNAMEPREFIX}releases/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
-PKGNAMEPREFIX= nextcloud-
-PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
-DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}
MAINTAINER= brnrd@freebsd.org
COMMENT= End-to-End Encryption app for Nextcloud
WWW= https://apps.nextcloud.com/apps/end_to_end_encryption
-LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=24:www/nextcloud@${PHP_FLAVOR}
+NEXTCLOUD_RUN_DEPENDS= 24
-USES= php:flavors
-IGNORE_WITH_PHP= 82
-NO_BUILD= yes
-NO_ARCH= yes
-
-WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-do-install:
- ${MKDIR} ${STAGEDIR}${WWWDIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
- ${RM} ${STAGEDIR}${WWWDIR}/COPYING
- @(cd ${WRKSRC}; ${FIND} . -not -type d) | ${SORT} | \
- ${SED} -e 's,^\.,${WWWDIR_REL},' >> ${TMPPLIST}
+USES= nextcloud php:flavors
.include <bsd.port.mk>