aboutsummaryrefslogtreecommitdiff
path: root/security/nextcloud-end_to_end_encryption/Makefile
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2020-08-22 12:07:45 +0000
committerBernard Spil <brnrd@FreeBSD.org>2020-08-22 12:07:45 +0000
commitacf0ce9015f22d46664f9026f3f2c9a0a28ca90e (patch)
tree71b7ab0ab7f669ee8a5cb0db7e4bf0550fb32af2 /security/nextcloud-end_to_end_encryption/Makefile
parentf63e8ec482a7d4c84b7639140fe053ec365de649 (diff)
downloadports-acf0ce9015f22d46664f9026f3f2c9a0a28ca90e.tar.gz
ports-acf0ce9015f22d46664f9026f3f2c9a0a28ca90e.zip
security/nextcloud-end_to_end_encryption: Add new port
* No longer marked pre-production
Notes
Notes: svn path=/head/; revision=545761
Diffstat (limited to 'security/nextcloud-end_to_end_encryption/Makefile')
-rw-r--r--security/nextcloud-end_to_end_encryption/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/nextcloud-end_to_end_encryption/Makefile b/security/nextcloud-end_to_end_encryption/Makefile
new file mode 100644
index 000000000000..a33431178281
--- /dev/null
+++ b/security/nextcloud-end_to_end_encryption/Makefile
@@ -0,0 +1,34 @@
+# Created by: Bernard Spil <brnrd@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= end_to_end_encryption
+PORTVERSION= 1.5.2
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+MASTER_SITES= https://github.com/${PKGNAMEPREFIX:S/-//}/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}
+
+MAINTAINER= brnrd@freebsd.org
+COMMENT= End-to-End Encryption app for Nextcloud
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=19:www/nextcloud@${PHP_FLAVOR}
+
+USES= php:flavors
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+ ${RM} ${STAGEDIR}${WWWDIR}/COPYING
+
+.include <bsd.port.mk>