aboutsummaryrefslogtreecommitdiff
path: root/security/putty
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-05-13 13:16:18 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-05-13 13:16:18 +0000
commit45cb65076faa822cbd51b2f809a81a48d18e87e1 (patch)
treedb488a197190f2e515318e5c3f884b0700300317 /security/putty
parenta149359059447b87c8c61bc29ecd9dfacb6432fc (diff)
downloadports-45cb65076faa822cbd51b2f809a81a48d18e87e1.tar.gz
ports-45cb65076faa822cbd51b2f809a81a48d18e87e1.zip
security/putty: install icon and .desktop file
PR: 219095 Submitted by: ehaupt@
Notes
Notes: svn path=/head/; revision=440836
Diffstat (limited to 'security/putty')
-rw-r--r--security/putty/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 9c37de968389..2e0693b40a3d 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -2,6 +2,7 @@
PORTNAME= putty
PORTVERSION= 0.69
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/${PORTVERSION}/ \
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
@@ -39,7 +40,14 @@ USE_XORG= x11
PLIST_FILES+= bin/pageant bin/pterm bin/putty bin/puttytel
PLIST_FILES+= man/man1/pageant.1.gz man/man1/pterm.1.gz man/man1/putty.1.gz man/man1/puttytel.1.gz
+PLIST_FILES+= share/pixmaps/putty.ico
MAKE_ARGS+= PUTTY_WITH_GTK=yes GTK_CONFIG="pkg-config gtk+-3.0 x11 --cflags"
+DESKTOP_ENTRIES="PuTTY" \
+ "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "${PORTNAME}" \
+ "" \
+ false
.else
MAKE_ARGS+= GTK_CONFIG=:
.endif
@@ -73,4 +81,9 @@ post-patch:
s,make,${MAKE_CMD},'\
${WRKSRC}/${MAKEFILE}
+post-install-GTK3-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/../windows/putty.ico \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
.include <bsd.port.mk>