aboutsummaryrefslogtreecommitdiff
path: root/security/putty
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-06-28 13:55:46 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-06-28 13:55:46 +0000
commit8afe3cfa90ebe55ecf0e8d34920c8796ea5ddb09 (patch)
treeeee2b0b3e6f895eb5c13068a46604079b9fcb63a /security/putty
parentd7af2c86ac87c03624812d7f4978ec98164bc673 (diff)
downloadports-8afe3cfa90ebe55ecf0e8d34920c8796ea5ddb09.tar.gz
ports-8afe3cfa90ebe55ecf0e8d34920c8796ea5ddb09.zip
security/putty*: upgrade to 0.74 security fix release
Changelog: https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html among them are these two---and more bugfixes beyond not listed here: * Security fix: if an SSH server accepted an offer of a public key and then rejected the signature, PuTTY could access freed memory, if the key had come from an SSH agent. * Security feature: new config option to disable PuTTY's dynamic host key preference policy, if you prefer to avoid giving away to eavesdroppers which hosts you have stored keys for. MFH: 2020Q2 Security: 6190c0cd-b945-11ea-9401-2dcf562daa69 Security: CVE-2020-14002 Security: FZI-2020-5
Notes
Notes: svn path=/head/; revision=540716
Diffstat (limited to 'security/putty')
-rw-r--r--security/putty/Makefile75
-rw-r--r--security/putty/distinfo6
2 files changed, 48 insertions, 33 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index aee477d1cd10..a50b6d318a43 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= putty
-PORTVERSION= 0.73
+PORTVERSION= 0.74
CATEGORIES= security
MASTER_SITES= http://the.earth.li/~sgtatham/putty/${PORTVERSION}/ \
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
@@ -14,27 +14,34 @@ LICENSE= MIT
LICENSE_FILE= ${FILESDIR}/LICENSE
USES= cpe gmake pkgconfig
+CPE_VENDOR= simon_tatham
-WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
MAKEFILE= Makefile.gtk
-CPE_VENDOR= simon_tatham
-
-PLIST_FILES= bin/plink bin/pscp bin/psftp bin/puttygen
-PLIST_FILES+= man/man1/plink.1.gz man/man1/pscp.1.gz man/man1/psftp.1.gz man/man1/puttygen.1.gz
+CONFLICTS_INSTALL?= pssh-[0-9]* putty-gtk2-[0-9]* putty-nogtk-[0-9]*
-OPTIONS_RADIO= TOOLKIT
-OPTIONS_RADIO_TOOLKIT= GTK2 GTK3
-OPTIONS_DEFAULT=GSSAPI_BASE GTK3
-OPTIONS_SINGLE= GSSAPI_SELECT
-OPTIONS_SINGLE_GSSAPI_SELECT= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-CONFLICTS_INSTALL?= pssh-[0-9]* putty-gtk2-[0-9]* putty-nogtk-[0-9]*
+PLIST_FILES= bin/plink \
+ bin/pscp \
+ bin/psftp \
+ bin/puttygen \
+ man/man1/plink.1.gz \
+ man/man1/pscp.1.gz \
+ man/man1/psftp.1.gz \
+ man/man1/puttygen.1.gz
+
+OPTIONS_DEFAULT= GSSAPI_BASE GTK3
+OPTIONS_RADIO= TOOLKIT
+OPTIONS_RADIO_TOOLKIT= GTK2 GTK3
+OPTIONS_SINGLE= GSSAPI_SELECT
+OPTIONS_SINGLE_GSSAPI_SELECT= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL \
+ GSSAPI_MIT
.include <bsd.port.options.mk>
-CFLAGS+= -DBSD_PTYS -DOMIT_UTMP -DIPV6 -DHAVE_FUTIMES
+CFLAGS+= -DBSD_PTYS -DHAVE_FUTIMES -DIPV6 -DOMIT_UTMP
LDFLAGS+= -Wl,--as-needed
.if (${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3}) && !defined(WITHOUT_X11)
@@ -43,23 +50,31 @@ USE_XORG= x11
.if ${PORT_OPTIONS:MGTK2}
USES+= gnome
USE_GNOME= cairo gdkpixbuf2 gtk20
-MAKE_ARGS+= PUTTY_WITH_GTK=yes GTK_CONFIG="pkg-config gtk+-2.0 x11 --cflags"
+MAKE_ARGS+= GTK_CONFIG="pkg-config gtk+-2.0 x11 --cflags" \
+ PUTTY_WITH_GTK=yes
.endif
.if ${PORT_OPTIONS:MGTK3}
USES+= gnome
USE_GNOME= cairo gdkpixbuf2 gtk30
-MAKE_ARGS+= PUTTY_WITH_GTK=yes GTK_CONFIG="pkg-config gtk+-3.0 x11 --cflags"
+MAKE_ARGS+= GTK_CONFIG="pkg-config gtk+-3.0 x11 --cflags" \
+ PUTTY_WITH_GTK=yes
.endif
-PLIST_FILES+= bin/pageant bin/pterm bin/putty bin/puttytel
-PLIST_FILES+= man/man1/pageant.1.gz man/man1/pterm.1.gz man/man1/putty.1.gz man/man1/puttytel.1.gz
-PLIST_FILES+= share/pixmaps/putty.ico
-DESKTOP_ENTRIES="PuTTY" \
- "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
- "${PORTNAME}" \
- "" \
- false
+PLIST_FILES+= bin/pageant \
+ bin/pterm \
+ bin/putty \
+ bin/puttytel \
+ man/man1/pageant.1.gz \
+ man/man1/pterm.1.gz \
+ man/man1/putty.1.gz \
+ man/man1/puttytel.1.gz \
+ share/pixmaps/putty.ico
+DESKTOP_ENTRIES= "PuTTY" \
+ "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "${PORTNAME}" \
+ "" \
+ false
.else
MAKE_ARGS+= GTK_CONFIG=:
.endif
@@ -74,7 +89,7 @@ MAKE_ARGS+= KRB5CONFIG=${KRB5CONFIG}
USES+= gssapi:mit,flags
MAKE_ARGS+= KRB5CONFIG=${KRB5CONFIG}
.else
-_COMPAT= -DNO_GSSAPI
+_COMPAT= -DNO_GSSAPI
.endif
_COMPAT+= -DOMIT_UTMP
@@ -89,11 +104,11 @@ _COMPAT+= -DDEBUG
# currently, but override it nonetheless.
XFLAGS+= -Wno-error
-MAKE_ARGS+= COMPAT="${_COMPAT}" \
- CC="${CC}" \
- XFLAGS="${XFLAGS}" \
+MAKE_ARGS+= CC="${CC}" \
+ COMPAT="${_COMPAT}" \
INSTALL_DATA="${INSTALL_DATA}" \
- INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ XFLAGS="${XFLAGS}"
post-patch:
@${REINPLACE_CMD} -e 's,prefix=/usr/local,prefix=${PREFIX},;\
diff --git a/security/putty/distinfo b/security/putty/distinfo
index 633eddf1dd3c..38abd861e222 100644
--- a/security/putty/distinfo
+++ b/security/putty/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1571412224
-SHA256 (putty-0.73.tar.gz) = 3db0b5403fb41aecd3aa506611366650d927650b6eb3d839ad4dcc782519df1c
-SIZE (putty-0.73.tar.gz) = 2459115
+TIMESTAMP = 1593350227
+SHA256 (putty-0.74.tar.gz) = ddd5d388e51dd9e6e294005b30037f6ae802239a44c9dc9808c779e6d11b847d
+SIZE (putty-0.74.tar.gz) = 2476513