aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-04-25 06:41:26 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-04-29 06:34:22 +0000
commitf9c6c779d5d0f98f7e11b7fac8d0ab7aef7d6858 (patch)
tree96bd6b99b7f2484b42e8f6fe6367ccf2eb671963 /sysutils
parente199513d74a5585e71a2aa278fc495f1ce3c41fe (diff)
downloadports-f9c6c779d5d0f98f7e11b7fac8d0ab7aef7d6858.tar.gz
ports-f9c6c779d5d0f98f7e11b7fac8d0ab7aef7d6858.zip
sysutils/conky{-awesome}: update to 0.120.2
ChangeLog: https://github.com/brndnmtthws/conky/releases/tag/v1.20.2 Features * Separate cairo-xlib.h Lua bindings from cairo.h * Cleanup build flags, global namespace and includes * Use perfect hash (gperf) for parsing color names * set_struts improvements Bug fixes * Fix imlib_cache_size_setting::lua_setter Miscellaneous * Bump version * Annoyingly, the artifacts go into a subdir * Always run Nix & AppImage builds on PRs * Track more context labels * Fix matrix URL * Revert "Fix matrix URL" * Fix web components and pages (UI)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/conky/Makefile8
-rw-r--r--sysutils/conky/distinfo6
-rw-r--r--sysutils/conky/files/patch-lua_CMakeLists.txt16
-rw-r--r--sysutils/conky/files/patch-src_display-x11.cc6
-rw-r--r--sysutils/conky/files/patch-src_x11.h16
5 files changed, 19 insertions, 33 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 241bb9031ebb..349b704907b7 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -1,5 +1,5 @@
PORTNAME= conky
-PORTVERSION= 1.20.1
+PORTVERSION= 1.20.2
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
@@ -10,7 +10,8 @@ WWW= https://github.com/brndnmtthws/conky
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-BUILD_DEPENDS= gsed:textproc/gsed
+BUILD_DEPENDS= gperf:devel/gperf \
+ gsed:textproc/gsed
LIB_DEPENDS= libinotify.so:devel/libinotify
USES= cmake compiler:c++11-lib cpe gettext-runtime iconv \
@@ -76,7 +77,8 @@ LUA_CAIRO_IMPLIES= X11
LUA_CAIRO_USES= gnome
LUA_CAIRO_USE= GNOME=cairo
LUA_CAIRO_CMAKE_BOOL= BUILD_LUA_CAIRO
-LUA_CAIRO_PLIST_FILES= lib/conky/libcairo.so
+LUA_CAIRO_PLIST_FILES= lib/conky/libcairo.so \
+ lib/conky/libcairo_xlib.so
LUA_IMLIB2_IMPLIES= IMLIB2 X11
LUA_IMLIB2_CMAKE_BOOL= BUILD_LUA_IMLIB2
diff --git a/sysutils/conky/distinfo b/sysutils/conky/distinfo
index 50efb30b9efe..fd80db491a5a 100644
--- a/sysutils/conky/distinfo
+++ b/sysutils/conky/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1713443191
-SHA256 (brndnmtthws-conky-v1.20.1_GH0.tar.gz) = 5e0531d1bbb589ee2369876340c341073d3bc13f8a79c05f89ec6170d6374085
-SIZE (brndnmtthws-conky-v1.20.1_GH0.tar.gz) = 1839204
+TIMESTAMP = 1714027251
+SHA256 (brndnmtthws-conky-v1.20.2_GH0.tar.gz) = 16f2e17d35252c1c3b97363016ede5cd68be719c32a51961420fcd46859bf503
+SIZE (brndnmtthws-conky-v1.20.2_GH0.tar.gz) = 1837320
diff --git a/sysutils/conky/files/patch-lua_CMakeLists.txt b/sysutils/conky/files/patch-lua_CMakeLists.txt
index 16473e5f4093..72858b2abd11 100644
--- a/sysutils/conky/files/patch-lua_CMakeLists.txt
+++ b/sysutils/conky/files/patch-lua_CMakeLists.txt
@@ -1,11 +1,11 @@
---- lua/CMakeLists.txt.orig 2024-04-17 02:04:14 UTC
+--- lua/CMakeLists.txt.orig 2024-04-24 13:56:28 UTC
+++ lua/CMakeLists.txt
-@@ -30,6 +30,8 @@ if(BUILD_X11)
- get_filename_component(X11_SM_LIB_PATH ${X11_SM_LIB} DIRECTORY)
- link_directories(${X11_SM_LIB_PATH})
+@@ -28,6 +28,8 @@ if(BUILD_LUA_CAIRO)
+ if(BUILD_LUA_CAIRO)
+ include_directories(${luacairo_includes} ${CMAKE_CURRENT_SOURCE_DIR})
-+ link_directories(${LIBS})
++ link_directories(${LIBS})
+
- # cairo_set_dash() needs this special hack to work properly if you have a
- # better solution, please let me know
- wrap_tolua(luacairo_src cairo.pkg libcairo.patch)
+ # cairo_set_dash() needs this special hack to work properly if you have a
+ # better solution, please let me know
+ wrap_tolua(luacairo_src cairo.pkg libcairo.patch)
diff --git a/sysutils/conky/files/patch-src_display-x11.cc b/sysutils/conky/files/patch-src_display-x11.cc
index 6daaa35ff2d6..e98b4f3e347a 100644
--- a/sysutils/conky/files/patch-src_display-x11.cc
+++ b/sysutils/conky/files/patch-src_display-x11.cc
@@ -1,6 +1,6 @@
---- src/display-x11.cc.orig 2024-04-17 02:04:14 UTC
+--- src/display-x11.cc.orig 2024-04-24 13:56:28 UTC
+++ src/display-x11.cc
-@@ -762,7 +762,9 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
+@@ -683,7 +683,9 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
conky::display_output_x11 *surface, Display *display, XEvent &ev,
bool *consumed, void **cookie) {
if (ev.type != EnterNotify && ev.type != LeaveNotify) return false;
@@ -10,7 +10,7 @@
bool not_over_conky = ev.xcrossing.x_root <= window.x ||
ev.xcrossing.y_root <= window.y ||
-@@ -771,11 +773,13 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
+@@ -692,11 +694,13 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
if ((not_over_conky && ev.xcrossing.type == LeaveNotify) ||
(!not_over_conky && ev.xcrossing.type == EnterNotify)) {
diff --git a/sysutils/conky/files/patch-src_x11.h b/sysutils/conky/files/patch-src_x11.h
deleted file mode 100644
index 24e397f56352..000000000000
--- a/sysutils/conky/files/patch-src_x11.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/x11.h.orig 2024-04-17 02:04:14 UTC
-+++ src/x11.h
-@@ -22,6 +22,7 @@
- *
- */
-
-+#ifdef BUILD_X11
- #pragma once
-
- #include "config.h"
-@@ -246,3 +247,5 @@ extern priv::use_xpmdb_setting use_xpmdb;
- #else
- extern priv::use_xpmdb_setting use_xpmdb;
- #endif
-+
-+#endif /* BUILD_X11 */