aboutsummaryrefslogtreecommitdiff
path: root/textproc/datamash
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-24 13:13:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-24 13:13:44 +0000
commit0d0cc42cce60602761ef3abcad99cdbcb16cadd5 (patch)
tree0e74cd82b3a7a2ec493bd9fe46c3efc12f89b89f /textproc/datamash
parentd0c5002911f355978f248fe8a7ea7826b4726c74 (diff)
downloadports-0d0cc42cce60602761ef3abcad99cdbcb16cadd5.tar.gz
ports-0d0cc42cce60602761ef3abcad99cdbcb16cadd5.zip
Install the usual set of documentation files.
Notes
Notes: svn path=/head/; revision=496722
Diffstat (limited to 'textproc/datamash')
-rw-r--r--textproc/datamash/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/textproc/datamash/Makefile b/textproc/datamash/Makefile
index 6341ae751143..f253a51f48ac 100644
--- a/textproc/datamash/Makefile
+++ b/textproc/datamash/Makefile
@@ -15,8 +15,9 @@ USES= gmake
GNU_CONFIGURE= yes
INFO= ${PORTNAME}
+PORTDOCS= AUTHORS ChangeLog NEWS README THANKS TODO
-OPTIONS_DEFINE= EXAMPLES NLS
+OPTIONS_DEFINE= DOCS EXAMPLES NLS
OPTIONS_SUB= yes
NLS_USES= gettext-runtime
@@ -26,4 +27,8 @@ post-patch:
@${REINPLACE_CMD} -e '/^examplesdir/s,$$(.*,${EXAMPLESDIR},' \
${WRKSRC}/Makefile.in
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>