aboutsummaryrefslogtreecommitdiff
path: root/www/nghttp2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-06-13 15:48:42 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-06-13 15:48:42 +0000
commit41ab376cb06f3fe3f0341ea5106a0628da208a37 (patch)
tree04ff68d823c9a3810f7aeb5bf910532700edc12d /www/nghttp2
parent86d12f46fea3eeda0da0332c1da22a3e3f366d9a (diff)
downloadports-41ab376cb06f3fe3f0341ea5106a0628da208a37.tar.gz
ports-41ab376cb06f3fe3f0341ea5106a0628da208a37.zip
Update to 1.39.1
Notes
Notes: svn path=/head/; revision=504104
Diffstat (limited to 'www/nghttp2')
-rw-r--r--www/nghttp2/Makefile2
-rw-r--r--www/nghttp2/distinfo8
-rw-r--r--www/nghttp2/files/patch-src-asio_server_connection.h35
3 files changed, 4 insertions, 41 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 2ce237292d07..54e7dafc10d8 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nghttp2
-PORTVERSION= 1.38.0
+PORTVERSION= 1.39.1
DISTVERSIONPREFIX= v
CATEGORIES= www net
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index 8c1537a88258..e33be3651067 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1555604318
-SHA256 (nghttp2-nghttp2-v1.38.0_GH0.tar.gz) = 3d5f1642e571470bb23a2a58b3d26ea9612c4e65195b99e55fc76999d3a9d306
-SIZE (nghttp2-nghttp2-v1.38.0_GH0.tar.gz) = 1770767
-SHA256 (cbba1ebf8fce.patch) = 3ea8be7174759810bdc6108e80d301ce7fa6b18c822a1f87b5741b247c2bb673
-SIZE (cbba1ebf8fce.patch) = 1950
+TIMESTAMP = 1560418062
+SHA256 (nghttp2-nghttp2-v1.39.1_GH0.tar.gz) = 4eca2520da3a80cf01d8abb8e6483f70229b9f4e0c9b6dbdd67435c655526d66
+SIZE (nghttp2-nghttp2-v1.39.1_GH0.tar.gz) = 1748667
diff --git a/www/nghttp2/files/patch-src-asio_server_connection.h b/www/nghttp2/files/patch-src-asio_server_connection.h
deleted file mode 100644
index cb5336a9fce0..000000000000
--- a/www/nghttp2/files/patch-src-asio_server_connection.h
+++ /dev/null
@@ -1,35 +0,0 @@
-Obtained from: https://github.com/nghttp2/nghttp2/commit/cbba1ebf8fcecb24392f0cc07b1235b17d0de9d8
-
---- src/asio_server_connection.h.orig 2019-04-18 06:08:36 UTC
-+++ src/asio_server_connection.h
-@@ -51,6 +51,12 @@
- #include "util.h"
- #include "template.h"
-
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- namespace nghttp2 {
-
- namespace asio_http2 {
-@@ -71,7 +77,7 @@ public:
- SocketArgs &&... args)
- : socket_(std::forward<SocketArgs>(args)...),
- mux_(mux),
-- deadline_(socket_.get_io_service()),
-+ deadline_(GET_IO_SERVICE(socket_)),
- tls_handshake_timeout_(tls_handshake_timeout),
- read_timeout_(read_timeout),
- writing_(false),
-@@ -82,7 +88,7 @@ public:
- boost::system::error_code ec;
-
- handler_ = std::make_shared<http2_handler>(
-- socket_.get_io_service(), socket_.lowest_layer().remote_endpoint(ec),
-+ GET_IO_SERVICE(socket_), socket_.lowest_layer().remote_endpoint(ec),
- [this]() { do_write(); }, mux_);
- if (handler_->start() != 0) {
- stop();