aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-rendition
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-02-11 14:17:58 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-02-11 14:17:58 +0000
commit3f87b5cb51a9164076426ff318d5d77c12b0ced3 (patch)
treef850017ca906c1f973d599485b77a7dceb60e2fc /x11-drivers/xf86-video-rendition
parentce75c0657853608ceeaeda9f2d28dc0d2c634129 (diff)
downloadports-3f87b5cb51a9164076426ff318d5d77c12b0ced3.tar.gz
ports-3f87b5cb51a9164076426ff318d5d77c12b0ced3.zip
Xorg-servers update to 1.18.4 with driver updates and revision bumps.
Update xf86-video-ati to 7.8.0 Update xf86-video-intel to 2.99.917.20170103 Update xf86-input-synaptics to 1.9.0 Update xf86-input-evdev to 2.10.5 Update xf86-video-r128 to 6.10.2 Update xf86-video-rendition to 4.2.6 New port: xf86-video-geode PR: 214591,216269,214687,214593,214715,216276,216277,216278,216287, 216288,216292,216298,214560,216299,216300,216301,216302 Approved by: swills (mentor, portmgr) Differential Revision: https://reviews.freebsd.org/D9436
Notes
Notes: svn path=/head/; revision=433863
Diffstat (limited to 'x11-drivers/xf86-video-rendition')
-rw-r--r--x11-drivers/xf86-video-rendition/Makefile3
-rw-r--r--x11-drivers/xf86-video-rendition/distinfo5
-rw-r--r--x11-drivers/xf86-video-rendition/files/patch-src_rendition.c64
-rw-r--r--x11-drivers/xf86-video-rendition/files/patch-src_rendition.h31
4 files changed, 17 insertions, 86 deletions
diff --git a/x11-drivers/xf86-video-rendition/Makefile b/x11-drivers/xf86-video-rendition/Makefile
index 15949523f523..da39b93a2cdd 100644
--- a/x11-drivers/xf86-video-rendition/Makefile
+++ b/x11-drivers/xf86-video-rendition/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-rendition
-PORTVERSION= 4.2.5
-PORTREVISION= 7
+PORTVERSION= 4.2.6
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-rendition/distinfo b/x11-drivers/xf86-video-rendition/distinfo
index 86861706d499..5e6f5fafa856 100644
--- a/x11-drivers/xf86-video-rendition/distinfo
+++ b/x11-drivers/xf86-video-rendition/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xorg/driver/xf86-video-rendition-4.2.5.tar.bz2) = 39b5569338237de6e17b2a2c6be73ac6c405ee596079c41a7028cfd6e54134cb
-SIZE (xorg/driver/xf86-video-rendition-4.2.5.tar.bz2) = 356351
+TIMESTAMP = 1480082861
+SHA256 (xorg/driver/xf86-video-rendition-4.2.6.tar.bz2) = 660ecf21f65a4d6002c1b603d62c314f8e9624d208db5b346850b0df9dc2f9a8
+SIZE (xorg/driver/xf86-video-rendition-4.2.6.tar.bz2) = 362408
diff --git a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c b/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c
index 5d5bb0047117..580cf5cd75d7 100644
--- a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c
+++ b/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c
@@ -1,51 +1,13 @@
---- src/rendition.c.orig 2015-10-11 22:31:51.242126000 +0200
-+++ src/rendition.c 2015-10-11 22:32:20.465605000 +0200
-@@ -1173,7 +1173,6 @@ renditionScreenInit(SCREEN_INIT_ARGS_DEC
- fbPictureInit (pScreen, 0, 0);
-
- xf86SetBlackWhitePixels(pScreen);
-- miInitializeBackingStore(pScreen);
-
- /*********************************************************/
- /* The actual setup of the driver-specific code */
-@@ -1372,6 +1371,18 @@ renditionMapMem(ScrnInfoPtr pScreenInfo)
- /* Override on users request */
- WriteCombine
- = xf86ReturnOptValBool(pRendition->Options, OPTION_FBWC, WriteCombine);
-+#ifdef XSERVER_LIBPCIACCESS
-+ mapOption = PCI_DEV_MAP_FLAG_WRITABLE;
-+ if (WriteCombine)
-+ mapOption |= PCI_DEV_MAP_FLAG_WRITE_COMBINE;
-+
-+ err = pci_device_map_range(pRendition->PciInfo,
-+ pRendition->PciInfo->regions[0].base_addr,
-+ pRendition->PciInfo->regions[0].size,
-+ mapOption, (void *)&pRendition->board.vmem_base);
-+
-+ return (err == 0);
-+#else
- if (WriteCombine) {
- xf86DrvMsg(pScreenInfo->scrnIndex, X_CONFIG,
- ("Requesting Write-Combined memory access\n"));
-@@ -1382,12 +1393,6 @@ renditionMapMem(ScrnInfoPtr pScreenInfo)
- mapOption = VIDMEM_MMIO;
- }
-
--#ifdef XSERVER_LIBPCIACCESS
-- err = pci_device_map_region(pRendition->PciInfo, 0, TRUE);
-- pRendition->board.vmem_base = pRendition->PciInfo->regions[0].memory;
--
-- return (err == 0);
--#else
- pRendition->board.vmem_base=
- xf86MapPciMem(pScreenInfo->scrnIndex, mapOption,
- pRendition->pcitag,
-@@ -1416,7 +1421,7 @@ renditionUnmapMem(ScrnInfoPtr pScreenInf
- #else
- pci_device_unmap_range(pRendition->PciInfo,
- pRendition->board.vmem_base,
-- pScreenInfo->videoRam * 1024);
-+ pRendition->PciInfo->regions[0].size);
- #endif
- return TRUE;
- #ifdef DEBUG0
+# Correct a string that should be const
+#
+--- src/rendition.c.orig 2014-09-30 14:21:44 UTC
++++ src/rendition.c
+@@ -480,7 +480,7 @@ renditionPreInit(ScrnInfoPtr pScreenInfo
+ MessageType From;
+ int videoRam, Rounding, nModes = 0;
+ renditionPtr pRendition;
+- char *in_string;
++ const char *in_string;
+ vgaHWPtr pvgaHW;
+
+ #ifdef DEBUG
diff --git a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.h b/x11-drivers/xf86-video-rendition/files/patch-src_rendition.h
deleted file mode 100644
index 75a5fa411b62..000000000000
--- a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.h
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/rendition.h.orig 2015-10-11 22:31:54.085176000 +0200
-+++ src/rendition.h 2015-10-11 22:32:12.657760000 +0200
-@@ -14,9 +14,6 @@
- /* Everything using inb/outb, etc needs "compiler.h" */
- #include "compiler.h"
-
--/* Drivers for PCI hardware need this */
--#include "xf86PciInfo.h"
--
- /* Drivers that need to access the PCI config space directly need this */
- #include "xf86Pci.h"
-
-@@ -28,9 +25,6 @@
- /* All drivers initialising the SW cursor need this */
- #include "mipointer.h"
-
--/* All drivers implementing backing store need this */
--#include "mibstore.h"
--
- /* All drivers using the mi colormap manipulation need this */
- #include "micmap.h"
-
-@@ -69,4 +63,8 @@
-
- #include "compat-api.h"
- /* end of __RENDITION_H__ */
-+
-+#define PCI_CHIP_V1000 0x0001
-+#define PCI_CHIP_V2x00 0x2000
-+
- #endif