aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 15:10:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 15:10:30 +0000
commitc8a7efc906021b3a78f3a5490ff019f8714a775a (patch)
treee6e8a81e70e801c330358ae6abbd6999f02a8cb4 /x11-fonts
parentd2f706c81e43a0f9195acb53bbb676940d5abcaa (diff)
downloadports-c8a7efc906021b3a78f3a5490ff019f8714a775a.tar.gz
ports-c8a7efc906021b3a78f3a5490ff019f8714a775a.zip
x11-fonts/noto-sans-extra: Add noto-sans-extra 2.013
When text is rendered by a computer, sometimes characters are displayed as "tofu". They are little boxes to indicate your device doesn't have a font to display the text. Google has been developing a font family called Noto, which aims to support all languages with a harmonious look and feel. Noto is Google's answer to tofu. The name noto is to convey the idea that Google's goal is to see no more "tofu". Noto has multiple styles and weights, and is freely available to all. The comprehensive set of fonts and tools used in our development is available in our GitHub repositories. This port provides the extra fonts set of Noto Sans.
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/noto-sans-extra/Makefile34
-rw-r--r--x11-fonts/noto-sans-extra/distinfo3
-rw-r--r--x11-fonts/noto-sans-extra/pkg-descr12
-rw-r--r--x11-fonts/noto-sans-extra/pkg-plist68
5 files changed, 118 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 532cab5c0afe..d2bfe1d3c468 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -203,6 +203,7 @@
SUBDIR += noto-sans-cherokee
SUBDIR += noto-sans-devanagari
SUBDIR += noto-sans-ethiopic
+ SUBDIR += noto-sans-extra
SUBDIR += noto-sans-hk
SUBDIR += noto-sans-jp
SUBDIR += noto-sans-kr
diff --git a/x11-fonts/noto-sans-extra/Makefile b/x11-fonts/noto-sans-extra/Makefile
new file mode 100644
index 000000000000..21bfbaa37eba
--- /dev/null
+++ b/x11-fonts/noto-sans-extra/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= noto
+PORTVERSION= 2.013
+CATEGORIES= x11-fonts
+MASTER_SITES= https://github.com/notofonts/latin-greek-cyrillic/releases/download/NotoSans-v${PORTVERSION}/
+PKGNAMESUFFIX= -sans-extra
+DISTNAME= NotoSans-v${PORTVERSION}
+DIST_SUBDIR= Noto
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Noto Sans (Extra)
+WWW= https://fonts.google.com/noto \
+ https://notofonts.github.io/ \
+ https://github.com/notofonts/latin-greek-cyrillic
+
+LICENSE= OFL11
+LICENSE_FILE= ${WRKSRC}/OFL.txt
+
+USES= fonts zip
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+post-patch:
+ @${RM} ${WRKSRC}/NotoSans/hinted/ttf/NotoSans-Bold.ttf
+ @${RM} ${WRKSRC}/NotoSans/hinted/ttf/NotoSans-BoldItalic.ttf
+ @${RM} ${WRKSRC}/NotoSans/hinted/ttf/NotoSans-Italic.ttf
+ @${RM} ${WRKSRC}/NotoSans/hinted/ttf/NotoSans-Regular.ttf
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NotoSans/hinted/ttf/*.ttf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/noto-sans-extra/distinfo b/x11-fonts/noto-sans-extra/distinfo
new file mode 100644
index 000000000000..511be29dd377
--- /dev/null
+++ b/x11-fonts/noto-sans-extra/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1710676063
+SHA256 (Noto/NotoSans-v2.013.zip) = 9fd595dd701d7ea103a9ba8a9cfdcf0c35c5574ef754fecabe718eadad8bccde
+SIZE (Noto/NotoSans-v2.013.zip) = 124008613
diff --git a/x11-fonts/noto-sans-extra/pkg-descr b/x11-fonts/noto-sans-extra/pkg-descr
new file mode 100644
index 000000000000..57ce3f1bda11
--- /dev/null
+++ b/x11-fonts/noto-sans-extra/pkg-descr
@@ -0,0 +1,12 @@
+When text is rendered by a computer, sometimes characters are displayed as
+"tofu". They are little boxes to indicate your device doesn't have a font to
+display the text.
+
+Google has been developing a font family called Noto, which aims to support all
+languages with a harmonious look and feel. Noto is Google's answer to tofu. The
+name noto is to convey the idea that Google's goal is to see no more "tofu".
+Noto has multiple styles and weights, and is freely available to all. The
+comprehensive set of fonts and tools used in our development is available in our
+GitHub repositories.
+
+This port provides the extra fonts set of Noto Sans.
diff --git a/x11-fonts/noto-sans-extra/pkg-plist b/x11-fonts/noto-sans-extra/pkg-plist
new file mode 100644
index 000000000000..4ea68fd00243
--- /dev/null
+++ b/x11-fonts/noto-sans-extra/pkg-plist
@@ -0,0 +1,68 @@
+%%FONTSDIR%%/NotoSans-Black.ttf
+%%FONTSDIR%%/NotoSans-BlackItalic.ttf
+%%FONTSDIR%%/NotoSans-Condensed.ttf
+%%FONTSDIR%%/NotoSans-CondensedBlack.ttf
+%%FONTSDIR%%/NotoSans-CondensedBlackItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedBold.ttf
+%%FONTSDIR%%/NotoSans-CondensedBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedExtraBold.ttf
+%%FONTSDIR%%/NotoSans-CondensedExtraBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedExtraLight.ttf
+%%FONTSDIR%%/NotoSans-CondensedExtraLightItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedLight.ttf
+%%FONTSDIR%%/NotoSans-CondensedLightItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedMedium.ttf
+%%FONTSDIR%%/NotoSans-CondensedMediumItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedSemiBold.ttf
+%%FONTSDIR%%/NotoSans-CondensedSemiBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-CondensedThin.ttf
+%%FONTSDIR%%/NotoSans-CondensedThinItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraBold.ttf
+%%FONTSDIR%%/NotoSans-ExtraBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensed.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedBlack.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedBlackItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedBold.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedExtraBold.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedExtraBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedExtraLight.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedExtraLightItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedLight.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedLightItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedMedium.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedMediumItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedSemiBold.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedSemiBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedThin.ttf
+%%FONTSDIR%%/NotoSans-ExtraCondensedThinItalic.ttf
+%%FONTSDIR%%/NotoSans-ExtraLight.ttf
+%%FONTSDIR%%/NotoSans-ExtraLightItalic.ttf
+%%FONTSDIR%%/NotoSans-Light.ttf
+%%FONTSDIR%%/NotoSans-LightItalic.ttf
+%%FONTSDIR%%/NotoSans-Medium.ttf
+%%FONTSDIR%%/NotoSans-MediumItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiBold.ttf
+%%FONTSDIR%%/NotoSans-SemiBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensed.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedBlack.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedBlackItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedBold.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedExtraBold.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedExtraBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedExtraLight.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedExtraLightItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedLight.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedLightItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedMedium.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedMediumItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedSemiBold.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedSemiBoldItalic.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedThin.ttf
+%%FONTSDIR%%/NotoSans-SemiCondensedThinItalic.ttf
+%%FONTSDIR%%/NotoSans-Thin.ttf
+%%FONTSDIR%%/NotoSans-ThinItalic.ttf