aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Tk-DKW
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-17 11:19:54 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-17 11:19:54 +0000
commit84fdb891149917c475dd30935a736aa74e834bb8 (patch)
tree89c665494c291762eb42448d8d6fb8643976d2c6 /x11-toolkits/p5-Tk-DKW
parent404e62e8c13e3b6090f8fa69dd095f62cfc46242 (diff)
downloadports-84fdb891149917c475dd30935a736aa74e834bb8.tar.gz
ports-84fdb891149917c475dd30935a736aa74e834bb8.zip
Add port x11-toolkits/p5-Tk-DKW:
Tk::CheckBox - A radio button style widget that uses a check mark in a box. Useful as a boolean field. Tk::Columns - A multicolumn list widget with resizeable borders and sorting by column. Tk::ComboEntry - A Drop down listbox + entry widget with nice keyboard equivalent behaviour Tk::IconCanvas - A canvas implementing a moveable iconic interface. Allows attaching menus to icons and to background. Tk::SplitFrame - A sliding separator for two child widgets. Allows either horizontal or vertical separation between the two widgets. Can work in concert as horizontal inside vertical or vice-versa. Tk::TabFrame - A tabbed frame geometry manager (like NoteBook). Tk::DockFrame - A dockable widget management widget hierarchy. Tk::CornerBox - A textured window resizing widget (like in Win95) Tk::Signals - A publish and subscribe object signalling method like that found in QT. Very useful when widgets that are not in the same hierarchy need to alert each other to various application level events. WWW: http://search.cpan.org/dist/Tk-DKW/ Author: Damion K. Wilson <dkw@rcm.bm>
Notes
Notes: svn path=/head/; revision=190178
Diffstat (limited to 'x11-toolkits/p5-Tk-DKW')
-rw-r--r--x11-toolkits/p5-Tk-DKW/Makefile31
-rw-r--r--x11-toolkits/p5-Tk-DKW/distinfo3
-rw-r--r--x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL13
-rw-r--r--x11-toolkits/p5-Tk-DKW/pkg-descr22
-rw-r--r--x11-toolkits/p5-Tk-DKW/pkg-plist18
5 files changed, 87 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Tk-DKW/Makefile b/x11-toolkits/p5-Tk-DKW/Makefile
new file mode 100644
index 000000000000..eea3320787d7
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Tk-DKW
+# Date created: 16 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-DKW
+PORTVERSION= 0.03
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Collection of Tk widgets
+
+BUILD_DEPENDS= p5-Tk>=804:${PORTSDIR}/x11-toolkits/p5-Tk \
+ p5-Tk-Contrib>=0.07:${PORTSDIR}/x11-toolkits/p5-Tk-Contrib
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+DKW_MODULES= CheckBox Columns ComboEntry CornerBox DockFrame IconCanvas\
+ Menustrip ProgressIndicator SplitFrame TabFrame TabbedForm\
+ TableEdit
+MAN3= ${DKW_MODULES:S/^/Tk::/:S/$/.3/}
+
+post-extract:
+ @${MV} ${WRKSRC}/Tk/* ${WRKSRC}/
+ @${RMDIR} ${WRKSRC}/Tk/
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Tk-DKW/distinfo b/x11-toolkits/p5-Tk-DKW/distinfo
new file mode 100644
index 000000000000..264608b8c035
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tk-DKW-0.03.tar.gz) = 01fb09c497cbeff373d743ae7b8388f0
+SHA256 (Tk-DKW-0.03.tar.gz) = 5fede6f2f476ebcbdae868a3a33708d99824980f46c234d0f06cee70e81f22ab
+SIZE (Tk-DKW-0.03.tar.gz) = 50997
diff --git a/x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL b/x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL
new file mode 100644
index 000000000000..c756cae1b989
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/files/patch-Makefile.PL
@@ -0,0 +1,13 @@
+--- ./Makefile.PL.orig Tue Apr 17 13:19:53 2007
++++ ./Makefile.PL Tue Apr 17 13:20:16 2007
+@@ -23,8 +23,8 @@
+
+ PMLIBDIRS => ['Tk'],
+ DISTNAME => 'Tk-DKW',
+- VERSION => '0.02',
+- NAME => 'Tk',
++ VERSION => '0.03',
++ NAME => 'Tk::DKW',
+
+ 'dist' =>
+ {
diff --git a/x11-toolkits/p5-Tk-DKW/pkg-descr b/x11-toolkits/p5-Tk-DKW/pkg-descr
new file mode 100644
index 000000000000..bac0066e0178
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/pkg-descr
@@ -0,0 +1,22 @@
+Tk::CheckBox - A radio button style widget that uses a
+ check mark in a box. Useful as a boolean field.
+Tk::Columns - A multicolumn list widget with resizeable borders
+ and sorting by column.
+Tk::ComboEntry - A Drop down listbox + entry widget with nice keyboard
+ equivalent behaviour
+Tk::IconCanvas - A canvas implementing a moveable iconic interface.
+ Allows attaching menus to icons and to background.
+Tk::SplitFrame - A sliding separator for two child widgets. Allows either
+ horizontal or vertical separation between the two widgets.
+ Can work in concert as horizontal inside vertical or
+ vice-versa.
+Tk::TabFrame - A tabbed frame geometry manager (like NoteBook).
+Tk::DockFrame - A dockable widget management widget hierarchy.
+Tk::CornerBox - A textured window resizing widget (like in Win95)
+Tk::Signals - A publish and subscribe object signalling method like
+ that found in QT. Very useful when widgets that are not
+ in the same hierarchy need to alert each other to various
+ application level events.
+
+WWW: http://search.cpan.org/dist/Tk-DKW/
+Author: Damion K. Wilson <dkw@rcm.bm>
diff --git a/x11-toolkits/p5-Tk-DKW/pkg-plist b/x11-toolkits/p5-Tk-DKW/pkg-plist
new file mode 100644
index 000000000000..5f85d970f278
--- /dev/null
+++ b/x11-toolkits/p5-Tk-DKW/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/DKW/.packlist
+%%SITE_PERL%%/Tk/CheckBox.pm
+%%SITE_PERL%%/Tk/ChildNotification.pm
+%%SITE_PERL%%/Tk/Columns.pm
+%%SITE_PERL%%/Tk/ComboEntry.pm
+%%SITE_PERL%%/Tk/CornerBox.pm
+%%SITE_PERL%%/Tk/DockFrame.pm
+%%SITE_PERL%%/Tk/IconCanvas.pm
+%%SITE_PERL%%/Tk/Menustrip.pm
+%%SITE_PERL%%/Tk/ProgressIndicator.pm
+%%SITE_PERL%%/Tk/Signals.pm
+%%SITE_PERL%%/Tk/SplitFrame.pm
+%%SITE_PERL%%/Tk/TabFrame.pm
+%%SITE_PERL%%/Tk/TabbedForm.pm
+%%SITE_PERL%%/Tk/TableEdit.pm
+@dirrmtry %%SITE_PERL%%/Tk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/DKW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk