aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-05-01 22:40:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-05-01 22:47:44 +0000
commit9a6f7b2304952eeadd05429289adfddd3bafa3a8 (patch)
tree454f771872b1e63ee40efa51c837a0a5425051d0 /x11
parentc7106d659f48942c4f4b26dc4aa8e840750a162d (diff)
downloadports-9a6f7b2304952eeadd05429289adfddd3bafa3a8.tar.gz
ports-9a6f7b2304952eeadd05429289adfddd3bafa3a8.zip
x11/waybar: restore 5d35e5882352 after c8720b3105e2
Missed FreeBSD 13.3 (libc++ 17) as 13.2 (libc++ 14) isn't EOL until 2024-07-01 thus not covered by pkg-fallout@ yet.
Diffstat (limited to 'x11')
-rw-r--r--x11/waybar/Makefile20
-rw-r--r--x11/waybar/distinfo2
2 files changed, 22 insertions, 0 deletions
diff --git a/x11/waybar/Makefile b/x11/waybar/Makefile
index 6392729061d9..c712d5c24634 100644
--- a/x11/waybar/Makefile
+++ b/x11/waybar/Makefile
@@ -172,4 +172,24 @@ pre-test:
${TOUCH} ${WRKDIR}/.meson_build_tests; \
fi
+# XXX Drop after FreeBSD 13.3 EOL around 2025-07-01 (don't forget distinfo)
+.if ${CXX} == c++ && exists(/usr/include/c++/v1/__chrono/concepts.h) && \
+ !exists(/usr/include/c++/v1/__chrono/tzdb.h) || make(makesum) || make(fetch)
+USES+= cmake:indirect
+CMAKE_ARGS= -B ${WRKDIR}/libcxx_build -S ${WRKSRC_libcxx}/libcxx
+CMAKE_OFF= LIBCXX_INCLUDE_BENCHMARKS
+CMAKE_INSTALL_PREFIX= ${WRKDIR}/libcxx_prefix
+
+# XXX Move into separate port and standardize via USES
+GH_TUPLE+= llvm:llvm-project:llvmorg-16.0.1:libcxx
+CXXFLAGS+= -nostdinc++ -isystem${WRKDIR}/libcxx_prefix/include/c++/v1
+# Don't link against new libc++ as it's not necessary
+#LDFLAGS+= -nostdlib++ -L${WRKDIR}/libcxx_prefix/lib -l:libc++.a -lcxxrt
+
+pre-configure: bundled-libcxx
+bundled-libcxx:
+ @${SETENVI} ${WRK_ENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS}
+ @${DO_MAKE_BUILD:NDESTDIR*} install -C ${WRKDIR}/libcxx_build
+.endif # exists(/usr/include/c++/v1/__chrono/concepts.h)
+
.include <bsd.port.mk>
diff --git a/x11/waybar/distinfo b/x11/waybar/distinfo
index 209213bd424c..db7e8b7db044 100644
--- a/x11/waybar/distinfo
+++ b/x11/waybar/distinfo
@@ -1,6 +1,8 @@
TIMESTAMP = 1713887948
SHA256 (Alexays-Waybar-0.10.2_GH0.tar.gz) = 7ecccfe5d326d66987a32e77e02b825019d191670ab8e87412df01dd0913f9c0
SIZE (Alexays-Waybar-0.10.2_GH0.tar.gz) = 301414
+SHA256 (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = b5a9ff1793b1e2d388a3819bf35797002b1d2e40bb35a10c65605e0ea1435271
+SIZE (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = 179289803
SHA256 (f41458ea24a5.patch) = a125479cf8bf9b57306f8cd3df9fc969e43ddd797abd56a61f9328ba5877634c
SIZE (f41458ea24a5.patch) = 2490
SHA256 (67de082393dc.patch) = 71da4a4b2577f9a08555187151fc532b57a137f5de45622861e1307f70fffc3b