aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES15
-rw-r--r--Mk/Uses/shebangfix.mk12
2 files changed, 25 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 2b480a4bf76a..f91e8a2d46ca 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,21 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20151022:
+AUTHOR: amdmi3@FreeBSD.org
+
+ Improved support for USES=shebangfix
+
+ - We now support multiple values for *_OLD_CMD
+ - We replace more variants by default (/bin/${lang}, /usr/bin/${lang},
+ /usr/bin/env ${lang}).
+ - shebangfix now also supports lua if USES=lua is specified
+ - Pattern matching has been improved: we now only match whole worlds,
+ e.g. "/usr/bin/perl5.005" is no longer erroneously replaced with
+ "${perl_CMD}5.005".
+
+ Note that *_OLD_CMD entries which contain spaces must now be quoted.
+
20150928:
AUTHOR: amdmi3@FreeBSD.org
diff --git a/Mk/Uses/shebangfix.mk b/Mk/Uses/shebangfix.mk
index d98e52eaf85d..520cec286c90 100644
--- a/Mk/Uses/shebangfix.mk
+++ b/Mk/Uses/shebangfix.mk
@@ -13,6 +13,11 @@
#
# SHEBANG_FILES= path1/file path2/*.pl
#
+# To define custom shebangs to replace, use the following (note that
+# shebangs with spaces should be quoted):
+#
+# perl_OLD_CMD= /usr/bin/perl5.005 "/usr/bin/setenv perl5.005"
+#
# To define a new shebang scheme add the following to the port Makefile:
#
# SHEBANG_LANG= lua
@@ -36,8 +41,11 @@ SHEBANG_LANG+= lua
lua_CMD?= ${LOCALBASE}/bin/${LUA_CMD}
.endif
-tcl_CMD?= ${TCLSH}
-tk_CMD?= ${WISH}
+tcl_OLD_CMD+= /usr/bin/tclsh
+tcl_CMD?= ${TCLSH}
+
+tk_OLD_CMD+= /usr/bin/wish
+tk_CMD?= ${WISH}
.if ${USES:Mpython*}
python_CMD?= ${PYTHON_CMD}