aboutsummaryrefslogtreecommitdiff
path: root/astro/stellarium/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'astro/stellarium/files/patch-CMakeLists.txt')
-rw-r--r--astro/stellarium/files/patch-CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/astro/stellarium/files/patch-CMakeLists.txt b/astro/stellarium/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e59fd7f54490
--- /dev/null
+++ b/astro/stellarium/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2024-03-25 08:21:03 UTC
++++ CMakeLists.txt
+@@ -1040,9 +1040,9 @@ ENDIF()
+
+ include("cmake/Check-from_chars.cmake")
+ IF(NOT FROM_CHARS_WORKS)
+- CPMFindPackage(NAME fast_float
++ CPMFindPackage(NAME FastFloat
+ GIT_REPOSITORY https://github.com/fastfloat/fast_float
+- VERSION 6.1.0
++ VERSION 6
+ EXCLUDE_FROM_ALL yes)
+ GET_TARGET_PROPERTY(fast_float_INCLUDE_DIRECTORIES
+ FastFloat::fast_float INTERFACE_INCLUDE_DIRECTORIES)