aboutsummaryrefslogtreecommitdiff
path: root/audio/flacon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/flacon/Makefile')
-rw-r--r--audio/flacon/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/audio/flacon/Makefile b/audio/flacon/Makefile
index f0bb110e2cc1..b7e1633e2a15 100644
--- a/audio/flacon/Makefile
+++ b/audio/flacon/Makefile
@@ -1,5 +1,5 @@
PORTNAME= flacon
-PORTVERSION= 11.1.0
+PORTVERSION= 11.3.0
DISTVERSIONPREFIX= v
CATEGORIES= audio
@@ -9,6 +9,8 @@ WWW= https://flacon.github.io/
LICENSE= LGPL21+
+# XXX: yaml-cpp is needed for tests/flacon_test program only
+BUILD_DEPENDS= ${LOCALBASE}/include/yaml-cpp/yaml.h:devel/yaml-cpp
LIB_DEPENDS= libtag.so:audio/taglib \
libuchardet.so:textproc/uchardet
TEST_DEPENDS= alacenc:audio/alacenc \
@@ -28,5 +30,6 @@ CMAKE_ARGS= -DBUILD_TESTS:BOOL=YES
do-test:
@cd ${TEST_WRKSRC} && LC_ALL=C.UTF-8 ctest -C ${CMAKE_BUILD_TYPE} \
${_MAKE_JOBS}
+ @${CAT} ${TEST_WRKSRC}/Testing/Temporary/LastTest.log
.include <bsd.port.mk>