aboutsummaryrefslogtreecommitdiff
path: root/audio/libmysofa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/libmysofa/Makefile')
-rw-r--r--audio/libmysofa/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/audio/libmysofa/Makefile b/audio/libmysofa/Makefile
index 0ca80667c266..716b11100250 100644
--- a/audio/libmysofa/Makefile
+++ b/audio/libmysofa/Makefile
@@ -13,12 +13,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= node:www/node
USES= cmake cpe pathfix
-USE_LDCONFIG= yes
-
CPE_VENDOR= symonics
-
USE_GITHUB= yes
GH_ACCOUNT= hoene
+USE_LDCONFIG= yes
+
+EXTRACT_AFTER_ARGS= --exclude ${PORTNAME}-${DISTVERSION}/tests \
+ --exclude ${PORTNAME}-${DISTVERSION}/windows \
+ --no-same-owner --no-same-permissions
OPTIONS_DEFINE= STATIC TEST
OPTIONS_DEFAULT= STATIC
@@ -29,12 +31,17 @@ STATIC_CMAKE_BOOL= BUILD_STATIC_LIBS
TEST_BUILD_DEPENDS= cunit>0:devel/cunit
TEST_CMAKE_BOOL= BUILD_TESTS
TEST_TEST_TARGET= test
+TEST_EXTRA_PATCHES= ${PATCHDIR}/extrapatch-tests_compare.sh \
+ ${PATCHDIR}/extrapatch-tests_compareIgnoreNew.sh
# The tests are expected to be in ../tests relative to the build
# directory and the build results are expected to be in build/ relative
# to ${WRKSRC}. USES=cmake does not allow overwriting ${WRKDIR}/.build
# as the build directory.
-post-patch:
+post-extract-TEST-on:
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
+ -C ${WRKDIR} --include ${PORTNAME}-${DISTVERSION}/tests \
+ --no-same-owner --no-same-permissions
@${RLN} ${WRKSRC}/build ${CONFIGURE_WRKSRC}
.include <bsd.port.mk>