aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/hyperfine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/hyperfine/Makefile')
-rw-r--r--benchmarks/hyperfine/Makefile135
1 files changed, 65 insertions, 70 deletions
diff --git a/benchmarks/hyperfine/Makefile b/benchmarks/hyperfine/Makefile
index 211348cf06db..f99761444449 100644
--- a/benchmarks/hyperfine/Makefile
+++ b/benchmarks/hyperfine/Makefile
@@ -1,7 +1,7 @@
PORTNAME= hyperfine
DISTVERSIONPREFIX= v
-DISTVERSION= 1.17.0
-PORTREVISION= 7
+DISTVERSION= 1.18.0
+PORTREVISION= 1
CATEGORIES= benchmarks
MAINTAINER= pizzamig@FreeBSD.org
@@ -21,69 +21,68 @@ PLIST_FILES= bin/hyperfine
CARGO_CRATES= ahash-0.7.6 \
ahash-0.8.3 \
- aho-corasick-1.0.1 \
- anstream-0.3.2 \
- anstyle-1.0.0 \
- anstyle-parse-0.2.0 \
+ aho-corasick-1.1.1 \
+ anstream-0.6.4 \
+ anstyle-1.0.4 \
+ anstyle-parse-0.2.2 \
anstyle-query-1.0.0 \
- anstyle-wincon-1.0.1 \
- anyhow-1.0.71 \
+ anstyle-wincon-3.0.1 \
+ anyhow-1.0.75 \
approx-0.5.1 \
- arrayvec-0.7.2 \
- assert_cmd-2.0.11 \
+ arrayvec-0.7.4 \
+ assert_cmd-2.0.12 \
atty-0.2.14 \
autocfg-0.1.8 \
autocfg-1.1.0 \
bitflags-1.3.2 \
+ bitflags-2.4.0 \
bitvec-1.0.1 \
borsh-0.10.3 \
borsh-derive-0.10.3 \
borsh-derive-internal-0.10.3 \
borsh-schema-derive-internal-0.10.3 \
- bstr-1.5.0 \
+ bstr-1.6.2 \
bytecheck-0.6.11 \
bytecheck_derive-0.6.11 \
- byteorder-1.4.3 \
- bytes-1.4.0 \
- cc-1.0.79 \
+ bytes-1.5.0 \
+ cc-1.0.83 \
cfg-if-1.0.0 \
- clap-4.3.1 \
- clap_builder-4.3.1 \
- clap_complete-4.3.1 \
- clap_lex-0.5.0 \
+ clap-4.4.6 \
+ clap_builder-4.4.6 \
+ clap_complete-4.4.3 \
+ clap_lex-0.5.1 \
cloudabi-0.0.3 \
colorchoice-1.0.0 \
- colored-2.0.0 \
+ colored-2.0.4 \
console-0.15.7 \
- csv-1.2.2 \
- csv-core-0.1.10 \
+ csv-1.3.0 \
+ csv-core-0.1.11 \
difflib-0.4.0 \
doc-comment-0.3.3 \
- either-1.8.1 \
+ either-1.9.0 \
encode_unicode-0.3.6 \
- errno-0.3.1 \
+ errno-0.3.4 \
errno-dragonfly-0.1.2 \
- fastrand-1.9.0 \
+ fastrand-2.0.1 \
float-cmp-0.9.0 \
fuchsia-cprng-0.1.1 \
funty-2.0.0 \
- getrandom-0.2.9 \
+ getrandom-0.2.10 \
hashbrown-0.12.3 \
hashbrown-0.13.2 \
hermit-abi-0.1.19 \
- hermit-abi-0.3.1 \
+ hermit-abi-0.3.3 \
indicatif-0.17.4 \
instant-0.1.12 \
- io-lifetimes-1.0.11 \
- is-terminal-0.4.7 \
- itertools-0.10.5 \
- itoa-1.0.6 \
+ is-terminal-0.4.9 \
+ itertools-0.11.0 \
+ itoa-1.0.9 \
lazy_static-1.4.0 \
- libc-0.2.144 \
- linux-raw-sys-0.3.8 \
- memchr-2.5.0 \
+ libc-0.2.148 \
+ linux-raw-sys-0.4.8 \
+ memchr-2.6.4 \
memoffset-0.7.1 \
- nix-0.26.2 \
+ nix-0.26.4 \
normalize-line-endings-0.3.0 \
num-0.2.1 \
num-bigint-0.2.6 \
@@ -91,20 +90,20 @@ CARGO_CRATES= ahash-0.7.6 \
num-integer-0.1.45 \
num-iter-0.1.43 \
num-rational-0.2.4 \
- num-traits-0.2.15 \
+ num-traits-0.2.16 \
number_prefix-0.4.0 \
- once_cell-1.17.2 \
+ once_cell-1.18.0 \
pin-utils-0.1.0 \
- portable-atomic-1.3.3 \
+ portable-atomic-1.4.3 \
ppv-lite86-0.2.17 \
- predicates-3.0.3 \
+ predicates-3.0.4 \
predicates-core-1.0.6 \
predicates-tree-1.0.9 \
proc-macro-crate-0.1.5 \
- proc-macro2-1.0.59 \
+ proc-macro2-1.0.67 \
ptr_meta-0.1.4 \
ptr_meta_derive-0.1.4 \
- quote-1.0.28 \
+ quote-1.0.33 \
radium-0.7.0 \
rand-0.6.5 \
rand-0.8.5 \
@@ -121,39 +120,38 @@ CARGO_CRATES= ahash-0.7.6 \
rand_xorshift-0.1.1 \
rdrand-0.4.0 \
redox_syscall-0.3.5 \
- regex-1.8.3 \
- regex-automata-0.1.10 \
- regex-syntax-0.7.2 \
- rend-0.4.0 \
+ regex-1.9.6 \
+ regex-automata-0.3.9 \
+ regex-syntax-0.7.5 \
+ rend-0.4.1 \
rkyv-0.7.42 \
rkyv_derive-0.7.42 \
- rust_decimal-1.29.1 \
- rustix-0.37.19 \
- ryu-1.0.13 \
+ rust_decimal-1.32.0 \
+ rustix-0.38.17 \
+ ryu-1.0.15 \
seahash-4.1.0 \
- serde-1.0.163 \
- serde_derive-1.0.163 \
- serde_json-1.0.96 \
+ serde-1.0.188 \
+ serde_derive-1.0.188 \
+ serde_json-1.0.107 \
shell-words-1.1.0 \
simdutf8-0.1.4 \
- static_assertions-1.1.0 \
statistical-1.0.0 \
strsim-0.10.0 \
syn-1.0.109 \
- syn-2.0.18 \
+ syn-2.0.37 \
tap-1.0.1 \
- tempfile-3.5.0 \
- terminal_size-0.2.6 \
+ tempfile-3.8.0 \
+ terminal_size-0.3.0 \
termtree-0.4.1 \
- thiserror-1.0.40 \
- thiserror-impl-1.0.40 \
+ thiserror-1.0.49 \
+ thiserror-impl-1.0.49 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
toml-0.5.11 \
- unicode-ident-1.0.9 \
- unicode-width-0.1.10 \
+ unicode-ident-1.0.12 \
+ unicode-width-0.1.11 \
utf8parse-0.2.1 \
- uuid-1.3.3 \
+ uuid-1.4.1 \
version_check-0.9.4 \
wait-timeout-0.2.0 \
wasi-0.11.0+wasi-snapshot-preview1 \
@@ -163,24 +161,21 @@ CARGO_CRATES= ahash-0.7.6 \
windows-sys-0.45.0 \
windows-sys-0.48.0 \
windows-targets-0.42.2 \
- windows-targets-0.48.0 \
+ windows-targets-0.48.5 \
windows_aarch64_gnullvm-0.42.2 \
- windows_aarch64_gnullvm-0.48.0 \
+ windows_aarch64_gnullvm-0.48.5 \
windows_aarch64_msvc-0.42.2 \
- windows_aarch64_msvc-0.48.0 \
+ windows_aarch64_msvc-0.48.5 \
windows_i686_gnu-0.42.2 \
- windows_i686_gnu-0.48.0 \
+ windows_i686_gnu-0.48.5 \
windows_i686_msvc-0.42.2 \
- windows_i686_msvc-0.48.0 \
+ windows_i686_msvc-0.48.5 \
windows_x86_64_gnu-0.42.2 \
- windows_x86_64_gnu-0.48.0 \
+ windows_x86_64_gnu-0.48.5 \
windows_x86_64_gnullvm-0.42.2 \
- windows_x86_64_gnullvm-0.48.0 \
+ windows_x86_64_gnullvm-0.48.5 \
windows_x86_64_msvc-0.42.2 \
- windows_x86_64_msvc-0.48.0 \
+ windows_x86_64_msvc-0.48.5 \
wyz-0.5.1
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/hyperfine
-
.include <bsd.port.mk>