aboutsummaryrefslogtreecommitdiff
path: root/biology/kallisto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/kallisto/Makefile')
-rw-r--r--biology/kallisto/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/biology/kallisto/Makefile b/biology/kallisto/Makefile
index 8774208d9097..158ff03a9137 100644
--- a/biology/kallisto/Makefile
+++ b/biology/kallisto/Makefile
@@ -1,6 +1,7 @@
PORTNAME= kallisto
DISTVERSIONPREFIX= v
DISTVERSION= 0.50.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= biology
@@ -22,6 +23,8 @@ USES= cmake:noninja compiler:c++11-lang gmake localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= pachterlab
+EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/ext/htslib --no-same-owner --no-same-permissions
+
SUB_FILES= kallisto-test
PORTEXAMPLES= *
@@ -39,9 +42,6 @@ LDFLAGS+= -lhts -lz
OPTIONS_DEFINE= EXAMPLES
-post-extract:
- ${RM} -rf ${WRKSRC}/ext/htslib
-
post-install-EXAMPLES-on:
${INSTALL_SCRIPT} ${WRKDIR}/kallisto-test ${STAGEDIR}${PREFIX}/bin
cd ${WRKSRC}/test && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}