aboutsummaryrefslogtreecommitdiff
path: root/biology/star/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/star/Makefile')
-rw-r--r--biology/star/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/biology/star/Makefile b/biology/star/Makefile
index 968caa762551..8e01f3198cd4 100644
--- a/biology/star/Makefile
+++ b/biology/star/Makefile
@@ -26,13 +26,14 @@ USE_GCC= yes
USE_GITHUB= yes
GH_ACCOUNT= alexdobin
+EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/source/htslib --no-same-owner --no-same-permissions
+
WRKSRC_SUBDIR= source
MAKE_FLAGS= HTSLIB='' CXXFLAGS_SIMD=""
PLIST_FILES= bin/STAR
post-patch:
- ${RM} -rf ${WRKSRC}/htslib
${REINPLACE_CMD} \
-e 's|"htslib/htslib/sam.h"|<htslib/sam.h>|g' \
-e 's|"htslib/htslib/kstring.h"|<htslib/kstring.h>|g' \