aboutsummaryrefslogtreecommitdiff
path: root/chinese/libime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/libime/Makefile')
-rw-r--r--chinese/libime/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/chinese/libime/Makefile b/chinese/libime/Makefile
index c220f90ba125..25f82cb63d47 100644
--- a/chinese/libime/Makefile
+++ b/chinese/libime/Makefile
@@ -1,6 +1,5 @@
PORTNAME= libime
-DISTVERSION= 1.0.17
-PORTREVISION= 3
+DISTVERSION= 1.1.7
CATEGORIES= chinese textproc
MASTER_SITES= https://download.fcitx-im.org/fcitx5/${PORTNAME}/ \
https://download.fcitx-im.org/data/:opengram_lm,opengram_dict,table_dict
@@ -19,7 +18,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libFcitx5Utils.so:textproc/fcitx5
-USES= cmake compiler:c++17-lang kde:5 tar:xz
+USES= cmake compiler:c++17-lang kde:5 pkgconfig tar:zst
PLIST_SUB= VER=${PORTVERSION} \
VER_MAJOR=${PORTVERSION:R:R}
@@ -32,9 +31,9 @@ CMAKE_OFF= ENABLE_TEST
MAKE_ENV= FCITX5_DOWNLOAD_DISALLOWED=TRUE
# These must follow data/CMakeLists.txt
-OPENGRAM_LM_TAR= lm_sc.arpa-20220810.tar.xz
-OPENGRAM_DICT_TAR= dict-20220810.tar.xz
-TABLE_DICT_TAR= table.tar.gz
+OPENGRAM_LM_TAR= lm_sc.arpa-20230712.tar.xz
+OPENGRAM_DICT_TAR= dict-20240416.tar.zst
+TABLE_DICT_TAR= table-20240108.tar.gz
.include <bsd.port.pre.mk>