aboutsummaryrefslogtreecommitdiff
path: root/devel/freebsd-git-devtools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/freebsd-git-devtools/Makefile')
-rw-r--r--devel/freebsd-git-devtools/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/devel/freebsd-git-devtools/Makefile b/devel/freebsd-git-devtools/Makefile
index 756aa00011e4..071b5ffd2108 100644
--- a/devel/freebsd-git-devtools/Makefile
+++ b/devel/freebsd-git-devtools/Makefile
@@ -1,9 +1,9 @@
PORTNAME= freebsd-git-devtools
-PORTVERSION= 20230925
-PORTREVISION= 1
+PORTVERSION= 20240422
CATEGORIES= devel
MASTER_SITES= https://cgit.freebsd.org/src/plain/tools/tools/git/
-DISTFILES= git-arc.sh?id=${_REV} \
+DISTFILES= candidatematch.lua?id=${_REV} \
+ git-arc.sh?id=${_REV} \
git-arc.1?id=${_REV} \
mfc-candidates.sh?id=${_REV}
DIST_SUBDIR= ${PORTNAME}
@@ -17,6 +17,10 @@ RUN_DEPENDS= arc:devel/arcanist \
git:devel/git \
jq:textproc/jq
+USES= lua shebangfix
+SHEBANG_FILES= candidatematch.lua?id=${_REV}
+lua_OLD_CMD= /usr/libexec/flua
+
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= .
@@ -25,11 +29,12 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= bin/git-arc \
+PLIST_FILES= bin/candidatematch.lua \
+ bin/git-arc \
bin/mfc-candidates \
share/man/man1/git-arc.1.gz
-_REV= 61f8df6a13a357e1d45c22a2016b87491f10de87
+_REV= 76a8625bc71da3fa63eef5abb4782553d2588f5c
post-patch:
for f in ${WRKSRC}/*\?id=*; do \
@@ -37,6 +42,7 @@ post-patch:
done
do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/candidatematch.lua ${STAGEDIR}${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKSRC}/git-arc.sh ${STAGEDIR}${PREFIX}/bin/git-arc
${INSTALL_SCRIPT} ${WRKSRC}/mfc-candidates.sh ${STAGEDIR}${PREFIX}/bin/mfc-candidates
${INSTALL_MAN} ${WRKSRC}/git-arc.1 ${STAGEDIR}${PREFIX}/share/man/man1/