aboutsummaryrefslogtreecommitdiff
path: root/devel/got/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/got/Makefile')
-rw-r--r--devel/got/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index 1a41440bef3f..47e197e649b7 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,5 @@
PORTNAME= got
-DISTVERSION= 0.98.2
+DISTVERSION= 0.99
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/portable/
DISTNAME= got-portable-${DISTVERSION}
@@ -17,6 +17,14 @@ CONFLICTS_INSTALL= p5-App-GitGot
GNU_CONFIGURE= Yes
+# The regression test suite requires:
+# installed got
+# installed git
+# installed perl and HTTP::Daemon
+# ssh to 127.0.0.1
+tests:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} tests)
+
.include <bsd.port.pre.mk>
# When using LibreSSL use its own libtls, but when using OpenSSL