aboutsummaryrefslogtreecommitdiff
path: root/devel/libnotify/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libnotify/Makefile')
-rw-r--r--devel/libnotify/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/devel/libnotify/Makefile b/devel/libnotify/Makefile
index ca8bb31a5206..7f078cf1506b 100644
--- a/devel/libnotify/Makefile
+++ b/devel/libnotify/Makefile
@@ -1,6 +1,5 @@
PORTNAME= libnotify
-DISTVERSION= 0.8.2
-PORTREVISION= 2
+DISTVERSION= 0.8.3
CATEGORIES= devel gnome
MASTER_SITES= GNOME
@@ -11,16 +10,20 @@ WWW= https://gitlab.gnome.org/GNOME/libnotify
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= docbook-xsl-ns>=0:textproc/docbook-xsl-ns
-
USES= gmake gnome libtool meson pkgconfig tar:xz
-USE_GNOME= glib20 gdkpixbuf2 introspection:build libxslt:build
+USE_GNOME= gdkpixbuf2 glib20 introspection:build
USE_LDCONFIG= yes
-MESON_ARGS= -Dtests=false -Ddocbook_docs=disabled -Dgtk_doc=false
+MESON_ARGS= -Ddocbook_docs=disabled \
+ -Dgtk_doc=false \
+ -Dtests=false
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT= MANPAGES
+OPTIONS_SUB= yes
-post-patch:
- ${REINPLACE_CMD} -e "s#http:.*docbook.xsl#${LOCALBASE}/share/xsl/docbook-ns/manpages/docbook.xsl#g" \
- ${WRKSRC}/meson.build
+MANPAGES_BUILD_DEPENDS= docbook-xsl-ns>=0:textproc/docbook-xsl-ns
+MANPAGES_USE= GNOME=libxslt:build
+MANPAGES_MESON_TRUE= man
.include <bsd.port.mk>