aboutsummaryrefslogtreecommitdiff
path: root/devel/nextest/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/nextest/Makefile')
-rw-r--r--devel/nextest/Makefile259
1 files changed, 126 insertions, 133 deletions
diff --git a/devel/nextest/Makefile b/devel/nextest/Makefile
index 8ec37a0df430..980e40cf4e73 100644
--- a/devel/nextest/Makefile
+++ b/devel/nextest/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nextest
DISTVERSIONPREFIX= cargo-nextest-
-DISTVERSION= 0.9.68
+DISTVERSION= 0.9.70
PORTREVISION= 1
CATEGORIES= devel
@@ -20,71 +20,72 @@ USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= nextest-rs
+RUSTFLAGS= ${ARCH:S/i386/YES/:C/^[a-z].*//:S/YES/-C target-feature=+sse,+sse2/} # add sse sse2 target-features only on i386
+
CARGO_CRATES= addr2line-0.21.0 \
adler-1.0.2 \
- ahash-0.8.7 \
- aho-corasick-1.1.2 \
+ ahash-0.8.11 \
+ aho-corasick-1.1.3 \
android-tzdata-0.1.1 \
android_system_properties-0.1.5 \
- anstream-0.6.7 \
- anstyle-1.0.4 \
+ anstream-0.6.13 \
+ anstyle-1.0.6 \
anstyle-parse-0.2.3 \
anstyle-query-1.0.2 \
anstyle-wincon-3.0.2 \
- anyhow-1.0.75 \
+ anyhow-1.0.82 \
async-scoped-0.9.0 \
async-stream-0.3.5 \
async-stream-impl-0.3.5 \
- async-trait-0.1.74 \
+ async-trait-0.1.80 \
atomicwrites-0.4.3 \
- autocfg-1.1.0 \
+ autocfg-1.2.0 \
axum-0.6.20 \
axum-core-0.3.4 \
- backtrace-0.3.69 \
+ backtrace-0.3.71 \
backtrace-ext-0.2.1 \
- base64-0.21.5 \
+ base64-0.21.7 \
base64ct-1.6.0 \
bit-set-0.5.3 \
bit-vec-0.6.3 \
bitflags-1.3.2 \
- bitflags-2.4.1 \
+ bitflags-2.5.0 \
block-buffer-0.10.4 \
- bstr-0.2.17 \
bstr-1.9.1 \
- bumpalo-3.14.0 \
+ bumpalo-3.16.0 \
byteorder-1.5.0 \
- bytes-1.5.0 \
+ bytes-1.6.0 \
camino-1.1.6 \
camino-tempfile-1.1.1 \
- cargo-platform-0.1.5 \
+ cargo-platform-0.1.8 \
cargo_metadata-0.18.1 \
- cc-1.0.83 \
- cfg-expr-0.15.6 \
+ cc-1.0.95 \
+ cfg-expr-0.15.8 \
cfg-if-1.0.0 \
cfg_aliases-0.1.1 \
- chrono-0.4.35 \
- clap-4.4.18 \
- clap_builder-4.4.18 \
- clap_derive-4.4.7 \
- clap_lex-0.6.0 \
+ chrono-0.4.38 \
+ clap-4.5.4 \
+ clap_builder-4.5.2 \
+ clap_derive-4.5.4 \
+ clap_lex-0.7.0 \
color-eyre-0.6.3 \
colorchoice-1.0.0 \
config-0.14.0 \
- console-0.15.7 \
+ console-0.15.8 \
console-api-0.6.0 \
console-subscriber-0.2.0 \
const-oid-0.9.6 \
core-foundation-0.9.4 \
core-foundation-sys-0.8.6 \
- cpufeatures-0.2.11 \
- crc32fast-1.3.2 \
- crossbeam-channel-0.5.9 \
- crossbeam-utils-0.8.17 \
+ cpufeatures-0.2.12 \
+ crc32fast-1.4.0 \
+ crossbeam-channel-0.5.12 \
+ crossbeam-utils-0.8.19 \
crypto-common-0.1.6 \
- curve25519-dalek-4.1.1 \
+ curve25519-dalek-4.1.2 \
curve25519-dalek-derive-0.1.1 \
debug-ignore-1.0.5 \
- der-0.7.8 \
+ der-0.7.9 \
dialoguer-0.11.0 \
diff-0.1.13 \
digest-0.10.7 \
@@ -92,19 +93,19 @@ CARGO_CRATES= addr2line-0.21.0 \
duct-0.13.7 \
dunce-1.0.4 \
ed25519-2.2.3 \
- ed25519-dalek-2.1.0 \
- either-1.10.0 \
+ ed25519-dalek-2.1.1 \
+ either-1.11.0 \
enable-ansi-support-0.2.1 \
encode_unicode-0.3.6 \
- encoding_rs-0.8.33 \
+ encoding_rs-0.8.34 \
env_filter-0.1.0 \
env_logger-0.11.3 \
equivalent-1.0.1 \
errno-0.3.8 \
- eyre-0.6.11 \
+ eyre-0.6.12 \
fastrand-1.9.0 \
- fastrand-2.0.1 \
- fiat-crypto-0.2.5 \
+ fastrand-2.0.2 \
+ fiat-crypto-0.2.7 \
filetime-0.2.23 \
fixedbitset-0.4.2 \
flate2-1.0.28 \
@@ -123,18 +124,17 @@ CARGO_CRATES= addr2line-0.21.0 \
futures-task-0.3.30 \
futures-util-0.3.30 \
generic-array-0.14.7 \
- getrandom-0.2.11 \
+ getrandom-0.2.14 \
gimli-0.28.1 \
globset-0.4.14 \
- goldenfile-1.6.0 \
guppy-0.17.5 \
guppy-workspace-hack-0.1.0 \
- h2-0.3.24 \
+ h2-0.3.26 \
hashbrown-0.12.3 \
hashbrown-0.14.3 \
hdrhistogram-7.5.4 \
- heck-0.4.1 \
- hermit-abi-0.3.3 \
+ heck-0.5.0 \
+ hermit-abi-0.3.9 \
home-0.5.9 \
http-0.2.12 \
http-body-0.4.6 \
@@ -142,118 +142,118 @@ CARGO_CRATES= addr2line-0.21.0 \
httpdate-1.0.3 \
humantime-2.1.0 \
humantime-serde-1.1.1 \
- hyper-0.14.27 \
+ hyper-0.14.28 \
hyper-rustls-0.24.2 \
hyper-timeout-0.4.1 \
hyper-tls-0.5.0 \
- iana-time-zone-0.1.58 \
+ iana-time-zone-0.1.60 \
iana-time-zone-haiku-0.1.2 \
idna-0.5.0 \
indenter-0.3.3 \
indexmap-1.9.3 \
- indexmap-2.2.5 \
+ indexmap-2.2.6 \
indicatif-0.17.8 \
- indoc-2.0.4 \
- insta-1.36.1 \
+ indoc-2.0.5 \
+ insta-1.38.0 \
instant-0.1.12 \
ipnet-2.9.0 \
- is-terminal-0.4.9 \
+ is-terminal-0.4.12 \
is_ci-1.2.0 \
- itertools-0.11.0 \
itertools-0.12.1 \
- itoa-1.0.10 \
- jobserver-0.1.27 \
- js-sys-0.3.66 \
+ itoa-1.0.11 \
+ jobserver-0.1.31 \
+ js-sys-0.3.69 \
lazy_static-1.4.0 \
libc-0.2.153 \
libm-0.2.8 \
linked-hash-map-0.5.6 \
- linux-raw-sys-0.4.12 \
+ linux-raw-sys-0.4.13 \
log-0.4.21 \
maplit-1.0.2 \
matchers-0.1.0 \
matchit-0.7.3 \
- memchr-2.7.1 \
+ memchr-2.7.2 \
miette-7.2.0 \
miette-derive-7.2.0 \
mime-0.3.17 \
minimal-lexical-0.2.1 \
- miniz_oxide-0.7.1 \
+ miniz_oxide-0.7.2 \
mio-0.8.11 \
mukti-metadata-0.2.1 \
native-tls-0.2.11 \
nested-0.1.1 \
+ newtype-uuid-1.1.0 \
nix-0.28.0 \
nom-7.1.3 \
- num-traits-0.2.17 \
+ num-traits-0.2.18 \
num_cpus-1.16.0 \
number_prefix-0.4.0 \
- object-0.32.1 \
+ object-0.32.2 \
once_cell-1.19.0 \
- openssl-0.10.61 \
+ openssl-0.10.64 \
openssl-macros-0.1.1 \
openssl-probe-0.1.5 \
- openssl-sys-0.9.97 \
- os_pipe-1.1.4 \
+ openssl-sys-0.9.102 \
+ os_pipe-1.1.5 \
owo-colors-3.5.0 \
owo-colors-4.0.0 \
pathdiff-0.2.1 \
percent-encoding-2.3.1 \
petgraph-0.6.4 \
- pin-project-1.1.3 \
- pin-project-internal-1.1.3 \
- pin-project-lite-0.2.13 \
+ pin-project-1.1.5 \
+ pin-project-internal-1.1.5 \
+ pin-project-lite-0.2.14 \
pin-utils-0.1.0 \
pkcs8-0.10.2 \
- pkg-config-0.3.27 \
- platforms-3.2.0 \
+ pkg-config-0.3.30 \
+ platforms-3.4.0 \
portable-atomic-1.6.0 \
ppv-lite86-0.2.17 \
pretty_assertions-1.4.0 \
- proc-macro2-1.0.78 \
+ proc-macro2-1.0.81 \
proptest-1.4.0 \
- prost-0.12.3 \
- prost-derive-0.12.3 \
- prost-types-0.12.3 \
+ prost-0.12.4 \
+ prost-derive-0.12.4 \
+ prost-types-0.12.4 \
quick-error-1.2.3 \
+ quick-junit-0.4.0 \
quick-xml-0.23.1 \
quick-xml-0.31.0 \
- quote-1.0.35 \
+ quote-1.0.36 \
rand-0.8.5 \
rand_chacha-0.3.1 \
rand_core-0.6.4 \
rand_xorshift-0.3.0 \
recursion-0.5.2 \
redox_syscall-0.4.1 \
- regex-1.10.3 \
+ regex-1.10.4 \
regex-automata-0.1.10 \
- regex-automata-0.4.4 \
+ regex-automata-0.4.6 \
regex-syntax-0.6.29 \
- regex-syntax-0.8.2 \
- reqwest-0.11.22 \
- ring-0.17.7 \
+ regex-syntax-0.8.3 \
+ reqwest-0.11.27 \
+ ring-0.17.8 \
ron-0.8.1 \
rustc-demangle-0.1.23 \
rustc_version-0.4.0 \
- rustix-0.38.28 \
- rustls-0.21.10 \
+ rustix-0.38.33 \
+ rustls-0.21.11 \
rustls-pemfile-1.0.4 \
rustls-webpki-0.101.7 \
- rustversion-1.0.14 \
+ rustversion-1.0.15 \
rusty-fork-0.3.0 \
- ryu-1.0.16 \
- schannel-0.1.22 \
- scopeguard-1.2.0 \
+ ryu-1.0.17 \
+ schannel-0.1.23 \
sct-0.7.1 \
- security-framework-2.9.2 \
- security-framework-sys-2.9.1 \
+ security-framework-2.10.0 \
+ security-framework-sys-2.10.0 \
self-replace-1.3.7 \
self_update-0.39.0 \
semver-1.0.22 \
- serde-1.0.197 \
- serde_derive-1.0.197 \
+ serde-1.0.198 \
+ serde_derive-1.0.198 \
serde_ignored-0.1.10 \
- serde_json-1.0.114 \
+ serde_json-1.0.116 \
serde_path_to_error-0.1.16 \
serde_spanned-0.6.5 \
serde_urlencoded-0.7.1 \
@@ -261,21 +261,19 @@ CARGO_CRATES= addr2line-0.21.0 \
sharded-slab-0.1.7 \
shared_child-1.0.0 \
shell-words-1.1.0 \
- signal-hook-registry-1.4.1 \
+ signal-hook-registry-1.4.2 \
signature-2.2.0 \
- similar-2.3.0 \
- similar-asserts-1.5.0 \
+ similar-2.5.0 \
slab-0.4.9 \
- smallvec-1.13.1 \
+ smallvec-1.13.2 \
smawk-0.3.2 \
smol_str-0.2.1 \
- socket2-0.4.10 \
- socket2-0.5.5 \
+ socket2-0.5.6 \
spin-0.9.8 \
spki-0.7.3 \
static_assertions-1.1.0 \
strip-ansi-escapes-0.2.0 \
- strsim-0.10.0 \
+ strsim-0.11.1 \
structmeta-0.2.0 \
structmeta-derive-0.2.0 \
subtle-2.5.0 \
@@ -284,36 +282,36 @@ CARGO_CRATES= addr2line-0.21.0 \
supports-hyperlinks-3.0.0 \
supports-unicode-3.0.0 \
swrite-0.1.0 \
- syn-2.0.52 \
+ syn-2.0.60 \
sync_wrapper-0.1.2 \
system-configuration-0.5.1 \
system-configuration-sys-0.5.0 \
tar-0.4.40 \
- target-lexicon-0.12.13 \
+ target-lexicon-0.12.14 \
target-spec-3.1.0 \
target-spec-miette-0.4.0 \
- tempfile-3.8.1 \
+ tempfile-3.10.1 \
terminal_size-0.3.0 \
test-case-3.3.1 \
test-case-core-3.3.1 \
test-case-macros-3.3.1 \
test-strategy-0.3.1 \
- textwrap-0.16.0 \
- thiserror-1.0.58 \
- thiserror-impl-1.0.58 \
- thread_local-1.1.7 \
+ textwrap-0.16.1 \
+ thiserror-1.0.59 \
+ thiserror-impl-1.0.59 \
+ thread_local-1.1.8 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
- tokio-1.36.0 \
+ tokio-1.37.0 \
tokio-io-timeout-1.2.0 \
tokio-macros-2.2.0 \
tokio-native-tls-0.3.1 \
tokio-rustls-0.24.1 \
- tokio-stream-0.1.14 \
+ tokio-stream-0.1.15 \
tokio-util-0.7.10 \
- toml-0.8.11 \
+ toml-0.8.12 \
toml_datetime-0.6.5 \
- toml_edit-0.22.7 \
+ toml_edit-0.22.12 \
tonic-0.10.2 \
tower-0.4.13 \
tower-layer-0.3.2 \
@@ -325,17 +323,16 @@ CARGO_CRATES= addr2line-0.21.0 \
try-lock-0.2.5 \
typenum-1.17.0 \
unarray-0.1.4 \
- unicode-bidi-0.3.14 \
+ unicode-bidi-0.3.15 \
unicode-ident-1.0.12 \
unicode-linebreak-0.1.5 \
unicode-normalization-0.1.23 \
- unicode-segmentation-1.10.1 \
unicode-width-0.1.11 \
untrusted-0.9.0 \
url-2.5.0 \
urlencoding-2.1.3 \
utf8parse-0.2.1 \
- uuid-1.7.0 \
+ uuid-1.8.0 \
valuable-0.1.0 \
vcpkg-0.2.15 \
version_check-0.9.4 \
@@ -344,63 +341,59 @@ CARGO_CRATES= addr2line-0.21.0 \
wait-timeout-0.2.0 \
want-0.3.1 \
wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.89 \
- wasm-bindgen-backend-0.2.89 \
- wasm-bindgen-futures-0.4.39 \
- wasm-bindgen-macro-0.2.89 \
- wasm-bindgen-macro-support-0.2.89 \
- wasm-bindgen-shared-0.2.89 \
- web-sys-0.3.66 \
- webpki-roots-0.25.3 \
+ wasm-bindgen-0.2.92 \
+ wasm-bindgen-backend-0.2.92 \
+ wasm-bindgen-futures-0.4.42 \
+ wasm-bindgen-macro-0.2.92 \
+ wasm-bindgen-macro-support-0.2.92 \
+ wasm-bindgen-shared-0.2.92 \
+ web-sys-0.3.69 \
+ webpki-roots-0.25.4 \
win32job-2.0.0 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
windows-0.52.0 \
- windows-core-0.51.1 \
windows-core-0.52.0 \
windows-sys-0.42.0 \
- windows-sys-0.45.0 \
windows-sys-0.48.0 \
windows-sys-0.52.0 \
- windows-targets-0.42.2 \
windows-targets-0.48.5 \
- windows-targets-0.52.0 \
+ windows-targets-0.52.5 \
windows_aarch64_gnullvm-0.42.2 \
windows_aarch64_gnullvm-0.48.5 \
- windows_aarch64_gnullvm-0.52.0 \
+ windows_aarch64_gnullvm-0.52.5 \
windows_aarch64_msvc-0.42.2 \
windows_aarch64_msvc-0.48.5 \
- windows_aarch64_msvc-0.52.0 \
+ windows_aarch64_msvc-0.52.5 \
windows_i686_gnu-0.42.2 \
windows_i686_gnu-0.48.5 \
- windows_i686_gnu-0.52.0 \
+ windows_i686_gnu-0.52.5 \
+ windows_i686_gnullvm-0.52.5 \
windows_i686_msvc-0.42.2 \
windows_i686_msvc-0.48.5 \
- windows_i686_msvc-0.52.0 \
+ windows_i686_msvc-0.52.5 \
windows_x86_64_gnu-0.42.2 \
windows_x86_64_gnu-0.48.5 \
- windows_x86_64_gnu-0.52.0 \
+ windows_x86_64_gnu-0.52.5 \
windows_x86_64_gnullvm-0.42.2 \
windows_x86_64_gnullvm-0.48.5 \
- windows_x86_64_gnullvm-0.52.0 \
+ windows_x86_64_gnullvm-0.52.5 \
windows_x86_64_msvc-0.42.2 \
windows_x86_64_msvc-0.48.5 \
- windows_x86_64_msvc-0.52.0 \
- winnow-0.6.5 \
+ windows_x86_64_msvc-0.52.5 \
+ winnow-0.6.6 \
winreg-0.50.0 \
- xattr-1.1.3 \
+ xattr-1.3.1 \
xxhash-rust-0.8.10 \
- yaml-rust-0.4.5 \
yansi-0.5.1 \
- yansi-1.0.0-rc.1 \
- zerocopy-0.7.31 \
- zerocopy-derive-0.7.31 \
+ zerocopy-0.7.32 \
+ zerocopy-derive-0.7.32 \
zeroize-1.7.0 \
zipsign-api-0.1.1 \
- zstd-0.13.0 \
- zstd-safe-7.0.0 \
- zstd-sys-2.0.9+zstd.1.5.5
+ zstd-0.13.1 \
+ zstd-safe-7.1.0 \
+ zstd-sys-2.0.10+zstd.1.5.6
OPENSSLINC= /usr/include
OPENSSLLIB= /usr/lib