aboutsummaryrefslogtreecommitdiff
path: root/devel/py-flaky/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-flaky/Makefile')
-rw-r--r--devel/py-flaky/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/devel/py-flaky/Makefile b/devel/py-flaky/Makefile
index 143863e4c8b2..24b6daecaf90 100644
--- a/devel/py-flaky/Makefile
+++ b/devel/py-flaky/Makefile
@@ -1,5 +1,5 @@
PORTNAME= flaky
-DISTVERSION= 3.7.0
+DISTVERSION= 3.8.1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,27 +11,24 @@ WWW= https://github.com/box/flaky
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}genty>0:devel/py-genty@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR}
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils pytest
+
+TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
NO_ARCH= yes
+# Tests were taken from https://github.com/box/flaky/blob/v3.8.1/tox.ini#L17
+# The "--no-flaky-report" parameter has also been added to make the output
+# a little clearer.
do-test:
cd ${WRKSRC} && \
- ${PYTHON_CMD} -m nose -v --no-flaky-report \
- --with-flaky --exclude="test_nose_options_example" test/test_nose/ && \
${PYTHON_CMD} -m pytest -v -rs --no-flaky-report \
-k 'example and not options' -n 1 test/test_pytest && \
${PYTHON_CMD} -m pytest -v -rs \
-p no:flaky test/test_pytest/test_flaky_pytest_plugin.py && \
- ${PYTHON_CMD} -m nose -v --no-flaky-report \
- --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py && \
${PYTHON_CMD} -m pytest -v -rs --no-flaky-report \
--force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py