aboutsummaryrefslogtreecommitdiff
path: root/devel/py-grpcio-tools/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-grpcio-tools/files/patch-setup.py')
-rw-r--r--devel/py-grpcio-tools/files/patch-setup.py22
1 files changed, 11 insertions, 11 deletions
diff --git a/devel/py-grpcio-tools/files/patch-setup.py b/devel/py-grpcio-tools/files/patch-setup.py
index cecda56e3f44..b83ec7645346 100644
--- a/devel/py-grpcio-tools/files/patch-setup.py
+++ b/devel/py-grpcio-tools/files/patch-setup.py
@@ -1,15 +1,15 @@
---- setup.py.orig 2024-02-20 20:46:14 UTC
+--- setup.py.orig 2024-04-26 06:29:22 UTC
+++ setup.py
-@@ -145,7 +145,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
- # We need to statically link the C++ Runtime, only the C runtime is
- # available dynamically
- EXTRA_ENV_COMPILE_ARGS += " /MT"
-- elif "linux" in sys.platform or "darwin" in sys.platform:
-+ elif "linux" in sys.platform or "darwin" in sys.platform or "freebsd" in sys.platform:
- # GCC & Clang by defaults uses C17 so only C++14 needs to be specified.
+@@ -178,7 +178,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
+ # Reduce the optimization level from O3 (in many cases) to O1 to
+ # workaround gcc misalignment bug with MOVAPS (internal b/329134877)
+ EXTRA_ENV_COMPILE_ARGS += " -O1"
+- elif "darwin" in sys.platform:
++ elif "darwin" in sys.platform or "freebsd" in sys.platform:
+ # AppleClang by defaults uses C17 so only C++14 needs to be specified.
EXTRA_ENV_COMPILE_ARGS += " -std=c++14"
EXTRA_ENV_COMPILE_ARGS += " -fno-wrapv -frtti"
-@@ -174,7 +174,7 @@ if EXTRA_ENV_LINK_ARGS is None:
+@@ -211,7 +211,7 @@ if EXTRA_ENV_LINK_ARGS is None:
EXTRA_ENV_LINK_ARGS += " -Wl,-exported_symbol,_{}".format(
_EXT_INIT_SYMBOL
)
@@ -18,7 +18,7 @@
EXTRA_ENV_LINK_ARGS += " -lpthread"
if check_linker_need_libatomic():
EXTRA_ENV_LINK_ARGS += " -latomic"
-@@ -211,7 +211,7 @@ if "win32" in sys.platform:
+@@ -248,7 +248,7 @@ if "win32" in sys.platform:
)
if "64bit" in platform.architecture()[0]:
DEFINE_MACROS += (("MS_WIN64", 1),)
@@ -26,4 +26,4 @@
+elif "linux" in sys.platform or "darwin" in sys.platform or "freebsd" in sys.platform:
DEFINE_MACROS += (("HAVE_PTHREAD", 1),)
- # By default, Python3 setuptools(distutils) enforces compatibility of
+