aboutsummaryrefslogtreecommitdiff
path: root/devel/rust-analyzer/Makefile.crates
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rust-analyzer/Makefile.crates')
-rw-r--r--devel/rust-analyzer/Makefile.crates10
1 files changed, 10 insertions, 0 deletions
diff --git a/devel/rust-analyzer/Makefile.crates b/devel/rust-analyzer/Makefile.crates
index 9f55a0765556..25397e1eb30e 100644
--- a/devel/rust-analyzer/Makefile.crates
+++ b/devel/rust-analyzer/Makefile.crates
@@ -30,6 +30,8 @@ CARGO_CRATES= addr2line-0.21.0 \
dashmap-5.5.3 \
deranged-0.3.11 \
derive_arbitrary-1.3.2 \
+ directories-5.0.1 \
+ dirs-sys-0.4.1 \
dissimilar-1.0.7 \
dot-0.1.4 \
drop_bomb-0.1.5 \
@@ -63,6 +65,7 @@ CARGO_CRATES= addr2line-0.21.0 \
libc-0.2.153 \
libloading-0.8.3 \
libmimalloc-sys-0.1.35 \
+ libredox-0.1.3 \
line-index-0.1.1 \
linked-hash-map-0.5.6 \
lock_api-0.4.11 \
@@ -88,6 +91,7 @@ CARGO_CRATES= addr2line-0.21.0 \
object-0.33.0 \
once_cell-1.19.0 \
oorandom-11.1.3 \
+ option-ext-0.2.0 \
parking_lot-0.12.1 \
parking_lot_core-0.9.9 \
paste-1.0.14 \
@@ -116,6 +120,7 @@ CARGO_CRATES= addr2line-0.21.0 \
rayon-1.9.0 \
rayon-core-1.12.1 \
redox_syscall-0.4.1 \
+ redox_users-0.4.5 \
rowan-0.15.15 \
rustc-demangle-0.1.23 \
rustc-hash-1.1.0 \
@@ -130,6 +135,7 @@ CARGO_CRATES= addr2line-0.21.0 \
serde_derive-1.0.197 \
serde_json-1.0.114 \
serde_repr-0.1.18 \
+ serde_spanned-0.6.5 \
sharded-slab-0.1.7 \
smallvec-1.13.1 \
smol_str-0.2.1 \
@@ -148,6 +154,9 @@ CARGO_CRATES= addr2line-0.21.0 \
time-core-0.1.2 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
+ toml-0.8.8 \
+ toml_datetime-0.6.5 \
+ toml_edit-0.21.0 \
tracing-0.1.40 \
tracing-attributes-0.1.27 \
tracing-core-0.1.32 \
@@ -190,6 +199,7 @@ CARGO_CRATES= addr2line-0.21.0 \
windows_x86_64_gnullvm-0.52.4 \
windows_x86_64_msvc-0.48.5 \
windows_x86_64_msvc-0.52.4 \
+ winnow-0.5.32 \
write-json-0.1.4 \
xflags-0.3.2 \
xflags-macros-0.3.2 \