aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu/Makefile')
-rw-r--r--emulators/qemu/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 9f23e681bfed..13b8e0f82a2e 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -1,6 +1,5 @@
PORTNAME= qemu
-PORTVERSION= 8.2.2
-PORTREVISION= 2
+DISTVERSION= 9.0.0
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -19,8 +18,9 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc64 powerpc64le
BUILD_DEPENDS= bash:shells/bash
.if ${FLAVOR:U} != tools && ${FLAVOR:U} != guestagent
LIB_DEPENDS+= libfdt.so:sysutils/dtc \
- libzstd.so:archivers/zstd \
- libslirp.so:net/libslirp
+ libinotify.so:devel/libinotify \
+ libslirp.so:net/libslirp \
+ libzstd.so:archivers/zstd
.endif
.if (${FLAVOR:U} != nox11 && ${FLAVOR:U} != tools && ${FLAVOR:U} != guestagent)
LIB_DEPENDS+= libepoxy.so:graphics/libepoxy
@@ -238,7 +238,7 @@ PLIST_SUB+= LINUXBOOT_DMA=""
.endif
post-patch-CDROM_DMA-off:
- @${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/include/hw/ide/internal.h
+ @${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/hw/ide/ide-internal.h
do-build:
cd ${WRKSRC} && ${SETENVI} ${WRK_ENV} ${GMAKE} -j${MAKE_JOBS_NUMBER}