aboutsummaryrefslogtreecommitdiff
path: root/finance/hyperswitch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/hyperswitch/Makefile')
-rw-r--r--finance/hyperswitch/Makefile678
1 files changed, 362 insertions, 316 deletions
diff --git a/finance/hyperswitch/Makefile b/finance/hyperswitch/Makefile
index 91295f5631f5..0da44d59596f 100644
--- a/finance/hyperswitch/Makefile
+++ b/finance/hyperswitch/Makefile
@@ -1,7 +1,5 @@
PORTNAME= hyperswitch
-DISTVERSIONPREFIX= v
-DISTVERSION= 1.106.1
-PORTREVISION= 1
+DISTVERSION= 2024.05.16.1
CATEGORIES= finance
MAINTAINER= yuri@FreeBSD.org
@@ -11,6 +9,8 @@ WWW= https://hyperswitch.io/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_i386= compilation fails: error[E0412]: cannot find type `AtomicU128` in module `core::sync::atomic`
+
LIB_DEPENDS= librdkafka.so:net/librdkafka \
libzstd.so:archivers/zstd
@@ -19,204 +19,231 @@ USES= cargo pgsql pkgconfig ssl
USE_GITHUB= yes
GH_ACCOUNT= juspay
-CARGO_CRATES= actix-codec-0.5.1 \
- actix-cors-0.6.4 \
- actix-http-3.3.1 \
+CARGO_CRATES= actix-codec-0.5.2 \
+ actix-cors-0.6.5 \
+ actix-http-3.6.0 \
actix-macros-0.2.4 \
actix-multipart-0.6.1 \
actix-multipart-derive-0.6.1 \
- actix-router-0.5.1 \
+ actix-router-0.5.2 \
actix-rt-2.9.0 \
actix-server-2.3.0 \
actix-service-2.0.2 \
- actix-tls-3.1.1 \
+ actix-tls-3.3.0 \
actix-utils-3.0.1 \
- actix-web-4.3.1 \
+ actix-web-4.5.1 \
actix-web-codegen-4.2.2 \
addr2line-0.21.0 \
adler-1.0.2 \
- adler32-1.2.0 \
- ahash-0.7.7 \
- ahash-0.8.6 \
- aho-corasick-1.1.1 \
+ ahash-0.7.8 \
+ ahash-0.8.11 \
+ aho-corasick-1.1.3 \
alloc-no-stdlib-2.0.4 \
alloc-stdlib-0.2.2 \
allocator-api2-0.2.16 \
android-tzdata-0.1.1 \
android_system_properties-0.1.5 \
anes-0.1.6 \
- anstyle-1.0.0 \
- anyhow-1.0.75 \
- arc-swap-1.6.0 \
- argon2-0.5.2 \
+ anstyle-1.0.6 \
+ anyhow-1.0.81 \
+ arc-swap-1.7.1 \
+ argon2-0.5.3 \
arrayref-0.3.7 \
arrayvec-0.7.4 \
- asn1-rs-0.5.2 \
- asn1-rs-derive-0.4.0 \
- asn1-rs-impl-0.1.0 \
+ asn1-rs-0.6.1 \
+ asn1-rs-derive-0.5.0 \
+ asn1-rs-impl-0.2.0 \
assert-json-diff-2.0.2 \
- async-channel-1.9.0 \
- async-compression-0.4.3 \
+ async-compression-0.4.6 \
async-lock-2.8.0 \
async-stream-0.3.5 \
async-stream-impl-0.3.5 \
- async-trait-0.1.73 \
- atoi-1.0.0 \
+ async-trait-0.1.79 \
+ atoi-2.0.0 \
atomic-0.5.3 \
- autocfg-1.1.0 \
- awc-3.1.1 \
+ atomic-write-file-0.1.3 \
+ autocfg-1.2.0 \
+ awc-3.4.0 \
aws-config-0.55.3 \
+ aws-config-1.1.9 \
aws-credential-types-0.55.3 \
+ aws-credential-types-1.1.8 \
aws-endpoint-0.55.3 \
aws-http-0.55.3 \
+ aws-runtime-1.1.8 \
aws-sdk-kms-0.28.0 \
- aws-sdk-lambda-0.28.0 \
+ aws-sdk-lambda-1.18.0 \
aws-sdk-s3-0.28.0 \
aws-sdk-sesv2-0.28.0 \
aws-sdk-sso-0.28.0 \
+ aws-sdk-sso-1.18.0 \
+ aws-sdk-ssooidc-1.18.0 \
aws-sdk-sts-0.28.0 \
+ aws-sdk-sts-1.18.0 \
aws-sig-auth-0.55.3 \
aws-sigv4-0.55.3 \
+ aws-sigv4-1.2.0 \
aws-smithy-async-0.55.3 \
+ aws-smithy-async-1.2.0 \
aws-smithy-checksums-0.55.3 \
aws-smithy-client-0.55.3 \
aws-smithy-eventstream-0.55.3 \
+ aws-smithy-eventstream-0.60.4 \
aws-smithy-http-0.55.3 \
+ aws-smithy-http-0.60.7 \
aws-smithy-http-tower-0.55.3 \
aws-smithy-json-0.55.3 \
+ aws-smithy-json-0.60.7 \
aws-smithy-query-0.55.3 \
+ aws-smithy-query-0.60.7 \
+ aws-smithy-runtime-1.1.8 \
+ aws-smithy-runtime-api-1.2.0 \
aws-smithy-types-0.55.3 \
+ aws-smithy-types-1.1.8 \
aws-smithy-xml-0.55.3 \
+ aws-smithy-xml-0.60.7 \
aws-types-0.55.3 \
+ aws-types-1.1.8 \
axum-0.6.20 \
axum-core-0.3.4 \
- backtrace-0.3.69 \
+ backtrace-0.3.71 \
+ base32-0.4.0 \
base64-0.13.1 \
- base64-0.21.5 \
+ base64-0.21.7 \
+ base64-0.22.0 \
base64-simd-0.8.0 \
base64ct-1.6.0 \
- bb8-0.8.1 \
+ bb8-0.8.3 \
bigdecimal-0.3.1 \
bincode-1.3.3 \
bit-set-0.5.3 \
bit-vec-0.6.3 \
bitflags-1.3.2 \
- bitflags-2.4.0 \
+ bitflags-2.5.0 \
bitvec-1.0.1 \
blake2-0.10.6 \
- blake3-1.4.0 \
- block-buffer-0.9.0 \
+ blake3-1.5.1 \
block-buffer-0.10.4 \
- borsh-1.2.0 \
- borsh-derive-1.2.0 \
- brotli-3.4.0 \
- brotli-decompressor-2.5.0 \
- bstr-1.6.0 \
+ borsh-1.3.1 \
+ borsh-derive-1.3.1 \
+ brotli-3.5.0 \
+ brotli-decompressor-2.5.1 \
+ bstr-1.9.1 \
bumpalo-3.14.0 \
- bytecheck-0.6.11 \
- bytecheck_derive-0.6.11 \
- bytecount-0.6.4 \
- bytemuck-1.14.0 \
+ bytecheck-0.6.12 \
+ bytecheck_derive-0.6.12 \
+ bytecount-0.6.7 \
+ bytemuck-1.15.0 \
byteorder-1.5.0 \
bytes-0.4.12 \
- bytes-1.5.0 \
- bytes-utils-0.1.3 \
- bytestring-1.3.0 \
+ bytes-1.6.0 \
+ bytes-utils-0.1.4 \
+ bytestring-1.3.1 \
camino-1.1.6 \
- cargo-platform-0.1.3 \
+ cargo-platform-0.1.7 \
cargo_metadata-0.14.2 \
- cargo_metadata-0.15.4 \
cargo_metadata-0.18.1 \
cast-0.3.0 \
- cc-1.0.83 \
+ cc-1.0.90 \
cfb-0.7.3 \
cfg-if-0.1.10 \
cfg-if-1.0.0 \
cfg_aliases-0.1.1 \
- checked_int_cast-1.0.0 \
- chrono-0.4.31 \
- chrono-tz-0.8.3 \
- chrono-tz-build-0.2.0 \
- ciborium-0.2.1 \
- ciborium-io-0.2.1 \
- ciborium-ll-0.2.1 \
- clap-4.3.2 \
- clap_builder-4.3.1 \
- clap_derive-4.3.2 \
- clap_lex-0.5.0 \
+ chrono-0.4.35 \
+ chrono-tz-0.8.6 \
+ chrono-tz-build-0.2.1 \
+ ciborium-0.2.2 \
+ ciborium-io-0.2.2 \
+ ciborium-ll-0.2.2 \
+ clap-4.4.18 \
+ clap_builder-4.4.18 \
+ clap_derive-4.4.7 \
+ clap_lex-0.6.0 \
cloudabi-0.0.3 \
- color_quant-1.1.0 \
- concurrent-queue-2.3.0 \
- config-0.13.3 \
+ config-0.14.0 \
+ const-oid-0.9.6 \
+ const-random-0.1.18 \
+ const-random-macro-0.1.16 \
constant_time_eq-0.2.6 \
+ constant_time_eq-0.3.0 \
convert_case-0.4.0 \
+ convert_case-0.6.0 \
cookie-0.16.2 \
- cookie-factory-0.3.2 \
- core-foundation-0.9.3 \
- core-foundation-sys-0.8.4 \
- cpufeatures-0.2.9 \
+ cookie-0.18.1 \
+ cookie-factory-0.3.3 \
+ core-foundation-0.9.4 \
+ core-foundation-sys-0.8.6 \
+ cpufeatures-0.2.12 \
crc-3.0.1 \
crc-catalog-2.4.0 \
crc16-0.4.0 \
- crc32c-0.6.4 \
- crc32fast-1.3.2 \
+ crc32c-0.6.5 \
+ crc32fast-1.4.0 \
criterion-0.5.1 \
criterion-plot-0.5.0 \
- crossbeam-channel-0.5.8 \
+ crossbeam-channel-0.5.12 \
crossbeam-deque-0.7.4 \
- crossbeam-deque-0.8.3 \
+ crossbeam-deque-0.8.5 \
crossbeam-epoch-0.8.2 \
- crossbeam-epoch-0.9.15 \
+ crossbeam-epoch-0.9.18 \
crossbeam-queue-0.2.3 \
- crossbeam-queue-0.3.8 \
+ crossbeam-queue-0.3.11 \
crossbeam-utils-0.7.2 \
- crossbeam-utils-0.8.16 \
+ crossbeam-utils-0.8.19 \
+ crunchy-0.2.2 \
crypto-common-0.1.6 \
- darling-0.20.3 \
- darling_core-0.20.3 \
- darling_macro-0.20.3 \
+ darling-0.14.4 \
+ darling-0.20.8 \
+ darling_core-0.14.4 \
+ darling_core-0.20.8 \
+ darling_macro-0.14.4 \
+ darling_macro-0.20.8 \
dashmap-5.5.3 \
- data-encoding-2.4.0 \
- deadpool-0.9.5 \
+ data-encoding-2.5.0 \
+ deadpool-0.10.0 \
deadpool-runtime-0.1.3 \
- deflate-0.8.6 \
- der-parser-8.2.0 \
+ der-0.7.8 \
+ der-parser-9.0.0 \
+ deranged-0.3.11 \
+ derive_builder-0.12.0 \
+ derive_builder_core-0.12.0 \
+ derive_builder_macro-0.12.0 \
derive_deref-1.1.1 \
derive_more-0.99.17 \
- deunicode-0.4.4 \
- diesel-2.1.3 \
- diesel_derives-2.1.2 \
+ deunicode-1.4.3 \
+ diesel-2.1.5 \
+ diesel_derives-2.1.3 \
diesel_table_macro_syntax-0.1.0 \
- digest-0.9.0 \
digest-0.10.7 \
digits_iterator-0.1.0 \
- dirs-4.0.0 \
- dirs-sys-0.3.7 \
displaydoc-0.2.4 \
- dlv-list-0.3.0 \
+ dlv-list-0.5.2 \
dotenvy-0.15.7 \
- dyn-clone-1.0.14 \
- either-1.9.0 \
+ dyn-clone-1.0.17 \
+ either-1.10.0 \
encoding_rs-0.8.33 \
equivalent-1.0.1 \
erased-serde-0.3.31 \
- errno-0.3.4 \
- errno-dragonfly-0.1.2 \
+ erased-serde-0.4.4 \
+ errno-0.3.8 \
error-chain-0.12.4 \
- error-stack-0.3.1 \
+ error-stack-0.4.1 \
+ etcetera-0.8.0 \
event-listener-2.5.3 \
- fake-2.8.0 \
+ fake-2.9.2 \
fantoccini-0.19.3 \
fastrand-1.9.0 \
- fastrand-2.0.1 \
+ fastrand-2.0.2 \
+ fdeflate-0.3.4 \
finl_unicode-1.2.0 \
- flate2-1.0.27 \
+ flate2-1.0.28 \
float-cmp-0.9.0 \
+ flume-0.11.0 \
fnv-1.0.7 \
foreign-types-0.3.2 \
foreign-types-shared-0.1.1 \
- form_urlencoded-1.2.0 \
- fred-7.0.0 \
+ form_urlencoded-1.2.1 \
+ fred-7.1.2 \
frunk-0.4.2 \
frunk_core-0.4.2 \
frunk_derives-0.4.2 \
@@ -226,380 +253,389 @@ CARGO_CRATES= actix-codec-0.5.1 \
fuchsia-zircon-sys-0.3.3 \
funty-2.0.0 \
futures-0.1.31 \
- futures-0.3.28 \
- futures-channel-0.3.28 \
- futures-core-0.3.28 \
- futures-executor-0.3.28 \
- futures-intrusive-0.4.2 \
- futures-io-0.3.28 \
- futures-lite-1.13.0 \
- futures-macro-0.3.28 \
- futures-sink-0.3.28 \
- futures-task-0.3.28 \
- futures-timer-3.0.2 \
- futures-util-0.3.28 \
+ futures-0.3.30 \
+ futures-channel-0.3.30 \
+ futures-core-0.3.30 \
+ futures-executor-0.3.30 \
+ futures-intrusive-0.5.0 \
+ futures-io-0.3.30 \
+ futures-macro-0.3.30 \
+ futures-sink-0.3.30 \
+ futures-task-0.3.30 \
+ futures-util-0.3.30 \
generic-array-0.14.7 \
gethostname-0.4.3 \
- getrandom-0.1.16 \
- getrandom-0.2.11 \
- gif-0.11.4 \
- gimli-0.28.0 \
- git2-0.17.2 \
+ getrandom-0.2.12 \
+ gimli-0.28.1 \
+ git2-0.18.3 \
glob-0.3.1 \
- globset-0.4.13 \
+ globset-0.4.14 \
globwalk-0.8.1 \
- h2-0.3.21 \
- half-1.8.2 \
+ h2-0.3.25 \
+ h2-0.4.3 \
+ half-2.4.0 \
hashbrown-0.12.3 \
+ hashbrown-0.13.2 \
hashbrown-0.14.3 \
hashlink-0.8.4 \
headers-0.3.9 \
headers-core-0.2.0 \
heck-0.4.1 \
- hermit-abi-0.3.3 \
+ hermit-abi-0.3.9 \
hex-0.4.3 \
- hkdf-0.12.3 \
+ hkdf-0.12.4 \
hmac-0.12.1 \
- http-0.2.9 \
- http-body-0.4.5 \
- http-types-2.12.0 \
+ home-0.5.9 \
+ http-0.2.12 \
+ http-1.1.0 \
+ http-body-0.4.6 \
+ http-body-1.0.0 \
+ http-body-util-0.1.1 \
httparse-1.8.0 \
httpdate-1.0.3 \
humansize-2.1.3 \
- hyper-0.14.27 \
+ hyper-0.14.28 \
+ hyper-1.2.0 \
hyper-proxy-0.9.1 \
hyper-rustls-0.23.2 \
+ hyper-rustls-0.24.2 \
hyper-timeout-0.4.1 \
hyper-tls-0.5.0 \
- iana-time-zone-0.1.58 \
+ hyper-util-0.1.3 \
+ iana-time-zone-0.1.60 \
iana-time-zone-haiku-0.1.2 \
ident_case-1.0.1 \
- idna-0.4.0 \
- ignore-0.4.20 \
- image-0.23.14 \
+ idna-0.5.0 \
+ ignore-0.4.22 \
+ image-0.25.1 \
impl-more-0.1.6 \
indexmap-1.9.3 \
- indexmap-2.1.0 \
- infer-0.2.3 \
- infer-0.13.0 \
+ indexmap-2.2.6 \
+ infer-0.15.0 \
instant-0.1.12 \
iovec-0.1.4 \
- ipnet-2.8.0 \
- is-terminal-0.4.9 \
+ ipnet-2.9.0 \
+ is-terminal-0.4.12 \
+ iso_country-0.1.4 \
+ iso_currency-0.4.4 \
+ isocountry-0.3.2 \
itertools-0.10.5 \
itertools-0.11.0 \
- itoa-1.0.9 \
- jobserver-0.1.26 \
- josekit-0.8.3 \
- jpeg-decoder-0.1.22 \
- js-sys-0.3.64 \
+ itertools-0.12.1 \
+ itoa-1.0.11 \
+ jobserver-0.1.28 \
+ josekit-0.8.6 \
+ js-sys-0.3.69 \
json5-0.4.1 \
- jsonwebtoken-8.3.0 \
+ jsonwebtoken-9.2.0 \
kernel32-sys-0.2.2 \
language-tags-0.3.2 \
lazy_static-1.4.0 \
- libc-0.2.150 \
- libgit2-sys-0.15.2+1.6.4 \
+ libc-0.2.153 \
+ libgit2-sys-0.16.2+1.7.2 \
libm-0.2.8 \
libmimalloc-sys-0.1.35 \
- libz-sys-1.1.12 \
+ libsqlite3-sys-0.27.0 \
+ libz-sys-1.1.16 \
linked-hash-map-0.5.6 \
- linux-raw-sys-0.4.8 \
- local-channel-0.1.4 \
- local-waker-0.1.3 \
+ linux-raw-sys-0.4.13 \
+ local-channel-0.1.5 \
+ local-waker-0.1.4 \
lock_api-0.3.4 \
- lock_api-0.4.10 \
- log-0.4.20 \
+ lock_api-0.4.11 \
+ log-0.4.21 \
lru-cache-0.1.2 \
luhn-1.0.1 \
- mach2-0.4.1 \
matchers-0.1.0 \
matchit-0.7.3 \
- maud-0.25.0 \
- maud_macros-0.25.0 \
+ maud-0.26.0 \
+ maud_macros-0.26.0 \
maybe-uninit-2.0.0 \
md-5-0.10.6 \
md5-0.7.0 \
- memchr-2.6.4 \
+ memchr-2.7.2 \
memoffset-0.5.6 \
- memoffset-0.9.0 \
mimalloc-0.1.39 \
mime-0.3.17 \
mime_guess-2.0.4 \
minimal-lexical-0.2.1 \
- miniz_oxide-0.3.7 \
- miniz_oxide-0.4.4 \
- miniz_oxide-0.7.1 \
+ miniz_oxide-0.7.2 \
mio-0.6.23 \
- mio-0.8.8 \
+ mio-0.8.11 \
mio-uds-0.6.8 \
miow-0.2.2 \
- moka-0.12.1 \
+ moka-0.12.5 \
mutually_exclusive_features-0.0.3 \
nanoid-0.4.0 \
native-tls-0.2.11 \
net2-0.2.39 \
+ nix-0.28.0 \
nom-7.1.3 \
nu-ansi-term-0.46.0 \
num-bigint-0.4.4 \
- num-integer-0.1.45 \
- num-iter-0.1.43 \
- num-rational-0.3.2 \
- num-traits-0.2.17 \
+ num-bigint-dig-0.8.4 \
+ num-conv-0.1.0 \
+ num-integer-0.1.46 \
+ num-iter-0.1.44 \
+ num-traits-0.2.18 \
num_cpus-1.16.0 \
num_enum-0.5.11 \
num_enum_derive-0.5.11 \
- object-0.32.1 \
- oid-registry-0.6.1 \
- once_cell-1.18.0 \
+ num_threads-0.1.7 \
+ object-0.32.2 \
+ oid-registry-0.7.0 \
+ once_cell-1.19.0 \
oncemutex-0.1.1 \
oorandom-11.1.3 \
- opaque-debug-0.3.0 \
- openssl-0.10.60 \
+ opensearch-2.2.0 \
+ openssl-0.10.64 \
openssl-macros-0.1.1 \
openssl-probe-0.1.5 \
- openssl-sys-0.9.96 \
+ openssl-sys-0.9.102 \
opentelemetry-0.19.0 \
opentelemetry-otlp-0.12.0 \
opentelemetry-proto-0.2.0 \
opentelemetry_api-0.19.0 \
opentelemetry_sdk-0.19.0 \
- ordered-multimap-0.4.3 \
+ ordered-multimap-0.6.0 \
outref-0.5.1 \
overload-0.1.1 \
- parking-2.1.1 \
parking_lot-0.9.0 \
- parking_lot-0.11.2 \
parking_lot-0.12.1 \
parking_lot_core-0.6.3 \
- parking_lot_core-0.8.6 \
- parking_lot_core-0.9.8 \
+ parking_lot_core-0.9.9 \
parse-size-1.0.0 \
parse-zoneinfo-0.3.0 \
password-hash-0.5.0 \
paste-1.0.14 \
pathdiff-0.2.1 \
- pem-1.1.1 \
- percent-encoding-2.3.0 \
- pest-2.7.4 \
- pest_derive-2.7.4 \
- pest_generator-2.7.4 \
- pest_meta-2.7.4 \
+ pem-3.0.3 \
+ pem-rfc7468-0.7.0 \
+ percent-encoding-2.3.1 \
+ pest-2.7.8 \
+ pest_derive-2.7.8 \
+ pest_generator-2.7.8 \
+ pest_meta-2.7.8 \
phf-0.11.2 \
phf_codegen-0.11.2 \
phf_generator-0.11.2 \
phf_shared-0.11.2 \
phonenumber-0.3.3+8.13.9 \
- pin-project-1.1.3 \
- pin-project-internal-1.1.3 \
- pin-project-lite-0.2.13 \
+ pin-project-1.1.5 \
+ pin-project-internal-1.1.5 \
+ pin-project-lite-0.2.14 \
pin-utils-0.1.0 \
- pkg-config-0.3.27 \
+ pkcs1-0.7.5 \
+ pkcs8-0.10.2 \
+ pkg-config-0.3.30 \
plotters-0.3.5 \
plotters-backend-0.3.5 \
plotters-svg-0.3.5 \
- png-0.16.8 \
+ png-0.17.13 \
+ powerfmt-0.2.0 \
ppv-lite86-0.2.17 \
pq-sys-0.4.8 \
proc-macro-crate-1.3.1 \
- proc-macro-crate-2.0.0 \
+ proc-macro-crate-3.1.0 \
proc-macro-error-1.0.4 \
proc-macro-error-attr-1.0.4 \
- proc-macro2-1.0.70 \
- proptest-1.3.1 \
+ proc-macro2-1.0.79 \
+ proptest-1.4.0 \
prost-0.11.9 \
prost-derive-0.11.9 \
ptr_meta-0.1.4 \
ptr_meta_derive-0.1.4 \
- pulldown-cmark-0.9.3 \
- qrcode-0.12.0 \
- quanta-0.11.1 \
+ pulldown-cmark-0.9.6 \
+ qrcode-0.14.0 \
+ quanta-0.12.2 \
quick-error-1.2.3 \
quick-xml-0.28.2 \
quick-xml-0.31.0 \
- quote-1.0.33 \
+ quote-1.0.35 \
r2d2-0.8.10 \
radium-0.7.0 \
- rand-0.7.3 \
rand-0.8.5 \
- rand_chacha-0.2.2 \
rand_chacha-0.3.1 \
- rand_core-0.5.1 \
rand_core-0.6.4 \
- rand_hc-0.2.0 \
rand_xorshift-0.3.0 \
- raw-cpuid-10.7.0 \
- rayon-1.8.0 \
- rayon-core-1.12.0 \
- rdkafka-0.36.0 \
+ raw-cpuid-11.0.1 \
+ rayon-1.10.0 \
+ rayon-core-1.12.1 \
+ rdkafka-0.36.2 \
rdkafka-sys-4.7.0+2.3.0 \
redis-protocol-4.1.0 \
redox_syscall-0.1.57 \
- redox_syscall-0.2.16 \
- redox_syscall-0.3.5 \
- redox_users-0.4.3 \
- regex-1.9.6 \
+ redox_syscall-0.4.1 \
+ regex-1.10.4 \
regex-automata-0.1.10 \
- regex-automata-0.3.9 \
+ regex-automata-0.4.6 \
regex-cache-0.2.1 \
+ regex-lite-0.1.5 \
regex-syntax-0.6.29 \
- regex-syntax-0.7.5 \
- rend-0.4.1 \
- reqwest-0.11.22 \
- retain_mut-0.1.9 \
+ regex-syntax-0.8.3 \
+ rend-0.4.2 \
+ reqwest-0.11.27 \
ring-0.16.20 \
- rkyv-0.7.42 \
- rkyv_derive-0.7.42 \
- ron-0.7.1 \
+ ring-0.17.8 \
+ rkyv-0.7.44 \
+ rkyv_derive-0.7.44 \
+ ron-0.8.1 \
ron-parser-0.1.4 \
- roxmltree-0.18.1 \
- rust-embed-6.8.1 \
- rust-embed-impl-6.8.1 \
- rust-embed-utils-7.8.1 \
- rust-ini-0.18.0 \
- rust_decimal-1.33.1 \
- rust_decimal_macros-1.33.1 \
+ roxmltree-0.19.0 \
+ rsa-0.9.6 \
+ rust-ini-0.19.0 \
+ rust_decimal-1.35.0 \
rustc-demangle-0.1.23 \
rustc-hash-1.1.0 \
rustc_version-0.2.3 \
rustc_version-0.4.0 \
rusticata-macros-4.1.0 \
- rustix-0.38.17 \
+ rustify-0.5.3 \
+ rustify_derive-0.5.2 \
+ rustix-0.38.32 \
rustls-0.20.9 \
- rustls-0.21.7 \
+ rustls-0.21.10 \
rustls-native-certs-0.6.3 \
- rustls-pemfile-1.0.3 \
- rustls-webpki-0.101.6 \
+ rustls-pemfile-1.0.4 \
+ rustls-webpki-0.101.7 \
rustversion-1.0.14 \
rusty-fork-0.3.0 \
- rusty-money-0.4.1 \
- ryu-1.0.15 \
+ ryu-1.0.17 \
same-file-1.0.6 \
- schannel-0.1.22 \
+ schannel-0.1.23 \
scheduled-thread-pool-0.2.7 \
- scoped_threadpool-0.1.9 \
scopeguard-1.2.0 \
- sct-0.7.0 \
+ sct-0.7.1 \
seahash-4.1.0 \
security-framework-2.9.2 \
security-framework-sys-2.9.1 \
semver-0.9.0 \
- semver-1.0.19 \
+ semver-1.0.22 \
semver-parser-0.7.0 \
- serde-1.0.193 \
+ serde-1.0.197 \
serde-wasm-bindgen-0.5.0 \
- serde_derive-1.0.193 \
- serde_json-1.0.108 \
- serde_path_to_error-0.1.14 \
+ serde-wasm-bindgen-0.6.5 \
+ serde_derive-1.0.197 \
+ serde_json-1.0.115 \
+ serde_path_to_error-0.1.16 \
serde_plain-1.0.2 \
- serde_qs-0.8.5 \
serde_qs-0.12.0 \
- serde_repr-0.1.16 \
- serde_spanned-0.6.3 \
+ serde_repr-0.1.18 \
+ serde_spanned-0.6.5 \
serde_urlencoded-0.7.1 \
- serde_with-3.4.0 \
- serde_with_macros-3.4.0 \
- serial_test-2.0.0 \
- serial_test_derive-2.0.0 \
- sha-1-0.9.8 \
+ serde_with-3.7.0 \
+ serde_with_macros-3.7.0 \
+ serial_test-3.0.0 \
+ serial_test_derive-3.0.0 \
sha1-0.10.6 \
sha2-0.10.8 \
sharded-slab-0.1.7 \
- shellexpand-2.1.2 \
signal-hook-0.3.17 \
signal-hook-registry-1.4.1 \
signal-hook-tokio-0.3.1 \
+ signature-2.2.0 \
+ simd-adler32-0.3.7 \
simdutf8-0.1.4 \
simple_asn1-0.6.2 \
siphasher-0.3.11 \
skeptic-0.13.7 \
slab-0.4.9 \
- slug-0.1.4 \
+ slug-0.1.5 \
smallvec-0.6.14 \
- smallvec-1.11.1 \
- socket2-0.4.9 \
- socket2-0.5.4 \
+ smallvec-1.13.2 \
+ socket2-0.5.6 \
spin-0.5.2 \
- sqlformat-0.2.2 \
- sqlx-0.6.3 \
- sqlx-core-0.6.3 \
- sqlx-macros-0.6.3 \
- sqlx-rt-0.6.3 \
+ spin-0.9.8 \
+ spki-0.7.3 \
+ sqlformat-0.2.3 \
+ sqlx-0.7.3 \
+ sqlx-core-0.7.3 \
+ sqlx-macros-0.7.3 \
+ sqlx-macros-core-0.7.3 \
+ sqlx-mysql-0.7.3 \
+ sqlx-postgres-0.7.3 \
+ sqlx-sqlite-0.7.3 \
stringmatch-0.4.0 \
stringprep-0.1.4 \
strsim-0.10.0 \
strum-0.24.1 \
strum-0.25.0 \
+ strum-0.26.2 \
strum_macros-0.24.3 \
- strum_macros-0.25.2 \
- subtle-2.4.1 \
+ strum_macros-0.25.3 \
+ strum_macros-0.26.2 \
+ subtle-2.5.0 \
syn-1.0.109 \
- syn-2.0.39 \
+ syn-2.0.57 \
syn_derive-0.1.8 \
sync_wrapper-0.1.2 \
synstructure-0.12.6 \
+ synstructure-0.13.1 \
system-configuration-0.5.1 \
system-configuration-sys-0.5.0 \
tagptr-0.2.0 \
tap-1.0.1 \
- tempfile-3.8.0 \
+ tempfile-3.10.1 \
tera-1.19.1 \
- test-case-3.2.1 \
- test-case-core-3.2.1 \
- test-case-macros-3.2.1 \
+ test-case-3.3.1 \
+ test-case-core-3.3.1 \
+ test-case-macros-3.3.1 \
thirtyfour-0.31.0 \
thirtyfour-macros-0.1.1 \
- thiserror-1.0.49 \
- thiserror-impl-1.0.49 \
- thread_local-1.1.7 \
- tiff-0.6.1 \
- time-0.3.23 \
- time-core-0.1.1 \
- time-macros-0.2.10 \
+ thiserror-1.0.58 \
+ thiserror-impl-1.0.58 \
+ thread_local-1.1.8 \
+ time-0.3.36 \
+ time-core-0.1.2 \
+ time-macros-0.2.18 \
+ tiny-keccak-2.0.2 \
tinytemplate-1.2.1 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
tokio-0.1.22 \
- tokio-1.32.0 \
+ tokio-1.37.0 \
tokio-codec-0.1.2 \
tokio-current-thread-0.1.7 \
tokio-executor-0.1.10 \
tokio-fs-0.1.7 \
tokio-io-0.1.13 \
tokio-io-timeout-1.2.0 \
- tokio-macros-2.1.0 \
+ tokio-macros-2.2.0 \
tokio-native-tls-0.3.1 \
tokio-reactor-0.1.12 \
tokio-rustls-0.23.4 \
- tokio-stream-0.1.14 \
+ tokio-rustls-0.24.1 \
+ tokio-stream-0.1.15 \
tokio-sync-0.1.8 \
tokio-tcp-0.1.4 \
tokio-threadpool-0.1.18 \
tokio-timer-0.2.13 \
tokio-udp-0.1.6 \
tokio-uds-0.2.7 \
- tokio-util-0.7.9 \
- toml-0.5.11 \
- toml-0.7.4 \
- toml_datetime-0.6.3 \
- toml_edit-0.19.14 \
- toml_edit-0.20.2 \
+ tokio-util-0.7.10 \
+ toml-0.8.12 \
+ toml_datetime-0.6.5 \
+ toml_edit-0.19.15 \
+ toml_edit-0.21.1 \
+ toml_edit-0.22.9 \
tonic-0.8.3 \
+ totp-rs-5.5.1 \
tower-0.4.13 \
tower-layer-0.3.2 \
tower-service-0.3.2 \
- tracing-0.1.36 \
- tracing-actix-web-0.7.9 \
- tracing-appender-0.2.2 \
- tracing-attributes-0.1.22 \
- tracing-core-0.1.31 \
+ tracing-0.1.40 \
+ tracing-actix-web-0.7.10 \
+ tracing-appender-0.2.3 \
+ tracing-attributes-0.1.27 \
+ tracing-core-0.1.32 \
tracing-futures-0.2.5 \
- tracing-log-0.1.3 \
+ tracing-log-0.1.4 \
+ tracing-log-0.2.0 \
tracing-opentelemetry-0.19.0 \
tracing-serde-0.1.3 \
- tracing-subscriber-0.3.17 \
- triomphe-0.1.9 \
- try-lock-0.2.4 \
+ tracing-subscriber-0.3.18 \
+ triomphe-0.1.11 \
+ try-lock-0.2.5 \
typenum-1.17.0 \
ucd-trie-0.1.6 \
unarray-0.1.4 \
@@ -610,77 +646,87 @@ CARGO_CRATES= actix-codec-0.5.1 \
unic-ucd-segment-0.9.0 \
unic-ucd-version-0.9.0 \
unicase-2.7.0 \
- unicode-bidi-0.3.13 \
+ unicode-bidi-0.3.15 \
unicode-ident-1.0.12 \
- unicode-normalization-0.1.22 \
- unicode-segmentation-1.10.1 \
+ unicode-normalization-0.1.23 \
+ unicode-segmentation-1.11.0 \
unicode-xid-0.2.4 \
unicode_categories-0.1.1 \
- unidecode-0.3.0 \
untrusted-0.7.1 \
- url-2.4.1 \
+ untrusted-0.9.0 \
+ url-2.5.0 \
urlencoding-2.1.3 \
urlparse-0.7.3 \
- utoipa-3.5.0 \
- utoipa-gen-3.5.0 \
- utoipa-swagger-ui-3.1.5 \
- uuid-1.4.1 \
- validator-0.16.1 \
+ utoipa-4.2.0 \
+ utoipa-gen-4.2.0 \
+ uuid-1.8.0 \
+ validator-0.17.0 \
valuable-0.1.0 \
+ vaultrs-0.7.2 \
vcpkg-0.2.15 \
- vergen-8.2.1 \
+ vergen-8.3.1 \
version_check-0.9.4 \
+ void-1.0.2 \
vsimd-0.8.0 \
wait-timeout-0.2.0 \
- waker-fn-1.1.1 \
- walkdir-2.4.0 \
+ walkdir-2.5.0 \
want-0.3.1 \
- wasi-0.9.0+wasi-snapshot-preview1 \
wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.87 \
- wasm-bindgen-backend-0.2.87 \
- wasm-bindgen-futures-0.4.37 \
- wasm-bindgen-macro-0.2.87 \
- wasm-bindgen-macro-support-0.2.87 \
- wasm-bindgen-shared-0.2.87 \
- web-sys-0.3.64 \
+ wasite-0.1.0 \
+ wasm-bindgen-0.2.92 \
+ wasm-bindgen-backend-0.2.92 \
+ wasm-bindgen-futures-0.4.42 \
+ wasm-bindgen-macro-0.2.92 \
+ wasm-bindgen-macro-support-0.2.92 \
+ wasm-bindgen-shared-0.2.92 \
+ web-sys-0.3.69 \
webdriver-0.46.0 \
- webpki-0.22.2 \
+ webpki-0.22.4 \
webpki-roots-0.22.6 \
- weezl-0.1.7 \
- whoami-1.4.1 \
+ webpki-roots-0.25.4 \
+ whoami-1.5.1 \
winapi-0.2.8 \
winapi-0.3.9 \
winapi-build-0.1.1 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-util-0.1.6 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
- windows-core-0.51.1 \
+ windows-core-0.52.0 \
windows-sys-0.48.0 \
+ windows-sys-0.52.0 \
windows-targets-0.48.5 \
+ windows-targets-0.52.4 \
windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_gnullvm-0.52.4 \
windows_aarch64_msvc-0.48.5 \
+ windows_aarch64_msvc-0.52.4 \
windows_i686_gnu-0.48.5 \
+ windows_i686_gnu-0.52.4 \
windows_i686_msvc-0.48.5 \
+ windows_i686_msvc-0.52.4 \
windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnu-0.52.4 \
windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_gnullvm-0.52.4 \
windows_x86_64_msvc-0.48.5 \
- winnow-0.5.19 \
+ windows_x86_64_msvc-0.52.4 \
+ winnow-0.5.40 \
+ winnow-0.6.5 \
winreg-0.50.0 \
- wiremock-0.5.18 \
+ wiremock-0.6.0 \
ws2_32-sys-0.2.1 \
wyz-0.5.1 \
- x509-parser-0.15.1 \
+ x509-parser-0.16.0 \
xmlparser-0.13.6 \
yaml-rust-0.4.5 \
- zerocopy-0.7.31 \
- zerocopy-derive-0.7.31 \
- zeroize-1.6.0 \
- zip-0.6.6 \
- zstd-0.12.4 \
- zstd-safe-6.0.6 \
- zstd-sys-2.0.8+zstd.1.5.5 \
- async-bb8-diesel@git+https://github.com/jarnura/async-bb8-diesel?rev=53b4ab901aab7635c8215fd1c2d542c8db443094\#53b4ab901aab7635c8215fd1c2d542c8db443094
+ zerocopy-0.7.32 \
+ zerocopy-derive-0.7.32 \
+ zeroize-1.7.0 \
+ zstd-0.13.0 \
+ zstd-safe-7.0.0 \
+ zstd-sys-2.0.9+zstd.1.5.5 \
+ async-bb8-diesel@git+https://github.com/jarnura/async-bb8-diesel?rev=53b4ab901aab7635c8215fd1c2d542c8db443094\#53b4ab901aab7635c8215fd1c2d542c8db443094 \
+ rusty-money@git+https://github.com/varunsrin/rusty_money?rev=bbc0150742a0fff905225ff11ee09388e9babdcc\#bbc0150742a0fff905225ff11ee09388e9babdcc
RUSTFLAGS+= --cfg uuid_unstable