aboutsummaryrefslogtreecommitdiff
path: root/ftp/unftp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/unftp/Makefile')
-rw-r--r--ftp/unftp/Makefile362
1 files changed, 362 insertions, 0 deletions
diff --git a/ftp/unftp/Makefile b/ftp/unftp/Makefile
new file mode 100644
index 000000000000..bfa90c1af196
--- /dev/null
+++ b/ftp/unftp/Makefile
@@ -0,0 +1,362 @@
+PORTNAME= unftp
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.14.5
+PORTREVISION= 1
+CATEGORIES= ftp
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= FTP(S) server with a couple of twists written in Rust
+WWW= https://github.com/bolcom/unFTP
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cargo
+
+USE_GITHUB= yes
+GH_ACCOUNT= bolcom
+GH_PROJECT= unFTP
+
+CARGO_CRATES= addr2line-0.21.0 \
+ adler-1.0.2 \
+ aho-corasick-1.0.5 \
+ android-tzdata-0.1.1 \
+ android_system_properties-0.1.5 \
+ anyhow-1.0.71 \
+ arc-swap-1.6.0 \
+ asn1-rs-0.5.2 \
+ asn1-rs-derive-0.4.0 \
+ asn1-rs-impl-0.1.0 \
+ async-trait-0.1.75 \
+ atty-0.2.14 \
+ autocfg-1.1.0 \
+ axum-0.6.18 \
+ axum-core-0.3.4 \
+ backtrace-0.3.69 \
+ base64-0.13.1 \
+ base64-0.21.5 \
+ bitflags-1.3.2 \
+ bitflags-2.4.1 \
+ block-buffer-0.10.4 \
+ built-0.5.2 \
+ bumpalo-3.13.0 \
+ bytecount-0.6.3 \
+ byteorder-1.5.0 \
+ bytes-1.5.0 \
+ camino-1.1.6 \
+ cargo-lock-8.0.3 \
+ cargo-platform-0.1.5 \
+ cargo_metadata-0.14.2 \
+ cc-1.0.83 \
+ cfg-if-1.0.0 \
+ chrono-0.4.31 \
+ clap-3.2.25 \
+ clap_derive-3.2.25 \
+ clap_lex-0.2.4 \
+ codespan-reporting-0.11.1 \
+ combine-4.6.6 \
+ console-api-0.5.0 \
+ console-subscriber-0.1.10 \
+ convert_case-0.4.0 \
+ core-foundation-0.9.3 \
+ core-foundation-sys-0.8.6 \
+ crc32fast-1.3.2 \
+ crossbeam-channel-0.5.10 \
+ crossbeam-epoch-0.9.17 \
+ crossbeam-utils-0.8.18 \
+ crypto-common-0.1.6 \
+ cxx-1.0.91 \
+ cxx-build-1.0.91 \
+ cxxbridge-flags-1.0.91 \
+ cxxbridge-macro-1.0.91 \
+ dashmap-5.5.3 \
+ data-encoding-2.5.0 \
+ der-parser-8.2.0 \
+ deranged-0.3.10 \
+ derive_more-0.99.17 \
+ diff-0.1.13 \
+ digest-0.10.7 \
+ dirs-next-2.0.0 \
+ dirs-sys-next-0.1.2 \
+ displaydoc-0.2.4 \
+ doc-comment-0.3.3 \
+ dtoa-0.4.8 \
+ either-1.8.1 \
+ errno-0.2.8 \
+ errno-0.3.8 \
+ errno-dragonfly-0.1.2 \
+ error-chain-0.12.4 \
+ fastrand-2.0.1 \
+ flate2-1.0.28 \
+ fnv-1.0.7 \
+ form_urlencoded-1.1.0 \
+ futures-0.3.30 \
+ futures-channel-0.3.30 \
+ futures-core-0.3.30 \
+ futures-executor-0.3.30 \
+ futures-io-0.3.30 \
+ futures-macro-0.3.30 \
+ futures-sink-0.3.30 \
+ futures-task-0.3.30 \
+ futures-util-0.3.30 \
+ generic-array-0.14.7 \
+ getrandom-0.2.11 \
+ gimli-0.28.1 \
+ git2-0.15.0 \
+ glob-0.3.1 \
+ h2-0.3.19 \
+ hashbrown-0.12.3 \
+ hashbrown-0.14.3 \
+ hdrhistogram-7.5.2 \
+ heck-0.4.1 \
+ hermit-abi-0.1.19 \
+ hermit-abi-0.3.2 \
+ hex-0.4.3 \
+ http-0.2.11 \
+ http-body-0.4.5 \
+ httparse-1.8.0 \
+ httpdate-1.0.2 \
+ humantime-2.1.0 \
+ hyper-0.14.28 \
+ hyper-rustls-0.23.2 \
+ hyper-rustls-0.24.2 \
+ hyper-timeout-0.4.1 \
+ iana-time-zone-0.1.58 \
+ iana-time-zone-haiku-0.1.1 \
+ idna-0.3.0 \
+ indexmap-1.9.3 \
+ io-lifetimes-1.0.10 \
+ ipnet-2.9.0 \
+ iprange-0.6.7 \
+ itertools-0.10.5 \
+ itoa-0.4.8 \
+ itoa-1.0.10 \
+ jobserver-0.1.27 \
+ js-sys-0.3.64 \
+ lazy_static-1.4.0 \
+ libc-0.2.151 \
+ libgit2-sys-0.14.2+1.5.1 \
+ libunftp-0.19.1 \
+ libz-sys-1.1.8 \
+ link-cplusplus-1.0.8 \
+ linux-raw-sys-0.1.4 \
+ linux-raw-sys-0.4.12 \
+ lock_api-0.4.11 \
+ log-0.4.20 \
+ matchers-0.1.0 \
+ matchit-0.7.0 \
+ md-5-0.10.6 \
+ memchr-2.6.4 \
+ mime-0.3.17 \
+ minimal-lexical-0.2.1 \
+ miniz_oxide-0.7.1 \
+ mio-0.8.10 \
+ moka-0.11.3 \
+ nom-7.1.3 \
+ num-bigint-0.4.4 \
+ num-integer-0.1.45 \
+ num-traits-0.2.17 \
+ num_cpus-1.16.0 \
+ num_threads-0.1.6 \
+ object-0.32.2 \
+ oid-registry-0.6.1 \
+ once_cell-1.19.0 \
+ openssl-probe-0.1.5 \
+ os_str_bytes-6.5.0 \
+ pam-0.7.0 \
+ pam-sys-0.5.6 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.9.9 \
+ path_abs-0.5.1 \
+ percent-encoding-2.3.1 \
+ pin-project-1.0.12 \
+ pin-project-internal-1.0.12 \
+ pin-project-lite-0.2.13 \
+ pin-utils-0.1.0 \
+ pkg-config-0.3.26 \
+ powerfmt-0.2.0 \
+ ppv-lite86-0.2.17 \
+ pretty_assertions-1.4.0 \
+ proc-macro-error-1.0.4 \
+ proc-macro-error-attr-1.0.4 \
+ proc-macro2-1.0.71 \
+ procfs-0.14.2 \
+ prometheus-0.13.3 \
+ prost-0.11.9 \
+ prost-derive-0.11.9 \
+ prost-types-0.11.9 \
+ protobuf-2.28.0 \
+ proxy-protocol-0.5.0 \
+ pulldown-cmark-0.9.2 \
+ quote-1.0.33 \
+ r2d2-0.8.10 \
+ r2d2_redis-0.14.0 \
+ rand-0.8.5 \
+ rand_chacha-0.3.1 \
+ rand_core-0.6.4 \
+ redis-0.20.2 \
+ redox_syscall-0.2.16 \
+ redox_syscall-0.4.1 \
+ redox_users-0.4.3 \
+ regex-1.10.2 \
+ regex-automata-0.1.10 \
+ regex-automata-0.4.3 \
+ regex-syntax-0.6.29 \
+ regex-syntax-0.8.2 \
+ ring-0.16.20 \
+ ring-0.17.7 \
+ rustc-demangle-0.1.23 \
+ rustc_version-0.4.0 \
+ rusticata-macros-4.1.0 \
+ rustix-0.36.6 \
+ rustix-0.38.28 \
+ rustls-0.20.8 \
+ rustls-0.21.10 \
+ rustls-native-certs-0.6.2 \
+ rustls-pemfile-1.0.4 \
+ rustls-webpki-0.101.7 \
+ rustversion-1.0.12 \
+ ryu-1.0.16 \
+ same-file-1.0.6 \
+ schannel-0.1.21 \
+ scheduled-thread-pool-0.2.7 \
+ scopeguard-1.2.0 \
+ scratch-1.0.3 \
+ sct-0.7.1 \
+ seahash-4.1.0 \
+ security-framework-2.7.0 \
+ security-framework-sys-2.6.1 \
+ semver-1.0.20 \
+ serde-1.0.193 \
+ serde_derive-1.0.193 \
+ serde_json-1.0.108 \
+ sha1-0.6.1 \
+ sha1_smol-1.0.0 \
+ sharded-slab-0.1.4 \
+ signal-hook-registry-1.4.1 \
+ skeptic-0.13.7 \
+ slab-0.4.9 \
+ slog-2.7.0 \
+ slog-async-2.8.0 \
+ slog-scope-4.4.0 \
+ slog-stdlog-4.1.1 \
+ slog-term-2.9.0 \
+ smallvec-1.11.2 \
+ snafu-0.6.10 \
+ snafu-derive-0.6.10 \
+ socket2-0.5.5 \
+ spin-0.5.2 \
+ spin-0.9.8 \
+ std_prelude-0.2.12 \
+ stfu8-0.2.6 \
+ strsim-0.10.0 \
+ syn-1.0.109 \
+ syn-2.0.42 \
+ sync_wrapper-0.1.2 \
+ synstructure-0.12.6 \
+ tagptr-0.2.0 \
+ take_mut-0.2.2 \
+ tempfile-3.8.1 \
+ term-0.7.0 \
+ termcolor-1.4.0 \
+ textwrap-0.16.0 \
+ thiserror-1.0.51 \
+ thiserror-impl-1.0.51 \
+ thread_local-1.1.7 \
+ time-0.3.31 \
+ time-core-0.1.2 \
+ time-macros-0.2.16 \
+ tinyvec-1.6.0 \
+ tinyvec_macros-0.1.0 \
+ tokio-1.35.1 \
+ tokio-io-timeout-1.2.0 \
+ tokio-macros-2.2.0 \
+ tokio-rustls-0.23.4 \
+ tokio-rustls-0.24.1 \
+ tokio-stream-0.1.14 \
+ tokio-util-0.7.10 \
+ toml-0.5.10 \
+ tonic-0.9.2 \
+ tower-0.4.13 \
+ tower-layer-0.3.2 \
+ tower-service-0.3.2 \
+ tracing-0.1.40 \
+ tracing-attributes-0.1.27 \
+ tracing-core-0.1.32 \
+ tracing-subscriber-0.3.17 \
+ triomphe-0.1.11 \
+ try-lock-0.2.4 \
+ typenum-1.17.0 \
+ unftp-auth-jsonfile-0.3.3 \
+ unftp-auth-pam-0.2.4 \
+ unftp-auth-rest-0.2.4 \
+ unftp-sbe-fs-0.2.4 \
+ unftp-sbe-gcs-0.2.5 \
+ unftp-sbe-restrict-0.1.1 \
+ unftp-sbe-rooter-0.2.0 \
+ unicase-2.7.0 \
+ unicode-bidi-0.3.8 \
+ unicode-ident-1.0.12 \
+ unicode-normalization-0.1.22 \
+ unicode-width-0.1.11 \
+ unicode-xid-0.2.4 \
+ untrusted-0.7.1 \
+ untrusted-0.9.0 \
+ url-2.3.1 \
+ users-0.8.1 \
+ uuid-1.6.1 \
+ valid-0.3.1 \
+ valuable-0.1.0 \
+ vcpkg-0.2.15 \
+ version_check-0.9.4 \
+ walkdir-2.4.0 \
+ want-0.3.0 \
+ wasi-0.11.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.87 \
+ wasm-bindgen-backend-0.2.87 \
+ wasm-bindgen-macro-0.2.87 \
+ wasm-bindgen-macro-support-0.2.87 \
+ wasm-bindgen-shared-0.2.87 \
+ web-sys-0.3.61 \
+ webpki-0.22.0 \
+ winapi-0.3.9 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.5 \
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-core-0.51.1 \
+ windows-sys-0.42.0 \
+ windows-sys-0.48.0 \
+ windows-sys-0.52.0 \
+ windows-targets-0.48.5 \
+ windows-targets-0.52.0 \
+ windows_aarch64_gnullvm-0.42.2 \
+ windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_gnullvm-0.52.0 \
+ windows_aarch64_msvc-0.42.2 \
+ windows_aarch64_msvc-0.48.5 \
+ windows_aarch64_msvc-0.52.0 \
+ windows_i686_gnu-0.42.2 \
+ windows_i686_gnu-0.48.5 \
+ windows_i686_gnu-0.52.0 \
+ windows_i686_msvc-0.42.2 \
+ windows_i686_msvc-0.48.5 \
+ windows_i686_msvc-0.52.0 \
+ windows_x86_64_gnu-0.42.2 \
+ windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnu-0.52.0 \
+ windows_x86_64_gnullvm-0.42.2 \
+ windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_gnullvm-0.52.0 \
+ windows_x86_64_msvc-0.42.2 \
+ windows_x86_64_msvc-0.48.5 \
+ windows_x86_64_msvc-0.52.0 \
+ x509-parser-0.14.0 \
+ yansi-0.5.1 \
+ yup-oauth2-8.3.1
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>