aboutsummaryrefslogtreecommitdiff
path: root/games/sdl-sopwith/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'games/sdl-sopwith/files/patch-configure.ac')
-rw-r--r--games/sdl-sopwith/files/patch-configure.ac20
1 files changed, 8 insertions, 12 deletions
diff --git a/games/sdl-sopwith/files/patch-configure.ac b/games/sdl-sopwith/files/patch-configure.ac
index f7e9ca2c436e..4ba212ed45c0 100644
--- a/games/sdl-sopwith/files/patch-configure.ac
+++ b/games/sdl-sopwith/files/patch-configure.ac
@@ -1,15 +1,11 @@
---- configure.ac.orig 2024-02-03 20:39:30 UTC
+--- configure.ac.orig 2024-04-18 23:56:19 UTC
+++ configure.ac
-@@ -29,12 +29,6 @@ AC_CHECK_FUNCS(isatty)
- AC_CHECK_HEADERS(stdbool.h)
- AC_CHECK_FUNCS(isatty)
+@@ -27,7 +27,7 @@ if test "$GCC" = "yes"; then
--if test "$GCC" = "yes"
--then
-- WARNINGS="-Wall -Wdeclaration-after-statement -Wredundant-decls"
-- CFLAGS="-O$OPT_LEVEL -g $WARNINGS $CFLAGS"
--fi
--
- dnl network libraries
+ if test "$GCC" = "yes"; then
+ WARNINGS="-Wall -Wdeclaration-after-statement -Wredundant-decls"
+- CFLAGS="-O2 -g $WARNINGS $CFLAGS"
++ CFLAGS="$WARNINGS $CFLAGS"
+ fi
- SOCKET_LIBS=
+ dnl network libraries; not all systems have the sockets API in their libc: