aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/glfw/Makefile')
-rw-r--r--graphics/glfw/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 39b600a824c8..3b2e330c99ac 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -3,14 +3,14 @@ DISTVERSION= 3.4
CATEGORIES= graphics
MASTER_SITES= https://github.com/glfw/glfw/releases/download/${DISTVERSION}/
-MAINTAINER= eduardo@FreeBSD.org
+MAINTAINER= vvd@FreeBSD.org
COMMENT= Portable framework for OpenGL development
WWW= https://www.glfw.org/
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= cmake:insource localbase zip
+USES= cmake:insource localbase:ldflags zip
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
@@ -61,6 +61,13 @@ X11_USES= xorg
X11_USE= XORG=x11,xcursor,xi,xinerama,xrandr,xxf86vm
X11_CMAKE_BOOL= GLFW_BUILD_X11
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES} && ${PORT_OPTIONS:MPREEDIT}
+LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
+TESTS_FILES= input_text
+.endif
+
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/docs/html/search
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
@@ -77,8 +84,9 @@ do-install-EXAMPLES-on:
${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/tests && ${INSTALL_PROGRAM} \
allocator clipboard cursor empty events gamma glfwinfo icon \
- iconify inputlag joysticks monitors msaa reopen tearing threads \
- timeout title triangle-vulkan window \
+ iconify inputlag joysticks monitors msaa reopen \
+ tearing threads timeout title triangle-vulkan window \
+ ${TESTS_FILES} \
${STAGEDIR}${EXAMPLESDIR}/tests
.include <bsd.port.mk>