aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-demos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mesa-demos/Makefile')
-rw-r--r--graphics/mesa-demos/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/graphics/mesa-demos/Makefile b/graphics/mesa-demos/Makefile
index f8a8bb89904e..5c3ff5932655 100644
--- a/graphics/mesa-demos/Makefile
+++ b/graphics/mesa-demos/Makefile
@@ -1,8 +1,8 @@
PORTNAME= mesa-demos
-PORTVERSION= 8.4.0
-PORTREVISION= 3
+PORTVERSION= 8.5.0
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/demos/ #${PORTVERSION}/
+MASTER_SITES= https://mesa.freedesktop.org/archive/demos/${PORTVERSION}/ \
+ ftp://ftp.freedesktop.org/pub/mesa/demos/ #${PORTVERSION}/
MAINTAINER= x11@FreeBSD.org
COMMENT= OpenGL demos distributed with Mesa
@@ -10,17 +10,18 @@ WWW= https://www.mesa3d.org/
LICENSE= MIT
-LIB_DEPENDS= libdrm.so:graphics/libdrm
-
CONFLICTS_INSTALL= glx-utils
-USES= gmake gl localbase pkgconfig tar:bzip2 xorg
-GNU_CONFIGURE= yes
-USE_GL= egl gbm gl glesv2 glew glu glut
+USES= gl localbase meson pkgconfig tar:bzip2 xorg
+USE_GL= egl gl glesv2 glu glut
USE_XORG= xorgproto x11 xdamage xext xfixes xi xxf86vm
-CONFIGURE_ARGS+=--disable-gles1 --disable-osmesa --disable-vg --disable-wayland \
- --with-system-data-files
+MESON_ARGS+= -Dwith-glut=${LOCALBASE} \
+ -Dgles1=disabled \
+ -Dlibdrm=disabled \
+ -Dosmesa=disabled \
+ -Dwayland=disabled \
+ -Dwith-system-data-files=true
.include <bsd.port.options.mk>
@@ -28,4 +29,8 @@ CONFIGURE_ARGS+=--disable-gles1 --disable-osmesa --disable-vg --disable-wayland
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+post-stage:
+ # bitmap program conflicts with x11/bitmap
+ ${MV} ${STAGEDIR}/${PREFIX}/bin/bitmap ${STAGEDIR}/${PREFIX}/bin/bitmap_demo
+
.include <bsd.port.mk>