aboutsummaryrefslogtreecommitdiff
path: root/graphics/openexr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/openexr/Makefile')
-rw-r--r--graphics/openexr/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/graphics/openexr/Makefile b/graphics/openexr/Makefile
index 94de55a0624e..9508428b37f9 100644
--- a/graphics/openexr/Makefile
+++ b/graphics/openexr/Makefile
@@ -40,13 +40,23 @@ BUILD_DEPENDS?= help2man:misc/help2man
LIB_DEPENDS?= libImath-3_1.so.29:math/Imath \
libdeflate.so:archivers/libdeflate
-USES?= cmake compiler:c++14-lang cpe pathfix pkgconfig
+USES?= cmake:testing compiler:c++14-lang cpe pathfix pkgconfig
#USE_GITHUB= yes
#GH_TUPLE= AcademySoftwareFoundation:openexr:v${PORTVERSION}
USE_LDCONFIG= yes
+CMAKE_TESTING_ON= BUILD_TESTING \
+ OPENEXR_TEST_LIBRARIES \
+ OPENEXR_TEST_PYTHON \
+ OPENEXR_TEST_TOOLS
+
+CMAKE_OFF= BUILD_TESTING \
+ OPENEXR_TEST_LIBRARIES \
+ OPENEXR_TEST_PYTHON \
+ OPENEXR_TEST_TOOLS
+
CMAKE_ARGS?= -DCMAKE_DEBUG_POSTFIX=
CPPFLAGS+= -I.
@@ -104,8 +114,5 @@ post-install-EXAMPLES-off:
${RM} -R ${STAGEDIR}${PREFIX}/share/doc/OpenEXR/examples/
@${RMDIR} ${STAGEDIR}${PREFIX}/share/doc/OpenEXR 2>/dev/null || :
-do-test:
- cd ${BUILD_WRKSRC} && ctest -j ${MAKE_JOBS_NUMBER}
-
.endif
.include <bsd.port.mk>