aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-imageio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-imageio/Makefile')
-rw-r--r--graphics/py-imageio/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/py-imageio/Makefile b/graphics/py-imageio/Makefile
index d7e7d5a7b155..05e7783b265d 100644
--- a/graphics/py-imageio/Makefile
+++ b/graphics/py-imageio/Makefile
@@ -1,5 +1,5 @@
PORTNAME= imageio
-PORTVERSION= 2.34.0
+PORTVERSION= 2.34.1
CATEGORIES= graphics python
MASTER_SITES= PYPI \
https://github.com/imageio/imageio/releases/download/v${PORTVERSION}/
@@ -13,7 +13,8 @@ WWW= https://imageio.readthedocs.io/en/stable/ \
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-# Note: www/py-requests comes from devel/py-fsspec[github]
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libfreeimage.so:graphics/freeimage
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=8.3.2:graphics/py-pillow@${PY_FLAVOR}
@@ -23,11 +24,12 @@ TEST_DEPENDS= opencv>=0:graphics/opencv \
${PYTHON_PKGNAMEPREFIX}gdal>=0:graphics/py-gdal@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fsspec>=0:devel/py-fsspec@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tifffile>=0:graphics/py-tifffile@${PY_FLAVOR}
+# devel/py-fsspec[github]
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes