aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-yaml-editor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/eclipse-yaml-editor/Makefile')
-rw-r--r--java/eclipse-yaml-editor/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/java/eclipse-yaml-editor/Makefile b/java/eclipse-yaml-editor/Makefile
new file mode 100644
index 000000000000..08fa70aac718
--- /dev/null
+++ b/java/eclipse-yaml-editor/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= eclipse-yaml-editor
+PORTVERSION= 1.9.0
+CATEGORIES= java devel
+
+MAINTAINER= mizhka@FreeBSD.org
+COMMENT= Eclipse plugin for YAML editing
+WWW= https://github.com/de-jcup/eclipse-yaml-editor/wiki
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:java/eclipse
+
+USE_GITHUB= YES
+GH_TUPLE= de-jcup:update-site-${PORTNAME}:99ea8dc
+
+NO_ARCH= YES
+NO_BUILD= YES
+
+PLUGINDIR= share/eclipse/dropins/${PORTNAME}/eclipse
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+do-install:
+ @(cd ${WRKSRC}/update-site/ && \
+ ${COPYTREE_SHARE} "features plugins" ${STAGEDIR}${PREFIX}/${PLUGINDIR})
+ @(${FIND} ${STAGEDIR}${PREFIX}/${PLUGINDIR} -type f \
+ ! -name "*${PORTVERSION}*" -delete)
+
+.include <bsd.port.mk>