aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang-runtime21/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/erlang-runtime21/Makefile')
-rw-r--r--lang/erlang-runtime21/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/lang/erlang-runtime21/Makefile b/lang/erlang-runtime21/Makefile
index a466b48bf01e..c593e84b235e 100644
--- a/lang/erlang-runtime21/Makefile
+++ b/lang/erlang-runtime21/Makefile
@@ -1,7 +1,7 @@
PORTNAME= erlang
DISTVERSIONPREFIX= OTP-
DISTVERSION= 21.3.8.24
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang parallel java
PKGNAMESUFFIX= -runtime21
DIST_SUBDIR= erlang
@@ -13,15 +13,14 @@ WWW= https://www.erlang.org/
LICENSE= APACHE20
USES= autoreconf:build,2.69 compiler cpe gmake ncurses perl5
+CPE_VENDOR= erlang
+CPE_PRODUCT= erlang/otp
USE_GITHUB= nodefault
GH_ACCOUNT= erlang:otp,corba
GH_PROJECT= otp:otp corba:corba
GH_TAGNAME= 4.5.2:corba
USE_PERL5= build
-CPE_VENDOR= erlang
-CPE_PRODUCT= erlang/otp
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-smp-support
@@ -77,9 +76,8 @@ KQUEUE_CONFIGURE_ENABLE= kernel-poll
NATIVE_IMPLIES= HIPE
NATIVE_CONFIGURE_ENABLE= native-libs
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
+ODBC_USES= localbase:ldflags
ODBC_CONFIGURE_WITH= odbc
-ODBC_CFLAGS= -I/usr/local/include
-ODBC_LDFLAGS= -L/usr/local/lib
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
SCTP_CONFIGURE_ENABLE= sctp