aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc15-devel/files/patch-gcc_Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc15-devel/files/patch-gcc_Makefile.in')
-rw-r--r--lang/gcc15-devel/files/patch-gcc_Makefile.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/lang/gcc15-devel/files/patch-gcc_Makefile.in b/lang/gcc15-devel/files/patch-gcc_Makefile.in
new file mode 100644
index 000000000000..127c87b1af79
--- /dev/null
+++ b/lang/gcc15-devel/files/patch-gcc_Makefile.in
@@ -0,0 +1,19 @@
+--- gcc/Makefile.in.orig 2024-02-25 22:32:27 UTC
++++ gcc/Makefile.in
+@@ -671,6 +671,8 @@ libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/
+
+ # Directory in which the compiler finds libraries etc.
+ libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
++# Directory in which the compiler finds headers.
++libsubincludedir = $(libdir)/gcc/$(target_alias)/$(version)/include
+ # Directory in which the compiler finds executables
+ libexecsubdir = $(libexecdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
+ # Directory in which all plugin resources are installed
+@@ -3821,6 +3823,7 @@ installdirs:
+ # $(libdir)/gcc/include isn't currently searched by cpp.
+ installdirs:
+ $(mkinstalldirs) $(DESTDIR)$(libsubdir)
++ $(mkinstalldirs) $(DESTDIR)$(libsubincludedir)
+ $(mkinstalldirs) $(DESTDIR)$(libexecsubdir)
+ $(mkinstalldirs) $(DESTDIR)$(bindir)
+ $(mkinstalldirs) $(DESTDIR)$(includedir)