aboutsummaryrefslogtreecommitdiff
path: root/lang/hs-futhark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/hs-futhark/Makefile')
-rw-r--r--lang/hs-futhark/Makefile52
1 files changed, 27 insertions, 25 deletions
diff --git a/lang/hs-futhark/Makefile b/lang/hs-futhark/Makefile
index 60165525aa86..c4e0a598db35 100644
--- a/lang/hs-futhark/Makefile
+++ b/lang/hs-futhark/Makefile
@@ -1,6 +1,6 @@
PORTNAME= futhark
DISTVERSIONPREFIX= v
-DISTVERSION= 0.25.15
+DISTVERSION= 0.25.16
CATEGORIES= lang haskell
MAINTAINER= yuri@FreeBSD.org
@@ -20,14 +20,14 @@ USE_CABAL= Diff-0.5_1 \
adjunctions-4.4.2_2 \
aeson-2.2.1.0_1 \
alex-3.5.1.0 \
- ansi-terminal-1.1 \
+ ansi-terminal-1.1.1 \
ansi-terminal-types-1.1 \
assoc-1.1_1 \
- async-2.2.5 \
+ async-2.2.5_1 \
attoparsec-0.14.4_5 \
- base-compat-0.13.1 \
- base-compat-batteries-0.13.1 \
- base-orphans-0.9.1 \
+ base-compat-0.14.0 \
+ base-compat-batteries-0.14.0 \
+ base-orphans-0.9.2 \
base16-bytestring-1.0.2.0_1 \
bifunctors-5.6.2 \
bitvec-1.1.5.0_1 \
@@ -39,14 +39,15 @@ USE_CABAL= Diff-0.5_1 \
bytestring-to-vector-0.3.0.1 \
call-stack-0.4.0 \
case-insensitive-1.2.1.0 \
+ clock-0.8.4 \
cmark-gfm-0.2.6_1 \
co-log-core-0.3.2.1 \
colour-2.3.6 \
comonad-5.0.8_2 \
- constraints-0.14 \
+ constraints-0.14.1 \
contravariant-1.5.5 \
- cryptohash-md5-0.11.101.0_3 \
- cryptohash-sha1-0.11.101.0_3 \
+ cryptohash-md5-0.11.101.0_4 \
+ cryptohash-sha1-0.11.101.0_4 \
data-default-0.7.1.1 \
data-default-class-0.1.2.0 \
data-default-instances-containers-0.0.1 \
@@ -61,6 +62,7 @@ USE_CABAL= Diff-0.5_1 \
entropy-0.4.1.10_1 \
exception-mtl-0.4.0.2 \
exception-transformers-0.4.0.12 \
+ extra-1.7.14 \
fail-4.9.0.0 \
fgl-5.8.2.0 \
fgl-visualize-0.1.0.1 \
@@ -76,9 +78,9 @@ USE_CABAL= Diff-0.5_1 \
generic-lens-core-2.2.1.0_2 \
generically-0.1.1_2 \
githash-0.1.7.0 \
- half-0.3.1_1 \
+ half-0.3.1_2 \
happy-1.20.1.1 \
- hashable-1.4.3.0_1 \
+ hashable-1.4.4.0_1 \
haskell-src-exts-1.23.1 \
haskell-src-meta-0.8.13 \
hsc2hs-0.68.10_2 \
@@ -86,16 +88,16 @@ USE_CABAL= Diff-0.5_1 \
indexed-traversable-0.1.3 \
indexed-traversable-instances-0.1.1.2_2 \
integer-conversion-0.1.0.1_1 \
- integer-logarithms-1.0.3.1_5 \
+ integer-logarithms-1.0.3.1_6 \
invariant-0.6.3 \
kan-extensions-5.2.5_2 \
language-c-quote-0.13.0.1_1 \
- lens-5.2.3_3 \
+ lens-5.2.3_5 \
lens-aeson-1.2.3_2 \
- lsp-2.4.0.0 \
- lsp-types-2.1.1.0 \
+ lsp-2.5.0.0 \
+ lsp-types-2.2.0.0 \
mainland-pretty-0.7.1_3 \
- math-functions-0.3.4.3 \
+ math-functions-0.3.4.4 \
megaparsec-9.6.1 \
mod-0.2.0.1 \
mwc-random-0.15.0.2_1 \
@@ -104,7 +106,8 @@ USE_CABAL= Diff-0.5_1 \
network-uri-2.6.4.2_1 \
old-locale-1.0.0.7_2 \
old-time-1.1.0.4 \
- parallel-3.2.2.0_7 \
+ os-string-2.0.2.1 \
+ parallel-3.2.2.0_8 \
parser-combinators-1.3.0_1 \
prettyprinter-1.7.1 \
prettyprinter-ansi-terminal-1.1.3 \
@@ -117,7 +120,7 @@ USE_CABAL= Diff-0.5_1 \
regex-1.1.0.2 \
regex-base-0.94.0.2_4 \
regex-pcre-builtin-0.95.2.3.8.44_6 \
- regex-tdfa-1.3.2.2_2 \
+ regex-tdfa-1.3.2.2_3 \
row-types-1.0.1.2_1 \
safe-0.3.21_1 \
scientific-0.3.7.0_7 \
@@ -127,7 +130,7 @@ USE_CABAL= Diff-0.5_1 \
semirings-0.6_1 \
some-1.0.6 \
sorted-list-0.2.2.0 \
- splitmix-0.1.0.5 \
+ splitmix-0.1.0.5_1 \
srcloc-0.6.0.1 \
statistics-0.16.2.1 \
strict-0.5_1 \
@@ -139,17 +142,16 @@ USE_CABAL= Diff-0.5_1 \
text-rope-0.2 \
text-short-0.1.5_3 \
th-abstraction-0.6.0.0_2 \
- th-compat-0.1.5 \
- th-expand-syns-0.4.11.0_3 \
+ th-compat-0.1.5_2 \
+ th-expand-syns-0.4.11.0_4 \
th-lift-0.8.4_2 \
- th-orphans-0.13.14_2 \
+ th-orphans-0.13.14_3 \
th-reify-many-0.1.10 \
these-1.2_1 \
time-compat-1.9.6.1_6 \
time-locale-compat-0.1.1.5 \
transformers-base-0.4.6 \
transformers-compat-0.7.2 \
- type-equality-1_6 \
unliftio-core-0.2.1.0_3 \
unordered-containers-0.2.20_1 \
utf8-string-1.0.2 \
@@ -159,11 +161,11 @@ USE_CABAL= Diff-0.5_1 \
vector-algorithms-0.9.0.1_3 \
vector-binary-instances-0.2.5.2_5 \
vector-stream-0.1.0.1_1 \
- vector-th-unbox-0.2.2_5 \
+ vector-th-unbox-0.2.2_6 \
versions-6.0.6 \
void-0.7.3 \
witherable-0.4.2_4 \
- zlib-0.7.0.0_1
+ zlib-0.7.1.0
CABAL_PROJECT= remove