aboutsummaryrefslogtreecommitdiff
path: root/math/e-antic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/e-antic/Makefile')
-rw-r--r--math/e-antic/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/e-antic/Makefile b/math/e-antic/Makefile
index ec24a530502f..1a754baffc92 100644
--- a/math/e-antic/Makefile
+++ b/math/e-antic/Makefile
@@ -1,6 +1,5 @@
PORTNAME= e-antic
-DISTVERSION= 1.2.1
-PORTREVISION= 3
+DISTVERSION= 2.0.2
#MASTER_SITES= https://www.labri.fr/perso/vdelecro/e-antic/
CATEGORIES= math
@@ -25,7 +24,7 @@ USES= autoreconf compiler:c++11-lang gmake libtool localbase \
USE_GITHUB= yes
ANTIC_TAG= f4e8a60
-CATCH_TAG= ff349a5
+CATCH_TAG= 62fd660
CEREAL_TAG= ebef1e9
FLINT_TAG= ae7ec89
GH_ACCOUNT= flatsurf catchorg:c1 USCiLab:c2 wbhart:f
@@ -48,6 +47,11 @@ TEST_TARGET= check
PLIST_SUB= VER=${DISTVERSION}
+pre-extract:
+ ${MKDIR} ${WRKDIR}/flint-${FLINT_TAG}
+ ${LN} -sf ${WRKDIR}/flint-${FLINT_TAG} ${WRKDIR}/flint2-${FLINT_TAG}
+ ${RMDIR} ${WRKDIR}/flint-${FLINT_TAG}
+
post-install:
${REINPLACE_CMD} -e 's|${STAGEDIR}||' \
${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pyeantic/install_files.txt