aboutsummaryrefslogtreecommitdiff
path: root/math/kalc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/kalc/Makefile')
-rw-r--r--math/kalc/Makefile33
1 files changed, 16 insertions, 17 deletions
diff --git a/math/kalc/Makefile b/math/kalc/Makefile
index 11b082024cb1..0724924555b1 100644
--- a/math/kalc/Makefile
+++ b/math/kalc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kalc
DISTVERSIONPREFIX= v
-DISTVERSION= 1.1.2
+DISTVERSION= 1.1.5
CATEGORIES= math
PKGNAMESUFFIX= -calculator
@@ -20,9 +20,8 @@ USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= bgkillas
-CARGO_CRATES= autocfg-1.2.0 \
+CARGO_CRATES= autocfg-1.3.0 \
az-1.2.1 \
- bitflags-1.3.2 \
bitflags-2.5.0 \
byteorder-1.5.0 \
cfg-if-1.0.0 \
@@ -30,37 +29,37 @@ CARGO_CRATES= autocfg-1.2.0 \
crossterm_winapi-0.9.1 \
dirs-5.0.1 \
dirs-sys-0.4.1 \
- errno-0.3.8 \
- fastrand-2.0.2 \
- getrandom-0.2.14 \
+ errno-0.3.9 \
+ fastrand-2.1.0 \
+ getrandom-0.2.15 \
gmp-mpfr-sys-1.6.2 \
gnuplot-0.0.43 \
- libc-0.2.153 \
+ libc-0.2.154 \
libm-0.2.8 \
libredox-0.1.3 \
linux-raw-sys-0.4.13 \
- lock_api-0.4.11 \
+ lock_api-0.4.12 \
log-0.4.21 \
mio-0.8.11 \
option-ext-0.2.0 \
- parking_lot-0.12.1 \
- parking_lot_core-0.9.9 \
- proc-macro2-1.0.79 \
+ parking_lot-0.12.2 \
+ parking_lot_core-0.9.10 \
+ proc-macro2-1.0.82 \
quote-1.0.36 \
- redox_syscall-0.4.1 \
+ redox_syscall-0.5.1 \
redox_users-0.4.5 \
rug-1.24.1 \
- rustix-0.38.32 \
+ rustix-0.38.34 \
scopeguard-1.2.0 \
signal-hook-0.3.17 \
signal-hook-mio-0.2.3 \
- signal-hook-registry-1.4.1 \
+ signal-hook-registry-1.4.2 \
smallvec-1.13.2 \
- syn-2.0.58 \
+ syn-2.0.63 \
tempfile-3.10.1 \
term_size-0.3.2 \
- thiserror-1.0.58 \
- thiserror-impl-1.0.58 \
+ thiserror-1.0.60 \
+ thiserror-impl-1.0.60 \
unicode-ident-1.0.12 \
wasi-0.11.0+wasi-snapshot-preview1 \
winapi-0.3.9 \