aboutsummaryrefslogtreecommitdiff
path: root/math/libsemigroups/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/libsemigroups/Makefile')
-rw-r--r--math/libsemigroups/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/math/libsemigroups/Makefile b/math/libsemigroups/Makefile
index a739f2661284..f24114dbffa6 100644
--- a/math/libsemigroups/Makefile
+++ b/math/libsemigroups/Makefile
@@ -1,7 +1,6 @@
PORTNAME= libsemigroups
-PORTVERSION= 1.3.7
+PORTVERSION= 2.3.2
DISTVERSIONPREFIX= v
-PORTREVISION= 8
CATEGORIES= math
MAINTAINER= thierry@FreeBSD.org
@@ -16,7 +15,7 @@ LIB_DEPENDS= libfmt.so:devel/libfmt
USE_GITHUB= yes
USES= autoreconf compiler:c++11-lang eigen:3,build \
- libtool pkgconfig
+ libtool pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-fmt --with-external-fmt=yes \
@@ -33,11 +32,11 @@ CONFIGURE_ARGS+= --disable-hpcombi
pre-configure:
.if ${ARCH} == amd64
- ${REINPLACE_CMD} -e 's|$$srcdir/extern/HPCombi|${LOCALBASE}/share/HPCombi|' \
+ ${REINPLACE_CMD} -e 's|$$srcdir/extern/HPCombi/VERSION|${LOCALBASE}/share/hpcombi/HPCOMBI_VERSION|' \
${WRKSRC}/m4/ax_check_hpcombi.m4
- ${REINPLACE_CMD} -e 's|extern/HPCombi/include|${LOCALBASE}/include/HPCombi|' \
+ ${REINPLACE_CMD} -e 's|extern/HPCombi/include|${LOCALBASE}/include/hpcombi|' \
${WRKSRC}/Makefile.am
- ${REINPLACE_CMD} -e 's|HPCombi/include|HPCombi|' \
+ ${REINPLACE_CMD} -e 's|HPCombi/include|hpcombi|' \
${WRKSRC}/include/libsemigroups/hpcombi.hpp
.endif
${REINPLACE_CMD} -e 's|fmtinclude_HEADERS|#fmtinclude_HEADERS|' \