aboutsummaryrefslogtreecommitdiff
path: root/misc/bedrust/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/bedrust/Makefile')
-rw-r--r--misc/bedrust/Makefile319
1 files changed, 319 insertions, 0 deletions
diff --git a/misc/bedrust/Makefile b/misc/bedrust/Makefile
new file mode 100644
index 000000000000..4f689d1f1ce4
--- /dev/null
+++ b/misc/bedrust/Makefile
@@ -0,0 +1,319 @@
+PORTNAME= bedrust
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.7.4
+PORTREVISION= 1
+CATEGORIES= misc # machine-learning
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Invoke NN models on Amazon Bedrock
+WWW= https://rup12.net
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cargo
+
+USE_GITHUB= yes
+GH_ACCOUNT= darko-mesaros
+
+RUSTFLAGS= ${ARCH:S/i386/YES/:C/^[a-z].*//:S/YES/-C target-feature=+sse,+sse2/} # add sse sse2 target-features only on i386
+
+CARGO_CRATES= addr2line-0.21.0 \
+ adler-1.0.2 \
+ aligned-vec-0.5.0 \
+ anstream-0.6.13 \
+ anstyle-1.0.6 \
+ anstyle-parse-0.2.3 \
+ anstyle-query-1.0.2 \
+ anstyle-wincon-3.0.2 \
+ anyhow-1.0.82 \
+ arbitrary-1.3.2 \
+ arg_enum_proc_macro-0.3.4 \
+ arrayvec-0.7.4 \
+ autocfg-1.2.0 \
+ av1-grain-0.2.3 \
+ avif-serialize-0.8.1 \
+ aws-config-1.2.0 \
+ aws-credential-types-1.2.0 \
+ aws-runtime-1.2.0 \
+ aws-sdk-bedrock-1.21.0 \
+ aws-sdk-bedrockruntime-1.21.0 \
+ aws-sdk-sso-1.20.0 \
+ aws-sdk-ssooidc-1.20.0 \
+ aws-sdk-sts-1.20.0 \
+ aws-sigv4-1.2.0 \
+ aws-smithy-async-1.2.1 \
+ aws-smithy-eventstream-0.60.4 \
+ aws-smithy-http-0.60.8 \
+ aws-smithy-json-0.60.7 \
+ aws-smithy-query-0.60.7 \
+ aws-smithy-runtime-1.3.1 \
+ aws-smithy-runtime-api-1.4.0 \
+ aws-smithy-types-1.1.8 \
+ aws-smithy-xml-0.60.8 \
+ aws-types-1.2.0 \
+ backtrace-0.3.71 \
+ base64-0.21.7 \
+ base64-0.22.0 \
+ base64-simd-0.8.0 \
+ bit_field-0.10.2 \
+ bitflags-1.3.2 \
+ bitflags-2.5.0 \
+ bitstream-io-2.2.0 \
+ block-buffer-0.10.4 \
+ built-0.7.2 \
+ bumpalo-3.16.0 \
+ bytemuck-1.15.0 \
+ byteorder-1.5.0 \
+ byteorder-lite-0.1.0 \
+ bytes-1.6.0 \
+ bytes-utils-0.1.4 \
+ cc-1.0.95 \
+ cfg-expr-0.15.8 \
+ cfg-if-1.0.0 \
+ clap-4.5.4 \
+ clap_builder-4.5.2 \
+ clap_derive-4.5.4 \
+ clap_lex-0.7.0 \
+ color_quant-1.1.0 \
+ colorchoice-1.0.0 \
+ colored-2.1.0 \
+ console-0.15.8 \
+ core-foundation-0.9.4 \
+ core-foundation-sys-0.8.6 \
+ cpufeatures-0.2.12 \
+ crc32fast-1.4.0 \
+ crossbeam-deque-0.8.5 \
+ crossbeam-epoch-0.9.18 \
+ crossbeam-utils-0.8.19 \
+ crunchy-0.2.2 \
+ crypto-common-0.1.6 \
+ deranged-0.3.11 \
+ dialoguer-0.11.0 \
+ digest-0.10.7 \
+ dirs-5.0.1 \
+ dirs-sys-0.4.1 \
+ either-1.11.0 \
+ encode_unicode-0.3.6 \
+ equivalent-1.0.1 \
+ exr-1.72.0 \
+ fastrand-2.0.2 \
+ fdeflate-0.3.4 \
+ figlet-rs-0.1.5 \
+ flate2-1.0.28 \
+ flume-0.11.0 \
+ fnv-1.0.7 \
+ form_urlencoded-1.2.1 \
+ futures-0.3.30 \
+ futures-channel-0.3.30 \
+ futures-core-0.3.30 \
+ futures-executor-0.3.30 \
+ futures-io-0.3.30 \
+ futures-macro-0.3.30 \
+ futures-sink-0.3.30 \
+ futures-task-0.3.30 \
+ futures-util-0.3.30 \
+ fuzzy-matcher-0.3.7 \
+ generic-array-0.14.7 \
+ getrandom-0.2.14 \
+ gif-0.13.1 \
+ gimli-0.28.1 \
+ h2-0.3.26 \
+ half-2.4.1 \
+ hashbrown-0.14.3 \
+ heck-0.5.0 \
+ hermit-abi-0.3.9 \
+ hex-0.4.3 \
+ hmac-0.12.1 \
+ http-0.2.12 \
+ http-1.1.0 \
+ http-body-0.4.6 \
+ http-body-1.0.0 \
+ http-body-util-0.1.1 \
+ httparse-1.8.0 \
+ httpdate-1.0.3 \
+ hyper-0.14.28 \
+ hyper-rustls-0.24.2 \
+ idna-0.5.0 \
+ image-0.25.1 \
+ image-webp-0.1.2 \
+ imgref-1.10.1 \
+ indexmap-2.2.6 \
+ indicatif-0.17.8 \
+ instant-0.1.12 \
+ interpolate_name-0.2.4 \
+ itertools-0.12.1 \
+ itoa-1.0.11 \
+ jobserver-0.1.30 \
+ jpeg-decoder-0.3.1 \
+ lazy_static-1.4.0 \
+ lebe-0.5.2 \
+ libc-0.2.153 \
+ libfuzzer-sys-0.4.7 \
+ libredox-0.1.3 \
+ lock_api-0.4.11 \
+ log-0.4.21 \
+ loop9-0.1.5 \
+ maybe-rayon-0.1.1 \
+ memchr-2.7.2 \
+ minimal-lexical-0.2.1 \
+ miniz_oxide-0.7.2 \
+ mio-0.8.11 \
+ new_debug_unreachable-1.0.6 \
+ nom-7.1.3 \
+ noop_proc_macro-0.3.0 \
+ num-bigint-0.4.4 \
+ num-conv-0.1.0 \
+ num-derive-0.4.2 \
+ num-integer-0.1.46 \
+ num-rational-0.4.1 \
+ num-traits-0.2.18 \
+ num_cpus-1.16.0 \
+ number_prefix-0.4.0 \
+ object-0.32.2 \
+ once_cell-1.19.0 \
+ openssl-probe-0.1.5 \
+ option-ext-0.2.0 \
+ outref-0.5.1 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.9.9 \
+ paste-1.0.14 \
+ percent-encoding-2.3.1 \
+ pin-project-lite-0.2.14 \
+ pin-utils-0.1.0 \
+ pkg-config-0.3.30 \
+ png-0.17.13 \
+ portable-atomic-1.6.0 \
+ powerfmt-0.2.0 \
+ ppv-lite86-0.2.17 \
+ proc-macro2-1.0.81 \
+ profiling-1.0.15 \
+ profiling-procmacros-1.0.15 \
+ qoi-0.4.1 \
+ quick-error-2.0.1 \
+ quick-xml-0.31.0 \
+ quote-1.0.36 \
+ rand-0.8.5 \
+ rand_chacha-0.3.1 \
+ rand_core-0.6.4 \
+ rav1e-0.7.1 \
+ ravif-0.11.5 \
+ rayon-1.10.0 \
+ rayon-core-1.12.1 \
+ redox_syscall-0.4.1 \
+ redox_users-0.4.5 \
+ regex-lite-0.1.5 \
+ rgb-0.8.37 \
+ ring-0.17.8 \
+ ron-0.8.1 \
+ rustc-demangle-0.1.23 \
+ rustc_version-0.4.0 \
+ rustls-0.21.11 \
+ rustls-native-certs-0.6.3 \
+ rustls-pemfile-1.0.4 \
+ rustls-webpki-0.101.7 \
+ ryu-1.0.17 \
+ schannel-0.1.23 \
+ scopeguard-1.2.0 \
+ sct-0.7.1 \
+ security-framework-2.10.0 \
+ security-framework-sys-2.10.0 \
+ semver-1.0.22 \
+ serde-1.0.198 \
+ serde_derive-1.0.198 \
+ serde_json-1.0.116 \
+ serde_spanned-0.6.5 \
+ sha2-0.10.8 \
+ shell-words-1.1.0 \
+ signal-hook-registry-1.4.1 \
+ simd-adler32-0.3.7 \
+ simd_helpers-0.1.0 \
+ slab-0.4.9 \
+ smallvec-1.13.2 \
+ socket2-0.5.6 \
+ spin-0.9.8 \
+ strsim-0.11.1 \
+ subtle-2.5.0 \
+ syn-2.0.60 \
+ system-deps-6.2.2 \
+ target-lexicon-0.12.14 \
+ termcolor-1.4.1 \
+ thiserror-1.0.59 \
+ thiserror-impl-1.0.59 \
+ thread_local-1.1.8 \
+ tiff-0.9.1 \
+ time-0.3.36 \
+ time-core-0.1.2 \
+ time-macros-0.2.18 \
+ tinyvec-1.6.0 \
+ tinyvec_macros-0.1.1 \
+ tokio-1.37.0 \
+ tokio-macros-2.2.0 \
+ tokio-rustls-0.24.1 \
+ tokio-util-0.7.10 \
+ toml-0.8.12 \
+ toml_datetime-0.6.5 \
+ toml_edit-0.22.12 \
+ tower-service-0.3.2 \
+ tracing-0.1.40 \
+ tracing-attributes-0.1.27 \
+ tracing-core-0.1.32 \
+ try-lock-0.2.5 \
+ typenum-1.17.0 \
+ unicode-bidi-0.3.15 \
+ unicode-ident-1.0.12 \
+ unicode-normalization-0.1.23 \
+ unicode-width-0.1.11 \
+ untrusted-0.9.0 \
+ url-2.5.0 \
+ urlencoding-2.1.3 \
+ utf8parse-0.2.1 \
+ uuid-1.8.0 \
+ v_frame-0.3.8 \
+ version-compare-0.2.0 \
+ version_check-0.9.4 \
+ vsimd-0.8.0 \
+ want-0.3.1 \
+ wasi-0.11.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.92 \
+ wasm-bindgen-backend-0.2.92 \
+ wasm-bindgen-macro-0.2.92 \
+ wasm-bindgen-macro-support-0.2.92 \
+ wasm-bindgen-shared-0.2.92 \
+ weezl-0.1.8 \
+ winapi-0.3.9 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.6 \
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-sys-0.48.0 \
+ windows-sys-0.52.0 \
+ windows-targets-0.48.5 \
+ windows-targets-0.52.5 \
+ windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_gnullvm-0.52.5 \
+ windows_aarch64_msvc-0.48.5 \
+ windows_aarch64_msvc-0.52.5 \
+ windows_i686_gnu-0.48.5 \
+ windows_i686_gnu-0.52.5 \
+ windows_i686_gnullvm-0.52.5 \
+ windows_i686_msvc-0.48.5 \
+ windows_i686_msvc-0.52.5 \
+ windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnu-0.52.5 \
+ windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_gnullvm-0.52.5 \
+ windows_x86_64_msvc-0.48.5 \
+ windows_x86_64_msvc-0.52.5 \
+ winnow-0.6.6 \
+ xmlparser-0.13.6 \
+ zeroize-1.7.0 \
+ zune-core-0.4.12 \
+ zune-inflate-0.2.54 \
+ zune-jpeg-0.4.11
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>