aboutsummaryrefslogtreecommitdiff
path: root/net-im/iamb/Makefile.crates
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/iamb/Makefile.crates')
-rw-r--r--net-im/iamb/Makefile.crates565
1 files changed, 565 insertions, 0 deletions
diff --git a/net-im/iamb/Makefile.crates b/net-im/iamb/Makefile.crates
new file mode 100644
index 000000000000..e6e066fe0d5d
--- /dev/null
+++ b/net-im/iamb/Makefile.crates
@@ -0,0 +1,565 @@
+CARGO_CRATES= accessory-1.3.0 \
+ addr2line-0.21.0 \
+ adler-1.0.2 \
+ aead-0.5.2 \
+ aes-0.8.3 \
+ ahash-0.8.10 \
+ aho-corasick-1.1.1 \
+ allocator-api2-0.2.16 \
+ android-tzdata-0.1.1 \
+ android_system_properties-0.1.5 \
+ anstream-0.3.2 \
+ anstyle-1.0.2 \
+ anstyle-parse-0.2.1 \
+ anstyle-query-1.0.0 \
+ anstyle-wincon-1.0.2 \
+ anyhow-1.0.75 \
+ anymap2-0.13.0 \
+ aquamarine-0.5.0 \
+ arboard-3.3.0 \
+ arrayref-0.3.7 \
+ arrayvec-0.7.4 \
+ as_variant-1.2.0 \
+ assign-1.1.1 \
+ async-broadcast-0.5.1 \
+ async-channel-2.2.0 \
+ async-executor-1.8.0 \
+ async-fs-1.6.0 \
+ async-io-1.13.0 \
+ async-io-2.3.2 \
+ async-lock-2.8.0 \
+ async-lock-3.3.0 \
+ async-process-1.8.1 \
+ async-recursion-1.1.0 \
+ async-signal-0.2.5 \
+ async-stream-0.3.5 \
+ async-stream-impl-0.3.5 \
+ async-task-4.7.0 \
+ async-trait-0.1.73 \
+ atomic-waker-1.1.2 \
+ autocfg-1.1.0 \
+ backoff-0.4.0 \
+ backtrace-0.3.69 \
+ base64-0.21.7 \
+ base64ct-1.6.0 \
+ bincode-1.3.3 \
+ bit-set-0.5.3 \
+ bit-vec-0.6.3 \
+ bit_field-0.10.2 \
+ bitflags-1.3.2 \
+ bitflags-2.4.2 \
+ bitmaps-3.2.1 \
+ blake3-1.5.0 \
+ block-0.1.6 \
+ block-buffer-0.10.4 \
+ block-padding-0.3.3 \
+ blocking-1.5.1 \
+ bs58-0.5.0 \
+ bumpalo-3.14.0 \
+ bytemuck-1.14.0 \
+ byteorder-1.4.3 \
+ bytes-1.5.0 \
+ bytesize-1.3.0 \
+ cassowary-0.3.0 \
+ cbc-0.1.2 \
+ cc-1.0.83 \
+ cfg-if-1.0.0 \
+ cfg-vis-0.3.0 \
+ chacha20-0.9.1 \
+ chacha20poly1305-0.10.1 \
+ chrono-0.4.31 \
+ cipher-0.4.4 \
+ clap-4.3.24 \
+ clap_builder-4.3.24 \
+ clap_derive-4.3.12 \
+ clap_lex-0.5.0 \
+ clipboard-win-4.5.0 \
+ color_quant-1.1.0 \
+ colorchoice-1.0.0 \
+ comrak-0.18.0 \
+ concurrent-queue-2.4.0 \
+ const-oid-0.9.6 \
+ const_panic-0.2.8 \
+ constant_time_eq-0.3.0 \
+ convert_case-0.4.0 \
+ core-foundation-0.9.3 \
+ core-foundation-sys-0.8.4 \
+ core-graphics-0.22.3 \
+ core-graphics-types-0.1.2 \
+ cpufeatures-0.2.9 \
+ crc32fast-1.3.2 \
+ crossbeam-channel-0.5.8 \
+ crossbeam-deque-0.8.3 \
+ crossbeam-epoch-0.9.15 \
+ crossbeam-utils-0.8.16 \
+ crossterm-0.27.0 \
+ crossterm_winapi-0.9.1 \
+ crunchy-0.2.2 \
+ crypto-common-0.1.6 \
+ css-color-parser-0.1.2 \
+ ctr-0.9.2 \
+ curve25519-dalek-4.1.2 \
+ curve25519-dalek-derive-0.1.1 \
+ deadpool-0.10.0 \
+ deadpool-runtime-0.1.3 \
+ deadpool-sqlite-0.7.0 \
+ deadpool-sync-0.1.2 \
+ delegate-display-2.1.1 \
+ der-0.7.8 \
+ der_derive-0.7.2 \
+ deranged-0.3.8 \
+ derivative-2.2.0 \
+ derive_more-0.99.17 \
+ deunicode-0.4.4 \
+ diff-0.1.13 \
+ digest-0.10.7 \
+ dirs-4.0.0 \
+ dirs-next-2.0.0 \
+ dirs-sys-0.3.7 \
+ dirs-sys-next-0.1.2 \
+ displaydoc-0.2.4 \
+ dyn-clone-1.0.14 \
+ ed25519-2.2.3 \
+ ed25519-dalek-2.1.1 \
+ edit-0.1.4 \
+ either-1.9.0 \
+ emojis-0.5.3 \
+ encoding_rs-0.8.33 \
+ endian-type-0.1.2 \
+ entities-1.0.1 \
+ enumflags2-0.7.9 \
+ enumflags2_derive-0.7.9 \
+ equivalent-1.0.1 \
+ errno-0.3.8 \
+ error-code-2.3.1 \
+ event-listener-2.5.3 \
+ event-listener-3.1.0 \
+ event-listener-4.0.3 \
+ event-listener-5.2.0 \
+ event-listener-strategy-0.4.0 \
+ event-listener-strategy-0.5.0 \
+ exr-1.71.0 \
+ eyeball-0.8.7 \
+ eyeball-im-0.4.2 \
+ fallible-iterator-0.3.0 \
+ fallible-streaming-iterator-0.1.9 \
+ fancy-regex-0.11.0 \
+ fancy_constructor-1.2.2 \
+ fastrand-1.9.0 \
+ fastrand-2.0.1 \
+ fdeflate-0.3.0 \
+ fiat-crypto-0.2.6 \
+ flagset-0.4.4 \
+ flate2-1.0.27 \
+ flume-0.11.0 \
+ fnv-1.0.7 \
+ foreign-types-0.3.2 \
+ foreign-types-shared-0.1.1 \
+ form_urlencoded-1.2.0 \
+ fs2-0.4.3 \
+ futf-0.1.5 \
+ futures-0.3.28 \
+ futures-channel-0.3.28 \
+ futures-core-0.3.28 \
+ futures-executor-0.3.28 \
+ futures-io-0.3.28 \
+ futures-lite-1.13.0 \
+ futures-lite-2.3.0 \
+ futures-macro-0.3.28 \
+ futures-sink-0.3.28 \
+ futures-task-0.3.28 \
+ futures-util-0.3.28 \
+ fxhash-0.2.1 \
+ generic-array-0.14.7 \
+ gethostname-0.3.0 \
+ gethostname-0.4.3 \
+ getrandom-0.2.12 \
+ gif-0.12.0 \
+ gimli-0.28.0 \
+ gloo-timers-0.3.0 \
+ gloo-utils-0.2.0 \
+ h2-0.3.21 \
+ half-2.2.1 \
+ hashbrown-0.12.3 \
+ hashbrown-0.14.1 \
+ hashlink-0.8.4 \
+ heck-0.4.1 \
+ hermit-abi-0.3.3 \
+ hex-0.4.3 \
+ hkdf-0.12.4 \
+ hmac-0.12.1 \
+ home-0.5.5 \
+ html5ever-0.26.0 \
+ http-0.2.9 \
+ http-body-0.4.5 \
+ httparse-1.8.0 \
+ httpdate-1.0.3 \
+ hyper-0.14.27 \
+ hyper-rustls-0.24.1 \
+ hyper-tls-0.5.0 \
+ iana-time-zone-0.1.57 \
+ iana-time-zone-haiku-0.1.2 \
+ icy_sixel-0.1.1 \
+ idna-0.4.0 \
+ image-0.24.7 \
+ imbl-2.0.3 \
+ imbl-sized-chunks-0.1.2 \
+ include_dir-0.7.3 \
+ include_dir_macros-0.7.3 \
+ indexed_db_futures-0.4.1 \
+ indexmap-1.9.3 \
+ indexmap-2.0.2 \
+ indoc-2.0.4 \
+ inout-0.1.3 \
+ instant-0.1.12 \
+ intervaltree-0.2.7 \
+ io-lifetimes-1.0.11 \
+ ipnet-2.8.0 \
+ is-terminal-0.4.9 \
+ itertools-0.10.5 \
+ itertools-0.11.0 \
+ itertools-0.12.1 \
+ itoa-1.0.9 \
+ jpeg-decoder-0.3.0 \
+ js-sys-0.3.64 \
+ js_int-0.2.2 \
+ js_option-0.1.1 \
+ keybindings-0.0.1 \
+ konst-0.3.8 \
+ konst_kernel-0.3.8 \
+ lazy_static-0.1.16 \
+ lazy_static-1.4.0 \
+ lebe-0.5.2 \
+ libc-0.2.153 \
+ libsqlite3-sys-0.27.0 \
+ line-wrap-0.1.1 \
+ linked-hash-map-0.5.6 \
+ linux-raw-sys-0.3.8 \
+ linux-raw-sys-0.4.13 \
+ lock_api-0.4.10 \
+ log-0.4.20 \
+ mac-0.1.1 \
+ mac-notification-sys-0.6.1 \
+ macroific-1.3.1 \
+ macroific_attr_parse-1.3.0 \
+ macroific_core-1.0.2 \
+ macroific_macro-1.1.0 \
+ malloc_buf-0.0.6 \
+ maplit-1.0.2 \
+ markup5ever-0.11.0 \
+ markup5ever_rcdom-0.2.0 \
+ matrix-pickle-0.1.1 \
+ matrix-pickle-derive-0.1.1 \
+ matrix-sdk-0.7.1 \
+ matrix-sdk-base-0.7.0 \
+ matrix-sdk-common-0.7.0 \
+ matrix-sdk-crypto-0.7.0 \
+ matrix-sdk-indexeddb-0.7.0 \
+ matrix-sdk-sqlite-0.7.0 \
+ matrix-sdk-store-encryption-0.7.0 \
+ memchr-2.6.4 \
+ memoffset-0.7.1 \
+ memoffset-0.9.0 \
+ mime-0.3.17 \
+ mime2ext-0.1.52 \
+ mime_guess-2.0.4 \
+ minimal-lexical-0.2.1 \
+ miniz_oxide-0.7.1 \
+ mio-0.8.8 \
+ modalkit-0.0.18 \
+ modalkit-ratatui-0.0.18 \
+ native-tls-0.2.11 \
+ new_debug_unreachable-1.0.4 \
+ nibble_vec-0.1.0 \
+ nix-0.26.4 \
+ nom-7.1.3 \
+ notify-rust-4.10.0 \
+ nu-ansi-term-0.46.0 \
+ num-integer-0.1.45 \
+ num-rational-0.4.1 \
+ num-traits-0.2.16 \
+ num_cpus-1.16.0 \
+ num_threads-0.1.6 \
+ objc-0.2.7 \
+ objc-foundation-0.1.1 \
+ objc_id-0.1.1 \
+ object-0.32.1 \
+ once_cell-1.18.0 \
+ onig-6.4.0 \
+ onig_sys-69.8.1 \
+ opaque-debug-0.3.0 \
+ open-3.2.0 \
+ openssl-0.10.64 \
+ openssl-macros-0.1.1 \
+ openssl-probe-0.1.5 \
+ openssl-sys-0.9.101 \
+ ordered-stream-0.2.0 \
+ overload-0.1.1 \
+ parking-2.2.0 \
+ parking_lot-0.11.2 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.8.6 \
+ parking_lot_core-0.9.8 \
+ paste-1.0.14 \
+ pathdiff-0.2.1 \
+ pbkdf2-0.12.2 \
+ percent-encoding-2.3.0 \
+ phf-0.10.1 \
+ phf-0.11.2 \
+ phf_codegen-0.10.0 \
+ phf_generator-0.10.0 \
+ phf_shared-0.10.0 \
+ phf_shared-0.11.2 \
+ pin-project-lite-0.2.13 \
+ pin-utils-0.1.0 \
+ piper-0.2.1 \
+ pkcs7-0.4.1 \
+ pkcs8-0.10.2 \
+ pkg-config-0.3.27 \
+ platforms-3.3.0 \
+ plist-1.5.0 \
+ png-0.17.10 \
+ polling-2.8.0 \
+ polling-3.5.0 \
+ poly1305-0.8.0 \
+ ppv-lite86-0.2.17 \
+ precomputed-hash-0.1.1 \
+ pretty_assertions-1.4.0 \
+ proc-macro-crate-1.3.1 \
+ proc-macro-crate-2.0.0 \
+ proc-macro-error-1.0.4 \
+ proc-macro-error-attr-1.0.4 \
+ proc-macro2-1.0.78 \
+ prost-0.12.3 \
+ prost-derive-0.12.3 \
+ qoi-0.4.1 \
+ quick-xml-0.29.0 \
+ quick-xml-0.30.0 \
+ quote-1.0.35 \
+ radix_trie-0.2.1 \
+ rand-0.8.5 \
+ rand_chacha-0.3.1 \
+ rand_core-0.6.4 \
+ rand_xoshiro-0.6.0 \
+ ratatui-0.23.0 \
+ ratatui-image-0.8.1 \
+ rayon-1.8.0 \
+ rayon-core-1.12.0 \
+ readlock-0.1.7 \
+ redox_syscall-0.2.16 \
+ redox_syscall-0.3.5 \
+ redox_users-0.4.3 \
+ regex-1.9.6 \
+ regex-automata-0.3.9 \
+ regex-syntax-0.7.5 \
+ reqwest-0.11.22 \
+ ring-0.16.20 \
+ rmp-0.8.12 \
+ rmp-serde-1.1.2 \
+ ropey-1.6.0 \
+ rpassword-7.2.0 \
+ rtoolbox-0.0.1 \
+ ruma-0.9.4 \
+ ruma-client-api-0.17.4 \
+ ruma-common-0.12.1 \
+ ruma-events-0.27.11 \
+ ruma-federation-api-0.8.0 \
+ ruma-identifiers-validation-0.9.3 \
+ ruma-macros-0.12.0 \
+ rusqlite-0.30.0 \
+ rustc-demangle-0.1.23 \
+ rustc_version-0.4.0 \
+ rustix-0.37.24 \
+ rustix-0.38.32 \
+ rustls-0.21.7 \
+ rustls-pemfile-1.0.3 \
+ rustls-webpki-0.101.6 \
+ rustversion-1.0.14 \
+ ryu-1.0.15 \
+ safemem-0.3.3 \
+ same-file-1.0.6 \
+ schannel-0.1.23 \
+ scopeguard-1.2.0 \
+ sct-0.7.0 \
+ security-framework-2.9.2 \
+ security-framework-sys-2.9.1 \
+ semver-1.0.19 \
+ serde-1.0.197 \
+ serde-wasm-bindgen-0.6.5 \
+ serde_bytes-0.11.14 \
+ serde_derive-1.0.197 \
+ serde_html_form-0.2.4 \
+ serde_json-1.0.114 \
+ serde_repr-0.1.18 \
+ serde_spanned-0.6.5 \
+ serde_urlencoded-0.7.1 \
+ sha1-0.10.6 \
+ sha2-0.10.8 \
+ sharded-slab-0.1.7 \
+ shell-words-1.1.0 \
+ signal-hook-0.3.17 \
+ signal-hook-mio-0.2.3 \
+ signal-hook-registry-1.4.1 \
+ signature-2.2.0 \
+ simd-adler32-0.3.7 \
+ siphasher-0.3.11 \
+ slab-0.4.9 \
+ sled-0.34.7 \
+ slug-0.1.4 \
+ smallvec-1.11.1 \
+ smawk-0.3.2 \
+ socket2-0.4.9 \
+ socket2-0.5.4 \
+ spin-0.5.2 \
+ spin-0.9.8 \
+ spki-0.7.3 \
+ static_assertions-1.1.0 \
+ str-buf-1.0.6 \
+ str_indices-0.4.1 \
+ string_cache-0.8.7 \
+ string_cache_codegen-0.5.2 \
+ strsim-0.10.0 \
+ strum-0.25.0 \
+ strum_macros-0.25.2 \
+ subtle-2.5.0 \
+ syn-1.0.109 \
+ syn-2.0.52 \
+ syntect-5.1.0 \
+ system-configuration-0.5.1 \
+ system-configuration-sys-0.5.0 \
+ tauri-winrt-notification-0.1.3 \
+ temp-dir-0.1.12 \
+ tempfile-3.8.0 \
+ tendril-0.4.3 \
+ terminal_size-0.2.6 \
+ textwrap-0.16.0 \
+ thiserror-1.0.57 \
+ thiserror-impl-1.0.57 \
+ thread_local-1.1.7 \
+ tiff-0.9.0 \
+ time-0.3.29 \
+ time-core-0.1.2 \
+ time-macros-0.2.15 \
+ tinyvec-1.6.0 \
+ tinyvec_macros-0.1.1 \
+ tokio-1.32.0 \
+ tokio-macros-2.1.0 \
+ tokio-native-tls-0.3.1 \
+ tokio-rustls-0.24.1 \
+ tokio-stream-0.1.14 \
+ tokio-util-0.7.9 \
+ toml-0.8.12 \
+ toml_datetime-0.6.5 \
+ toml_edit-0.19.15 \
+ toml_edit-0.20.2 \
+ toml_edit-0.22.9 \
+ tower-0.4.13 \
+ tower-layer-0.3.2 \
+ tower-service-0.3.2 \
+ tracing-0.1.40 \
+ tracing-appender-0.2.2 \
+ tracing-attributes-0.1.27 \
+ tracing-core-0.1.32 \
+ tracing-log-0.1.3 \
+ tracing-subscriber-0.3.17 \
+ try-lock-0.2.4 \
+ typed-arena-2.0.2 \
+ typenum-1.17.0 \
+ typewit-1.9.0 \
+ typewit_proc_macros-1.8.1 \
+ uds_windows-1.1.0 \
+ ulid-1.1.2 \
+ unicase-2.7.0 \
+ unicode-bidi-0.3.13 \
+ unicode-ident-1.0.12 \
+ unicode-linebreak-0.1.5 \
+ unicode-normalization-0.1.22 \
+ unicode-segmentation-1.10.1 \
+ unicode-width-0.1.11 \
+ unicode_categories-0.1.1 \
+ universal-hash-0.5.1 \
+ untrusted-0.7.1 \
+ url-2.4.1 \
+ urlencoding-2.1.3 \
+ utf-8-0.7.6 \
+ utf8parse-0.2.1 \
+ uuid-1.6.1 \
+ valuable-0.1.0 \
+ vcpkg-0.2.15 \
+ vergen-8.2.5 \
+ version_check-0.9.4 \
+ vodozemac-0.5.1 \
+ waker-fn-1.1.1 \
+ walkdir-2.4.0 \
+ want-0.3.1 \
+ wasi-0.11.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.87 \
+ wasm-bindgen-backend-0.2.87 \
+ wasm-bindgen-futures-0.4.37 \
+ wasm-bindgen-macro-0.2.87 \
+ wasm-bindgen-macro-support-0.2.87 \
+ wasm-bindgen-shared-0.2.87 \
+ wasm-streams-0.3.0 \
+ web-sys-0.3.64 \
+ web-time-1.0.0 \
+ webpki-roots-0.25.2 \
+ weezl-0.1.7 \
+ which-4.4.2 \
+ wildmatch-2.1.1 \
+ winapi-0.3.9 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.6 \
+ winapi-wsapoll-0.1.1 \
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-0.48.0 \
+ windows-0.51.1 \
+ windows-core-0.51.1 \
+ windows-sys-0.42.0 \
+ windows-sys-0.48.0 \
+ windows-sys-0.52.0 \
+ windows-targets-0.48.5 \
+ windows-targets-0.52.4 \
+ windows_aarch64_gnullvm-0.42.2 \
+ windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_gnullvm-0.52.4 \
+ windows_aarch64_msvc-0.42.2 \
+ windows_aarch64_msvc-0.48.5 \
+ windows_aarch64_msvc-0.52.4 \
+ windows_i686_gnu-0.42.2 \
+ windows_i686_gnu-0.48.5 \
+ windows_i686_gnu-0.52.4 \
+ windows_i686_msvc-0.42.2 \
+ windows_i686_msvc-0.48.5 \
+ windows_i686_msvc-0.52.4 \
+ windows_x86_64_gnu-0.42.2 \
+ windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnu-0.52.4 \
+ windows_x86_64_gnullvm-0.42.2 \
+ windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_gnullvm-0.52.4 \
+ windows_x86_64_msvc-0.42.2 \
+ windows_x86_64_msvc-0.48.5 \
+ windows_x86_64_msvc-0.52.4 \
+ winnow-0.5.15 \
+ winnow-0.6.5 \
+ winreg-0.50.0 \
+ x11rb-0.12.0 \
+ x11rb-protocol-0.12.0 \
+ x25519-dalek-2.0.1 \
+ x509-cert-0.2.5 \
+ xdg-2.5.2 \
+ xdg-home-1.1.0 \
+ xml5ever-0.17.0 \
+ yaml-rust-0.4.5 \
+ yansi-0.5.1 \
+ zbus-3.15.2 \
+ zbus_macros-3.15.2 \
+ zbus_names-2.6.1 \
+ zerocopy-0.7.32 \
+ zerocopy-derive-0.7.32 \
+ zeroize-1.7.0 \
+ zeroize_derive-1.4.2 \
+ zune-inflate-0.2.54 \
+ zvariant-3.15.2 \
+ zvariant_derive-3.15.2 \
+ zvariant_utils-1.0.1