aboutsummaryrefslogtreecommitdiff
path: root/net/benthos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/benthos/Makefile')
-rw-r--r--net/benthos/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/benthos/Makefile b/net/benthos/Makefile
new file mode 100644
index 000000000000..4b61d9e0cdd1
--- /dev/null
+++ b/net/benthos/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= benthos
+DISTVERSION= 4.27.0
+DISTVERSIONPREFIX= v
+PORTREVISION= 1
+CATEGORIES= net
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Stream processor for a wide array of data sources and sinks
+WWW= https://www.benthos.dev/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_RC_SUBR= benthos
+
+GO_MODULE= github.com/benthosdev/benthos/v4
+GO_TARGET= ./cmd/benthos
+
+USERS= benthos
+GROUPS= benthos
+
+PLIST_FILES= bin/benthos \
+ "@dir(,,755) %%ETCDIR%%" \
+ "@sample %%ETCDIR%%/config.yaml.sample"
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${FILESDIR}/config.yaml ${STAGEDIR}${ETCDIR}/config.yaml.sample
+
+.include <bsd.port.mk>