aboutsummaryrefslogtreecommitdiff
path: root/net/py-ripe.atlas.sagan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-ripe.atlas.sagan/Makefile')
-rw-r--r--net/py-ripe.atlas.sagan/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net/py-ripe.atlas.sagan/Makefile b/net/py-ripe.atlas.sagan/Makefile
index aca3116d8ff4..66ec7251565f 100644
--- a/net/py-ripe.atlas.sagan/Makefile
+++ b/net/py-ripe.atlas.sagan/Makefile
@@ -1,22 +1,27 @@
PORTNAME= ripe.atlas.sagan
-PORTVERSION= 1.3.0
-PORTREVISION= 1
+DISTVERSION= 1.3.1
CATEGORIES= net python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= mstucchi@ripe.net
+MAINTAINER= eduardo@FreeBSD.org
COMMENT= Parsing library for RIPE Atlas measurement results
WWW= https://github.com/RIPE-NCC/ripe.atlas.sagan
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-dateutil>0:devel/py-python-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent cryptography distutils
+USE_PYTHON= autoplist concurrent cryptography pep517 pytest
+PYTEST_IGNORED_TESTS= test_invalid_country_code #WIP
+
+TEST_ARGS= tests/*.py
+
NO_ARCH= yes
.include <bsd.port.mk>