aboutsummaryrefslogtreecommitdiff
path: root/net/torsocks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/torsocks/Makefile')
-rw-r--r--net/torsocks/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/net/torsocks/Makefile b/net/torsocks/Makefile
index 377e1dc5a811..d176860f33bd 100644
--- a/net/torsocks/Makefile
+++ b/net/torsocks/Makefile
@@ -1,21 +1,26 @@
PORTNAME= torsocks
-DISTVERSION= 2.3.0
-PORTREVISION= 2
+DISTVERSION= 2.4.0
CATEGORIES= net security
-MASTER_SITES= https://people.torproject.org/~dgoulet/${PORTNAME}/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Easy way to make any app work through Tor
-WWW= https://github.com/dgoulet/torsocks
+WWW= https://gitlab.torproject.org/tpo/core/torsocks
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/gpl-2.0.txt
-USES= alias gmake libtool tar:xz
+USES= autoreconf alias gmake libtool tar:xz
+USE_LDCONFIG= ${PREFIX}/lib/torsocks
+
+USE_GITLAB= yes
+GL_SITE= https://gitlab.torproject.org/tpo
+GL_ACCOUNT= core
+GL_TAGNAME= afe9dea542a8b495dbbbbe5e4b98a33cde06729b
+
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
+
INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
SUB_FILES= pkg-message
@@ -35,4 +40,7 @@ post-install:
check: build
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
+# known problems:
+# Fails when file fetch is attempted: Resolve destination buffer too small: https://gitlab.torproject.org/tpo/core/torsocks/-/issues/40020
+
.include <bsd.port.mk>