aboutsummaryrefslogtreecommitdiff
path: root/textproc/rasqal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/rasqal/Makefile')
-rw-r--r--textproc/rasqal/Makefile61
1 files changed, 0 insertions, 61 deletions
diff --git a/textproc/rasqal/Makefile b/textproc/rasqal/Makefile
deleted file mode 100644
index 3d7a73a3d882..000000000000
--- a/textproc/rasqal/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: redland
-# Date created: Nov 22, 2001
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= redland
-PORTVERSION= 1.0.5
-CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://librdf.org/dist/source/
-MASTER_SITE_SUBDIR= librdf
-
-MAINTAINER= chuck@pkix.net
-COMMENT= A high-level interface for RDF
-
-LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
-
-USE_BDB= yes
-INVALID_BDB_VER=2
-USE_GNOME= gnomehack gnometarget lthack pkgconfig
-USE_OPENSSL= yes
-USE_GETOPT_LONG=yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-raptor=system \
- --with-rasqal=internal \
- --with-threestore=no \
- --mandir=${PREFIX}/man
-
-USE_LDCONFIG= yes
-
-MAN1= rasqal-config.1 rdfproc.1 redland-config.1 \
- redland-db-upgrade.1 roqet.1
-MAN3= librasqal.3 redland.3
-
-OPTIONS+= MYSQL "Use MySQL instead of BDB" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql=yes
-.endif
-
-pre-everything::
- @${ECHO_CMD} "You can choose BDB version by setting WITH_BDB_VER to one off:"
- @${ECHO_CMD} "3 40 41 42 43 44 3+ 40+ 41+ 42+ 43+ 44+ (current: ${BDB_VER})"
-. if defined(WITH_MYSQL)
- @${ECHO_CMD} "MySQL version to be used: ${MYSQL_VER}"
- @${ECHO_CMD} "If you don't have MySQL installed you can stop the build now"
- @${ECHO_CMD} "and set WITH_MYSQL_VER to the desired version"
-. endif
-
-.include <bsd.port.post.mk>