aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/stardict3/Makefile')
-rw-r--r--textproc/stardict3/Makefile53
1 files changed, 0 insertions, 53 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
deleted file mode 100644
index 42522c517151..000000000000
--- a/textproc/stardict3/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# Ports collection makefile for: stardict2
-# Date created: 13 April 2003
-# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
-#
-# $FreeBSD$
-#
-
-PORTNAME= stardict
-PORTVERSION= 2.4.8
-PORTREVISION= 6
-CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DIST_SUBDIR= stardict
-
-MAINTAINER= delphij@FreeBSD.org
-COMMENT= A cross-platform and international dictionary written in Gtk2
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-USE_GMAKE= yes
-USE_BZIP2= yes
-USE_GNOME= gnomehack gnomeprefix
-USE_GETTEXT= yes
-
-OPTIONS= GNOMEUI "GNOME support" On
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_GNOMEUI)
-USE_GNOME+= libgnomeui
-GCONF_SCHEMAS= stardict.schemas
-INSTALLS_OMF= yes
-PLIST_SUB= GNOME=""
-.else
-USE_GNOME+= gtk20
-CONFIGURE_ARGS+=--disable-gnome-support --disable-schemas-install
-PLIST_SUB= GNOME="@comment not installed: "
-.endif
-
-MAN1= stardict.1
-
-post-patch:
-# gcc 2.95 does not know std::string::clear()
- @${REINPLACE_CMD} -e 's|.clear()|.erase()|' \
- ${WRKSRC}/src/docklet.cpp ${WRKSRC}/src/floatwin.cpp \
- ${WRKSRC}/src/selection.cpp
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>